v.90/USR Courier/Call Waiting

It may be a coincidence but since I flashed my two USR external analog Couriers to the v.90 code, callers calling on the two separate lines the modems are hooked up to only get a constant ringing.  Also, I found out that GTE has been upgrading our residential lines around town.    The "call waiting" call does not interupt my data session nor do I know that the call is there.  USR support has heard of other people complaining of this problem as well but has no answers.  I have even tried to reflash the modem to the old X2 codes but the same conditions exists.  Anybody know of a software or hardware fix for this?  Is it because the new call waiting makes a tone rather than the old ka-chunk sound?   These guys say they have a fix http://www.mbay.net/~rsb/index.html 
haradaAsked:
Who is Participating?
 
OttaConnect With a Mentor Commented:
When "call-waiting" is enabled, then the second caller
will(!) only hear the "ringing" sound.
When it is disabled, then the second caller will get a "busy" signal.
When "call-waiting" is enabled, then you (or your modem)
hears the "beep" to announce the second call.
When it is disabled, then there is no interruption.

The "solution" at: http://www.mbay.net/~rsb/
is a feature offered by some telephone-companies;
the second-call causes a notification to be sent across
the Internet, to your computer, where their software
will "beep" your computer, and notify you.
Then, when you hang-up the modem, the second caller
will get connected.
0
 
haradaAuthor Commented:
Everything is correct except when call waiting is enabled, the problem is that the modem nor I hears anything nor is alerted in anyway.  Prior to that, I was bumped off my data connection and the phone would ring.  This is what I am looking to accomplish again.  It appears that http://www.mbay.net/~rsb/  maybe the only solution if their product promises what they claim.
0
 
OttaCommented:
> when call waiting is enabled, the problem is that
> the modem nor I hears anything nor is alerted in anyway.

Well, the modem *does* "hear" it,
but it is just choosing to ignore it.

One of your modem's S-registers can be set
to maintain the connection after <X> amount
of time without the carrier.  Try decreasing that value,
so that any (short) loss-of-carrier is treated as a "hang-up".

Wouldn't it be easier to get a second telephone-line,
so that your "voice" line isn't always busy?
(Or, get ADSL, which can carry both "voice" and "data" at the same time, over one line.)
0
 
OttaCommented:
> when call waiting is enabled, the problem is that
> the modem nor I hears anything nor is alerted in anyway.

Well, the modem *does* "hear" it,
but it is just choosing to ignore it.

One of your modem's S-registers can be set
to maintain the connection after <X> amount
of time without the carrier.  Try decreasing that value,
so that any (short) loss-of-carrier is treated as a "hang-up".

Wouldn't it be easier to get a second telephone-line,
so that your "voice" line isn't always busy?
(Or, get ADSL, which can carry both "voice" and "data" at the same time, over one line.)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.