We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Help!!! invalid page faults

wcoyote
wcoyote asked
on
Medium Priority
196 Views
Last Modified: 2013-12-16
I have a new Pentium II 300, Asus P2B Motherboard (BX chipset), 128M SDRAM PC100 memory chip, Maxtor 7G hard drive, Mitsumi 1.44, Toshiba 32x CD, and Matrox MGA PCI video card.  No other cards are installed.  

When installing  Windows 95 OSR2.1, at the point where it normally says something like configuring items in control panel, I get an error that says "Regsrv32 performed an illegal operation."   Details said "regserv32 caused an invalid page fault in module oleaut32.dll at 0137:7ff0fd18"
I clicked ok and the install continued normally.  Then I installed the PIIX4 patch program.  The first time I tried to run the patch program, I got an error that said "Access violation at address 0041586F.  Read of address 00AB13A8."   Without doing anything else, I ran it again and it seemed to work.  Now I can't get into control panel or device manager at all.  If I right click on My Computer, I get "rundll32 caused an invalid page fault in module shell32.dll at 0137:7fddb9a0"  If I use start, settings, control panel, or double-click on control panel in My computer, I get "explorer caused an invalid page fault in module shell32.dll at 1037:7fddb9a0"

This is the 4th time trying to install 95 on this computer.  I am getting so frustrated.  I need some fresh input on this problem.    I need to get this computer working by Saturday.
Comment
Watch Question

Commented:
Only a shot in the dark
Did you try to speed down your board?
I do not know the board until now but
normaly inside the setup program there are options
to set the speed for comunicating with devices

Commented:
I agree with Norbert.  You may have to slow down your board's bus speed or disable caches to get Windows installed, then hopefully speed it back up after the install.  However, depending on the board, you may have to adjust board jumpers to adjust the bus speed.  The setup usually controls the caches.

Sometimes the board will become unstable as you bring it back to its rated speed.
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Try disabling onboard cache and set RAS to CAS and the other similar settings in your BIOS up one notch and try the installation again and let us know what happens.


Mike

Commented:
Have you checked the Ram to make sure it's good?  Try replacing the Ram with another chip or chips (try a different manufacturer if you can), and see if you still get page faults.  If not, the Ram was the problem.

Author

Commented:
I'm rejecting nbdyfool's answer because I do not have a spare chip to try.  It's rather expensive to buy another one if I'm not sure that is the problem.  I will try everyone else's suggestions and let you know how it goes.  

Please don't lock this question until I have had a chance to try things.  If someone gives a good suggestion, I'll ask them to repost as an answer.  Thanks!

Commented:
Well, I agree with nbdyfool that there is a fair chance it is bad SDRAM.  I've seen problems almost identical to this before on two other machines, and in both cases it turned out to be RAM -- which I discovered after many hours of trying other things, because I would not believe it.

Of course, it could still be something else. . . .

Author

Commented:
Norbert, please resubmit your comment as an answer so I can give you the points!  It worked!!! Yeah!!!!  :)
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
The motherboard had two choices for setting up a 300MHz chip.  100MHz with 3x multiplier, or 66MHz with 4.5x multiplier.  It wouldn't work at 100, but it worked just fine at 66.

Getting new RAM from the dealer wasn't an option unless I wanted to wait a month.  I got it at a computer swapmeet.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.