?
Solved

Virtual Hosts w/Apache 1.3, Solaris 2.5.1

Posted on 1998-07-01
4
Medium Priority
?
260 Views
Last Modified: 2013-12-16
I am upgrading from Apache 1.1.1 to 1.3.0, and I ran into a problem with the <VirtualHost> configuration.  Previously, I had the following in httpd.conf:

        <VirtualHost 128.200.149.10>
        ServerAdmin cmfao@uci.edu
        DocumentRoot /...apache_1.1.1_dir/htdocs/med
        ServerName www.com.fao.uci.edu
        ErrorLog logs/com-error_log
        TransferLog logs/com-access_log
        </VirtualHost>

and everything worked fine.

Right now, I have not removed the old server yet (I want to test the new server before putting it into production).  So, I am running the 1.3 server on port 8000.  When I tried accessing the main server page (by going to www.fao.uci.edu:8000), it kept displaying the virtualhost page.  I noticed that NameVirtualHost seems to be required now, so I tried that, but that didn't help.  Below is the section from the new httpd.conf:

        NameVirtualHost 128.200.149.10:8000

        <VirtualHost 128.200.149.10:8000>
        ServerAdmin root@azalea.fao.uci.edu
        DocumentRoot /... apache_1.3.0_dir/htdocs/
        ServerName www.fao.uci.edu
        ErrorLog logs/error_log
        TransferLog logs/access_log
        </VirtualHost>
       
        <VirtualHost 128.200.149.10:8000>
        ServerAdmin cmfao@uci.edu
        DocumentRoot /... apache_1.3.0_dir/htdocs/med
        ServerName www.com.fao.uci.edu
        ErrorLog logs/com-error_log
        TransferLog logs/com-access_log
        </VirtualHost>

Any suggestions?
0
Comment
Question by:cokeman_
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 

Accepted Solution

by:
beacker earned 200 total points
ID: 1812273
You need to add the following Listen directive before the
applicable VirtualHost directive:

Listen 128.200.149.10:8000

<VirtualHost 128.200.149.10:8000>

Brad
0
 

Author Comment

by:cokeman_
ID: 1812274
When I put the server into production (ie, remove the references to port 8000 and let it run off of port 80), would I still need the Listen directive?
0
 

Expert Comment

by:beacker
ID: 1812275
You will either need to leave the Listen in place, or use the
Bind directive to let httpd know which addresses to work with.

0
 

Author Comment

by:cokeman_
ID: 1812276
muchas gracias
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let's say you need to move the data of a file system from one partition to another. This generally involves dismounting the file system, backing it up to tapes, and restoring it to a new partition. You may also copy the file system from one place to…
This tech tip describes how to install the Solaris Operating System from a tape backup that was created using the Solaris flash archive utility. I have used this procedure on the Solaris 8 and 9 OS, and it shoudl also work well on the Solaris 10 rel…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question