Solved

Assigning Drive letters to a new HDD

Posted on 1998-07-07
18
219 Views
Last Modified: 2010-04-27
I'm trying to set up the second hard drive to my system, It's the first time I've ever done this.
I've gotten the system to indentify the drive, although it sees it as only half of it's actual capacity, but I cannot access the drive.
How do I assign a new drive letter to the second hard drive?
How do I get the system to accept the real size of the drive?
0
Comment
Question by:Flibit
  • 4
  • 4
  • 2
  • +8
18 Comments
 

Expert Comment

by:jilang
ID: 1137021
Some quick help:  drive letters are assigned at boot time; the first IDE hard drive is C:, and second partitions on the first drive get D:, etc.; the second IDE hard drive gets whatever follows.  SCSI hard drives follow the IDE hard drives in drive letters.
In order to anwer your question, though, it would be helpful to know which part of the system only sees half of the drive's capacity.  E.g., is it in fdisk?  Is it through Explorer?  Also, have you formatted the drive?
0
 

Expert Comment

by:victorso
ID: 1137022
When you add a new harddisk, the mainboard will auto detect it, but you should use fdisk
to fix the size of harddisk and then format the disk for using.
After that, I think you can use your drive and get the drive letter after fdisk.
Are your drive large than 2.1G? if yes , you should use fdisk to fix the harddisk into two or more drives that depend on size o fdrive.
Or if you use Win95 osr2 or above, you can fix it in a drive as using format.

fdisk is fdisk.exe
0
 
LVL 5

Expert Comment

by:tuvi
ID: 1137023
Actually, the first partition on the first drive is C, the first partition on the second drive is drive D, then alphabetically all the other partitions of the first drive follow by all the other partitions of the second drive. If your hard drive is greater than 2.1G and your BIOS is of older version, the BIOS may not identify your hard drive correctly. That's OK. You still can use FDISK to partition and format the drive. But if you don't have the Win95 OSR2 or above, you have to divide your partitions into smaller chunks of 2.1G or less just like Victorso said.
0
 
LVL 2

Expert Comment

by:harley47
ID: 1137024
if the bios does not see the drive at its full capacity then you need to use a bios overlay like EZ drive from western digital.  if the bios does see the drive then you need to fdisk it with a primary partition then a extended partition( i'm asumming you are using win95a) then you create the logical drives in the extended partition.  
0
 

Author Comment

by:Flibit
ID: 1137025
Here is an update.
The drive is formated and the motherboard has auto detected it, but it is still showing as only 2.1 GB.
I haven't tried fdisk yet because there appears to be a boot sector virus I need to clen first.
The issue now is that yes I do have an older BIOS that will not accept more than 2.1 GB hard drives.
I have a odd brand of motherboard and will need to find out what it is before I can ugrade the BIOS.
Thank you all for your input.
0
 
LVL 5

Expert Comment

by:tuvi
ID: 1137026
Try fdisk/mbr to clean out boot sector virus. Also, even your BIOS does not identify your drive correctly, you may still use fdisk to partition your drive.
0
 

Author Comment

by:Flibit
ID: 1137027
Tuvi,
Can you provide me with specific instruction as to how I can do this with fdisk.
Otherwise I'm going to have to upgrade the Bios, and I'm not looking forward to doing that.
0
 
LVL 5

Expert Comment

by:tuvi
ID: 1137028
Flibit,
It depends on what operating system you have. If you have Win95 OSR2, then go ahead use fdisk to do it. fdisk will certainly recognize your hard drive capacity.
If you have the old DOS or Win95, then you have to divide your hard drive into smaller partition of 2.1G or less. First create a primary partition, when asked whether you want to use all, answer no; then enter the appropriate size. Then create the extended partition. That's simple. But remember to clean the boot sector virus first. If you don't have an antivirus software, try fdisk/mbr first. (fdisk/mbr may not clean your boot sector, but you can try).
I hope this is clear to you.
Final note: you have to use a boot floppy with fdisk on it and boot your computer with the floppy.
0
 
LVL 2

Expert Comment

by:harley47
ID: 1137029
what brand of hard drive is it and what size?  is the bios only seeing it at half of its size?  if so you don't have to upgrade your bios just use a bios overlay.  why do you think theres a boot sector virus?
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Expert Comment

by:mikkie
ID: 1137030
I believe older bios's are unable to correctly handle a drive over 1024 cyl. thou you set it up in bios incorrectly, I believe the drive is being set up as a smaller drive through sector translation. and when you partition it with fdisk no matter
how many partitions the total drive space is limited to bios's
size. I would use an overlay such as disk manager at least ver
7.06 or above.
0
 
LVL 5

Expert Comment

by:tuvi
ID: 1137031
Mikkie is almost right. But if your BIOS can support LBA mode, then fdisk will handle your drive properly. Otherwise, use an overlay manager.
0
 
LVL 12

Expert Comment

by:Otta
ID: 1137032
VICTORSO is probably correct.
DOS (and the "retail" version of Windows 95)
have a limitation of 65536 (2**16) clusters,
using 64 sectors (at 512 bytes each) per cluster,
which is exactly 2GB.
Other file-systems (VFAT, HPFS, NTFS) remove the limitation
of a maximum of 65536 clusters, so that the entire disk
can be allocated.
HPFS is used by IBM's OS/2 Warp, and by Windows NT 3.5.
NTFS is used by Windows NT 4.
VFAT is part of the "OSR2" release of Windows 95,
which shipped only with new PCs.

So, you may need to use FDISK to create a 2GB "primary" partition,
and create an "extended" partition,
and create one (or more) "logical" drives inside the "extended" partition.
0
 
LVL 2

Expert Comment

by:nebworth
ID: 1137033
 If it's a Packar Bell with a Hillary BIOS, upgrade the BIOS.  Probably not, though.  Probably a FAT16 limitation. Either go out and get Windows98, which installs as an upgrade, AND has a nifty FAT32 converter for existing disks, or create a Primary Dos Partition as 2.1 and an extended DOS partition as 2.1 with a Logical drive that fills the whole partition.
0
 

Author Comment

by:Flibit
ID: 1137034
Let me give my system info, so that no one has to make a guess as to what I'm dealing with here.
120mhz pentium CPU
MicroStar TR5 mainboard, AMI Bios (does not support drives larger than 2.1 GB)
#1 drive is a Seagate 1.3 GB
New drive is a Fujitsu 4.3 GB

I tried the fdisk option, no dice.
I've got the Fujitsu Disk Manager software, but Fujitsu recommends not using it, which doesn't make feel better about it.
Yes nebworth, I'm stuck with a FAT16 limitation, and no I don't need anymore of Bill's bugware.
If you know where I can get another FAT32 converter, that may be the way to go.
Thanx again to everyone for your input.
0
 
LVL 1

Expert Comment

by:kmarf
ID: 1137035
what did fdisk tell you?  Wouldn't see the rest of the drive at all?  Is the disk configured in bios according to specs on drive?
0
 
LVL 2

Expert Comment

by:datn
ID: 1137036
Get Partition Magic 3.0 if you need a Fat16  to Fat32 converter without losing any data. What has sometimes worked for me is to make the new larger hard drive be drive C. Some older motherboards can still correctly detect only one large hard drive, as long as it is the master on the primary IDE.
0
 

Author Comment

by:Flibit
ID: 1137037
I finally got it working.
A suggestion from the Fujitsu site solved the problem.
I simply switched the CD Rom to the secondary IDE, and placed the new drive as a slave on the primary IDE.
After that the bios had no trouble detecting the drive correctly.
A quick install of Disk Manager, and I'm all done.
Thanx to everyone, it was a great learning experience.
0
 
LVL 10

Accepted Solution

by:
MasseyM earned 200 total points
ID: 1137038
Make sure you read the manual that came with the new hard drive and set the "jumpers" correctly.  You will need to make one drive a slave and the other a master (The master is C and usually has the OS on it).  This will solve any problems with incompatibility.  Also, when your computer boots up, and option to enter setup become avaliable (possibly F1, CTRL+ALT+S, etc...)  Choose this and verify that the HD is properly defined according to the specs in the new manual...

- Matt
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Suggested Solutions

this article is a guided solution for most of the common server issues in server hardware tasks we are facing in our routine job works. the topics in the following article covered are, 1) dell hardware raidlevel (Perc) 2) adding HDD 3) how t…
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now