Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 275
  • Last Modified:

Alowing anonymous uploads via IIS

Does anyone know what I can to to alow users to upload files to my IIS-server via the Web using Microsoft Posting Acceptor without displaying a username/passwd box....

0
lulle
Asked:
lulle
  • 6
  • 4
1 Solution
 
sybeCommented:
Have you tried giving Add & Read rights to IUSR_.... on the directory.
0
 
lulleAuthor Commented:
Yupp.. done that.... IIE dosen´t allow a IUSR_.... without a password..
0
 
phillydeeCommented:
You need to go into the MMC and with the IIS snap in loaded
go in to your website properties by right clicking.

Once there you need to set it so you have

Allow anonymouse connections and configure that with the IUSER account you have mentioned. Now you need to set "Allow ONLY anonymous connections"

Make sure you have at least write permission for the anonymous account as you have said above.

This should work fine.  If you want to allow specific user access to other parts of your website, do the same as above but instead of right clicking on your website root, find the page or directory you wish and make the changes.  That way only the current selection will have those properties and not the whole website, since it is a hierarchical approach.

Hope this helps.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
lulleAuthor Commented:
Well.. I could only change the premmisssions for the root dir.. I need to be able to change them in this speciffic web..
0
 
phillydeeCommented:
You may need to double click on your root dir top expand it out.  Then you can apply the permissions changes to individual directories

It is important that you also allow the same permissions on the area where you intend people to access.


0
 
lulleAuthor Commented:
Tried that one to...didn´t work..  
0
 
phillydeeCommented:
What did you try exactly?

double clicking on the website to expand it?

What happened?
0
 
phillydeeCommented:
What did you try exactly?

double clicking on the website to expand it?

What happened?
0
 
phillydeeCommented:
What have you got your authentication method set as?

What have you got your anonymous settings set to?
0
 
lulleAuthor Commented:
oops..sorry.. got it now... answer again if u want the points..
0
 
phillydeeCommented:
You may need to double click on your root dir top expand it out.  Then you can apply the permissions changes to individual directories

It is important that you also allow the same permissions on the area where you intend people to access.


Glad I could help.


Cheers

Phil
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now