2 a: and b: drives

i have two floppy drives (a:=3.5 floppy and b:=5.25 floppy), a partitioned hard drive (c: and d:) and a cd-rom=e:.  for some reason my computer has added an f: and g: drive which really happens to be my a: and b: drives. However, now my a: and b: do not work.  My f: is my a: and my g: is my b:.  If I try to use a or b it freezes the computer.  i've tried deleting the floppy disk drive "drivers" for f and g from device manager in safe-mode but it comes back when i reboot....any help??
bigtj42Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
RWlodarczykConnect With a Mentor Commented:
Solution:

1. Right click on "My Computer" and click on "Properties"
2. Click on "Device Manager" tab
3. Click on the (+) next to "Disk Drives"
4. Right click on one of the floppy disk drives
5. There click on the middle tab, and you should see the drive letter setting.

Do this until you find the floppy drive that take drive letter F or G. Delete both of these drives... everythign should now work.

Rob.
0
 
bigtj42Author Commented:
Edited text of question
0
 
shalbeCommented:
bigtj42,

Wow. That's weird.

What happens when you boot to a DOS prompt only. Do not go into Windows.

Turn off your computer (cold boot). Turn it on and press F8 when it says Starting Windows. Select Command prompt only from the menu.

See what drive assignments your floppy drives have then.  Let us know what you find.

Steve
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
vxCommented:
Maybe you should remove the floppy drives from the devicemanager menu, reboot and reinstall them. See if it helps.

Ties
0
 
waynebCommented:
Are you using some kind of drvspace ?  And have you scanned your system for viruses ?
0
 
bigtj42Author Commented:
TO SHALBE:
WHEN I START WINDOWS AND DO "COMMAND PROMPT ONLY" MY A: DRIVE SHOWS AS MY A: DRIVE AND THERE IS NO F: OR G: DRIVES.  IT MUST BE A WINDOWS CONFLICT.

TO WAYNE B:
I AM USING MACAFEE VIRUS DETECTION. I AM NOT USING DRVSPACE.

TO VX:
I WILL TRY THAT AND LET YOU KNOW.

0
 
datnCommented:
It sounds like your settings for the 3.5 and 5.25 are not set correctly. You will get sporadic occurrences when they are not set and terminated correctly.
If using a twist cable, make sure both drives are set to the second DS position, usually labeled DS1. Also, make sure that the end drive is terminated. I have a similar setup with the 3.5 being the end drive, which is A. The 5.25 is in the middle of the cable using the edge connector and needs its termination removed (all of them come terminated as standard).
If using a straight cable, set the jumpers on the 3.5 floppy DS0 and the 5.25 DS1.
0
 
Thunder041398Commented:
The problem is not in the hardware, but in the "Plug and Pray" softare you are using...

Something like that happened to me.... I had a 3.5 floppy (a:) and a 5.25 floppy (b:). I took out the 5.25 floppy and Windows reported to me that I had that 3.5 drive and the 5.25 floppy... niether floppy worked, nor the real one nor the imaginary.

I tried everything... deleting the drives, changing options in BIOS, adding another floppy in the "add hardware" option and none worked.

When I upgraded to Windows98 the problem disapeared...

I can recommend you to reinsall Windows or upgrading... but first try other posibilities. This is the last resource...  
0
 
patedmCommented:
Were the phantom drive letters always there?  When did they first appear?
0
 
chris99Commented:
Make sure 'removable' is checked in the control panel/ device manager/disk drives/floppies/properties

if it isn't, drive allocation under windows can go screwy !
0
 
mkdjoCommented:
Maybe you mapped your drives without knowing that? If you go to explorer, right mouse click and choose properties. If you have the possibility to disconnect, do this.
0
 
nathanwCommented:
I think you nearly had it when you tried booting into safe mode and removed the drives from the device manager.  But the problem would be that windows wanted them to be there.  When you started up into normal mode, it detected that you had removed the drives, and put them back.  A: and B: were already taken so it was stuck with F: and G:

What you need to do is boot into safe mode, and remove ALL floppy drives, not just the wrong ones.  When you boot again, it will restore the drives, this time to A: and B:

PS:  the same can happen with all devices.
0
 
bigtj42Author Commented:
I TRIED REMOVING THE TWO DRIVES AND WHEN IT REBOOTS IT ADDS ALL FOUR AGAIN.  MY CABLES ARE SETUP CORRECTLY, SO THAT WASN'T IT.  I DON'T KNOW HOW TO SEE IF I "MAPPED" THEM WRONG (PLEASE LET ME KNOW).  REALLY, SAFE MODE IS THE ONLY WAY IT WORKS.....CAN I TRANSFER MY "PREFERENCES" TO BE THE SAME AS IN "NORMAL" MODE?
ALSO...IT NOW SAYS THAT "A" AND "B" DRIVES ARE IN MS-DOS COMPATABILITY MODE........
0
 
mkdjoCommented:
Have you installed a program, when this problem started. With mapped I meant, right mouseclick f.\ in your windows explorer, and look if there is the possibility to disconnect. But now I don't think this is your problem. Do you load any floppy drivers? Can you please post your config.sys and autoexec.bat. Try this: Connect only the 3.5" floppy and remove the drivers again. Boot again and look how it works. Do the same with the other floppy. Does one version work proper?
 
0
 
datnCommented:
Did this setup ever work before? If you recently installed the hardware, I still suggest to check the jumpers! Having two 3.5" floppies are easy since the majority of them are auto terminating and work fine. 5.25" floppies are not so simple and must be manually adjusted. You said you have looked at the cables, OK. But, again, check your jumpers!
Several months ago, I put an old 5.25" floppy with my 3.5" floppy. It workd fine, until a few days later when it started to give me problems exactly like you are describing.
1. Fix the jumpers.
2. Check BIOS info for correct hardware, 720K vs 1.2MB 5.25".
3. Delete all floppy info in Device Manager.
3. Restart computer and let it autodetect new setup.
0
 
bigtj42Author Commented:
IN RESPONSE TO MKDJO :I TRIED TO DISCONNECT MY CABLE FOR ONE, DELETE THE DRIVERS, AND REBOOT.  IT DIDN'T WORK FOR EITHER A: OR B: (3.5 OR 5.25). I CANNOT CHANGE THE MAPPING.  IT SAYS F: AND G:. IT IS DEFINATELY A WINDOWS PROBLEM....BECAUSE IN "TRUE" DOS IT'S A: AND B: (NO F: AND G: EXISTS)....BUT IF I GO TO "WINDOWS DOS PROMPT"..IT'S F: AND G: (A: OR B: LOCKS UP THE SYSTEM.  I AM GOING TO TRY TO REINSTALL WINDOWS.

ANY OTHER SUGGESTIONS PLEASE LET ME KNOW....THANKS
0
 
harley47Commented:
try to reset the bios.  there should be a jumper on you motherboard that disables the bios battery,  set this jumper and leave it for about 30 seconds.  Then set it back and restart your computer.  After this you will need to enter the bois and setup the 5 1/4 drive again.


hope this helps
bill
0
 
engeltjeCommented:
Try to boot windows itself in safe mode. When the drives show correcly.
Be carefull with resetting the BIOS. I don't think this causes the error, booting to command mode wouldn't show the drives right...

0
 
vxCommented:
Do you have 2 floppy controllers in Windows as well?
0
 
gravityCommented:
Don't forget that regardless of setup, drives a: and b: are automatically reserved for floppy drives.
0
 
rubleCommented:
What type of mother board do you have?
Is there an I/O card with drive controller installed in machine?
Was this machine on a network?
Please add more info.
0
 
bigtj42Author Commented:
I DID NOT TRY THE LAST ANSWER.  I HAD ALREADY REINSTALLED WINDOWS AND IT FIXED MY PROBLEM.  THANKS FOR EVERYONE'S HELP.TB
0
 
harley47Commented:
If you didn't try the last answer why did you accept it?  You gave your points away for nothing
0
 
bigtj42Author Commented:
I DIDN'T KNOW IF IT WOULD WORK OR NOT....I DIDN'T KNOW I COULD "NOT ACCEPT" THE ANSWER......
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.