Solved

pppd used to work, now doesn't

Posted on 1998-07-11
6
273 Views
Last Modified: 2010-03-18
I broke something.  PPP to my ISP used to work fine.  I had a dialup script that started pppd, chatted with the modem and sent/recieved stuff for the login menu perfectly.  Then one day, I decide to go an change my home computer host names around and now pppd won't work.  I use RH 5.0 and used its network configurator to change my host name.  I also removed the domain name since, I figured that it was just a small home network, I didn't need a home name - so now my computers are just known by a single name, rather than name.home, name2.home, etc.  How do I know that its not PPPd itself?  Because pppd still works for my connection to work(which I am currently using and is incredibly sloooow)

My script does all the transactions properly such as sending the name/passwd/menu options, pppd starts but doesn't seem to 'take hold' and just quits...usually leaving my modem connected.  ifconfig never shows a ppp0 interface.  My ISP delivers dynamic addresses.

I am wondering what I can do to debug this problem since its getting the best of me.  Not only does my script not work anymore, but neither does RH's autoPPP utility or KDE's ppp program.  I have a suspicion that something is awry with the routing, but I have not the knowledge to know where to begin looking.

I have a couple hundred points, so if anyone wants to work with me on this, I'd seriously appreciate it as well as learn something in the process.  Let me know which config files to send and which program output to send.

Thanks a bunch!!!.
0
Comment
Question by:racy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 2

Accepted Solution

by:
alexbik earned 200 total points
ID: 1584776
Hi,

First of all, it is a _very_ bad idea not to define a domainname. I can't see what the
disadvantage is of using one, since your machine itself will allways listen to 'hostname' without the domainname if you defined it in /etc/hosts or if you include your local domain in /etc/resolv.conf. The problem with PPP might be that you either use the wrong login name (could it be that your old hostname was equal to the loginname you used to login to your ISP?) or that you use the wron password (this could be caused by changing your hostname as well). Take a look at /etc/ppp/pap-secrets and if your hostname differs from the login you have to use, make sure you use the user <u> command line option to override this (see man pppd for details).

Alex.
0
 

Author Comment

by:racy
ID: 1584777
Okay, this brings on a few more questions.  

First, I didn't think I needed to muck with /etc/ppp/pap-secrets since I am not using pap...the login method of my ISP is a menu that I go thru: Enter name, enter passwd, selct '1' for ppp. This is/was scripted using chat.  Why would I still need an entry in the /etc/ppp/pap-secrets file?

Also, the reason I chose to rid the domain name from my home LAN is that I simply didn't know what was legal...can I call it anything I want, such as 'home.com' or 'home.org', with the hosts being 'comp1.home.org', etc?  Obviously, I need to re-read up on DNS, but here's the problem that I don't understand:

I use one computer to dialup ppp via modem...this same computer also has an ethernet adapter.  If I want to ping say comp2.home.org, what is preventing it from looking over the internet via the ppp connection to find a comp2.home.org?

Thanks again for your knowledge and patience ;)

0
 
LVL 2

Expert Comment

by:jprohart
ID: 1584778
you must setup routes.
If your local domain is something.com, add an entry in /etc/networks with
x.x.x.0  something.com
then add a route to your local domain
route add -net something.com eth0
(but this is made implicitly with the network on which your NIC is configured)
if your box doesn't know the network you call, it'll use the default route, which must be on your calling device.

ex:
your NIC is 192.0.2.34
you must have a route on 192.0.2.0
(route add -net 192.0.2.0 eth0)
if you use a router or another box to access to 200.1.1.0, add a route to this network on eth0:
route add -net 200.1.1.0 gw the_address_of_the_gateway\
on_your_local_network

put your default route on your ppp device

But you can also look at the FAQs.
0
Create CentOS 7 Newton Packstack Running Keystone

A bug was filed against RDO for the installation of Keystone v3. This guide is designed to walk you through the configuration for using Keystone v3 with Packstack. You will accomplish this using various repos and the Answers file.

 
LVL 1

Expert Comment

by:m4rc
ID: 1584779
as for routing,  i the script i use to connect also automatically sets the ppp connection as the default route.  but since you will have home.org,  or rather, comp2.home.org, specifically set up, it will find your computer, on your lan, first, because in
/etc/host.conf you can tell the computer what to check first, the DNS (prob your isp's DNS ) or your /etc/hosts file (which will contain a address for comp2).

does that make sense?  

for instance, i use marc.com on my lan.  so i cant connect to the www.marc.com on the internet using its name, i have to use its ip (www.marc.com has address 208.221.206.22) to connect from my lan.  

0
 

Author Comment

by:racy
ID: 1584780
Thanks to all of you.  Not only did I fix my problem, but my understanding of the situation is better.

I am not sure how this point scheme works, since it has never worked very well on this site.  I guess the points are distributed?

Thanks again ;)

0
 
LVL 1

Expert Comment

by:m4rc
ID: 1584781
hehe.  fyi, no, all the points go to alex, cuz it was his answer u agreed to.  i guess EA doesnt have a system of splitting credit...

m

0

Featured Post

WordPress Tutorial 1: Installation & Setup

WordPress is a very popular option for running your web site and can be used to get your content online quickly for the world to see. This guide will walk you through installing the WordPress server software and the initial setup process.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question