Solved

FDC (floppy disk controller) error on bootup...

Posted on 1998-07-14
12
834 Views
Last Modified: 2013-12-29
When I turn on my computer, a message comes up saying 'FDC ERROR   F1 to continue'. This is only happenning since I put in an expansion card, however with a different motherboard it worked fine, even with the expansion card. If I take out the expansion card the error goes (but I need the card) and if I try and access the Floppy drive from windows the computer stops responding. There is no fault with the floppy drive itself, and there are no  conflicts registering in the system control panel. HELP! what do I do? (PS the new motherboard is an older TX pro)
0
Comment
Question by:TimJ
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 1

Expert Comment

by:bravado042997
ID: 1717531
Hi Tim, need some more info, like what is the expansion card?

But it just could be that if the expansion card handles floppy drives then perhaps it and that motherboard are at war, try disabling floppy on the expansion card.
0
 

Expert Comment

by:patedm
ID: 1717532
Expansion card? That could describe a LOT of cards. What exactly do you mean by "expansion card"?
0
 
LVL 2

Expert Comment

by:SirCaleb
ID: 1717533
Bravado is completely right!  If that is an IDE controller card, you've got a major conflict [war] between the onboard FDC and the expansion card's FDC.  I'm assuming that this is what you have, so if it this will save you some waiting time...look on your expansion card, look for the jumper that disables the Floppy disk controller [FDC].  You should have gotten some documentation labeling the jumpers.  Basically I am just seconding everything that Bravado stated.  :-)  Give him credit.
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 

Expert Comment

by:RayK
ID: 1717534
I know it seems stupid but I have to ask... did you double check you cable for your drive so your red stripe (indicating pin1) is in the correct position?
0
 

Author Comment

by:TimJ
ID: 1717535
Yes, the cable is definitely in the right place, I have checked all the cabling thoroughly.
I do not know the exact type of the card, but it has 2 com ports 1 parallel 1 game port 2 IDE ports and one Floppy drive port.
I will see if it is possible to disable it.
0
 
LVL 1

Expert Comment

by:durcaj01
ID: 1717536
Damn, if only I had got here sooner! bravado deserves all the credit. You definately have an I/O CARD. This is what was very common in older computers to control all the periferal devices such as printer etc. You say you must have the card. Do you mean 'must' as in you need to have a game port? If so, your better of getting a dedicated Game controller. Not a lot of cash involved in the purchase of one.
0
 
LVL 7

Expert Comment

by:rin1010
ID: 1717537

  If you absolutely must use that card, try plugging your floppy drive into the card's floppy drive port and run it that way. Be sure to disable (set to "none")  the onboard fdc in your BIOS setup, if that's what it has.

  I'm still not clear as to why you need that (presumably isa?) controller card, but if so, using its fdc might work for you...
 
0
 
LVL 1

Expert Comment

by:johncook
ID: 1717538
bravado and SirCaleb are absolutely correct.... disable the FDC on the Multi-I/O card and you will have no more probs.


John C. Cook
0
 
LVL 2

Expert Comment

by:SirCaleb
ID: 1717539
bravado...claim your prize  :-)
0
 
LVL 2

Expert Comment

by:SirCaleb
ID: 1717540
bravado...claim your prize  :-)
0
 
LVL 1

Expert Comment

by:johncook
ID: 1717541
For the sake of clarity,
Your motherboardhas an integrated IDE controller built into it. This will include a floppy drive controller.
You must either:
1. disable the integrated FDC port... should be able to be done through the CMOS.
2. Disable the port on the Multi-I/O card you are using. By jumpers on the board.

Yea I know i am repeating myself and others...but I wanted to make it more concise.

John C. Cook

0
 

Accepted Solution

by:
sfurr earned 50 total points
ID: 1717542
I would check and make sure that the floppy drive is disabled in the BIOS because most controller card don't like it when the motherboard is trying to access the device at the same time as the controller card.  Controller cards have their own BIOS and depending on the card you might have to alter differant BIOS settings.  If this doesn't work I would try leaving the card in and running the floppy drive off of the motherboard while leaving your hard drives on the card.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Determining the an SCCM package name from the Package ID
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
As developers, we are not limited to the functions provided by the VBA language. In addition, we can call the functions that are part of the Windows operating system. These functions are part of the Windows API (Application Programming Interface). U…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question