Solved

Losing access to lpt1

Posted on 1998-07-14
3
639 Views
Last Modified: 2013-12-23
I have a client who has NT 4.0 workstations and a Novell 3.12 server with several print queues.  They are using the Novell Intranetware client.  The workstations are also part of an NT domain.  Some of the workstations have a local printer.  They have a DOS app that will only print to lpt1.  I can use a net use lpt1 command to redirect to the network printers.  However, when I issue a net use lpt1 /delete to switch printing to the local printer I lose access to lpt1.  I get a message that the device prn is not available.  

I have found that if I issue a net stop spooler and a net start spooler command I regain access to lpt1.  However, it appears that the users must be domain admins to start and stop spooler.  I have tried using policy/user rights for both the individual workstations and the domain to give them this right.  However, I can give all rights and they still cannot start and stop the service.
0
Comment
Question by:dtarkir
  • 2
3 Comments
 
LVL 1

Expert Comment

by:phillydee
ID: 1568149
As a troubleshooting measure can you try sharing the printer you have installed locally on yourComputer and then doing

net use lpt1: \\yourComputer\printer1

test printing to lpt1

and then net use lpt1: /d

test printing again

Another way of solving the problem is to make the users members of the print operators group.  This may allow the users to stop and start the spooler service.


0
 
LVL 1

Author Comment

by:dtarkir
ID: 1568150
Sharing the printer and then deleting it seems to work.  What is interesting about it is that you can't print to it untill you do the net use lpt1 /d.  If you try to print after the net use the spooler just churns the system.

I will try the second option next week when I am back at the site.

Change your comment to a question and then I can award points.

Thanks

0
 
LVL 1

Accepted Solution

by:
phillydee earned 100 total points
ID: 1568151
As a troubleshooting measure can you try sharing the printer you have installed locally on yourComputer and then doing

net use lpt1: \\yourComputer\printer1

test printing to lpt1

and then net use lpt1: /d

test printing again

Another way of solving the problem is to make the users members of the print operators group.  This may allow the users to stop and start the spooler service.


Thank you very much and let me know how you get on.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Nslookup is a command line driven utility supplied as part of most Windows operating systems that can reveal information related to domain names and the Internet Protocol (IP) addresses associated with them. In simple terms, it is a tool that can …
Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question