• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 343
  • Last Modified:

CD Stuck?

I am running a Sun ultra 30, and I stuck a music cd in the drive and nothing is working, it will not play the disc, eject the disk. I'm not sure if it is mounted or not?  When I go into file manager it shows that there is a cdrom directory and a cdrom0 directory but in the file /etc/vfstab and the mnttab file I'm not sure which of the lines are for the cdrom if any? Any ideas would be great! thanks
0
bcarder
Asked:
bcarder
1 Solution
 
n0thingCommented:
If you want to play the CD, you'll need some software like "xmcd", otherwise it won't play just like that. To eject the disk, just logon as root and issue the command "eject". The cdrom won't be in /etc/vfstab, since it's not a permanent mount point. It will just mount the CD automaticaly when you insert a new CD in.

Regards,
Minh Lai
0
 
bcarderAuthor Commented:
I tried "eject cdrom" & "eject /dev/dsk/c0t0d0s0" and neither would work. When I tried the latter it told me that the floppy or cd was busy and to use the former, but with no success. Any other ideas.
0
 
bcarderAuthor Commented:
I read in a solaris book that you could use something called workman to listen to regular cd, but I don't think that I have that.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
n0thingCommented:
The "eject" alone doesn't work ?? Or try "eject -f cd" ??
0
 
bcarderAuthor Commented:
I got "cdrom0: No such file or directory".  I forgot to mention that I'm running under CDE ver1.0 or ver 1.1 I think. but all of the commands and buttons that I've found on the desktop will not open the cd.  Thanks for your help.
0
 
bcarderAuthor Commented:
I got it out finally. I turned the power off and after I turned it back on and while it was scanning the disk I jit the manual eject and it came out.  Thanks for your help.
0
 
blowfishCommented:
To eject a CD on Solaris, login as root and type eject.  

You got "device busy" because there was a process running that had issued a cd to one of the directories on the cd-rom (file manager maybe?).  You cannot unmount a filesystem if a user or process is using a file or is currently working in a directory on that filesystem.

Also, if you have problems ejecting a CD it may be because Volume Management is confused (again...).  Look for the process called vold, ie.:

  ps -ef | egrep vold)

If it's running kill it and try the eject again.  Another way is to run the Volume Management start/stop script with the stop argument, like so;

  /etc/init.d/volmgt stop

Volume Management gets started each time you reboot.  To permanantly disable it rename the link to the start/stop script in /etc/rc2.d like so:

  mv /etc/rc2.d/S92volmgt /etc/rc2.d/s92volmgt

(Note the change from upper-case "S" to lower-case "s")

--cheers
0
 
jlmsCommented:
Then award the points or ask managment to delete it so we don't come here any more ...
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now