We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Installed accelerator card and lost CDROM.

rhyma
rhyma asked
on
Medium Priority
342 Views
Last Modified: 2010-04-27
I installed an Iomega Ditto Dash accelerator card to improve the performance of my Ditto Dash backup tape drive.

Now, when I try to run my CDROM I get the following message:

"F:\ is not accessible. ["F" is my CDROM drive.]
A device attached to the system is not functioning."

FYI, my Ditto tape backup no longer works either, but I think if I can run the Setup program via the CDROM, it'll be OK. (Or at least that's my plan.)

BTW, I'm running Win'95 on a home built PC.

Thanks.
Comment
Watch Question

Author

Commented:
Edited text of question

Commented:
try opening the device manage by right clicking the right mouse button on the "my computer" icon, and se if there is a confilct with you CD-ROM

Author

Commented:
skarj

Although a "yellow conflict symbol" DOES appear next to the Ditto Accelerator, I can't see any conflict re I/O, DMA, or IRQ.

FYI, the Device Manager indicates that the CDROM is working properly.

Commented:
I use a Ditto without the accellerator. Please list the Device Manager settings in their entirity, along with those for your CD-ROM drive, and we should be able to resolve the issue.
CERTIFIED EXPERT

Commented:
Try the following:
Put the line "DEVICE=cdrom-driver /d:OEMCD001" in your config.sys where cdrom-driver = the .sys cdromdriver with full path, usualy located in the root directory.
Put MSCDEX /D:OEMCD001 in your autoexec.bat.
Reboot the system.
You must see the CDROM for now, but it is in 16 bit dos-mode.
Install the Ditto soft, so that no conflicts exist anymore.
Remove the CD-ROM line in your autoexec.bat. You can leave the line in Config.sys.
Reboot again.
Successfull ? See the CD again ?

CU
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
What is listed under the resource tab in the device manager for the Accelerator card? There should be a device showing up in the box underneath that is telling you what device is conflicting.

Mike
Are you using the Flash!File program from Iomega?  If so, uninstall the Ditto Tools and reinstall without the Flash!File.  Iomega admits that there is a problem with Flash!File conflicting with the Ditto Tools.

Check out http://www.iomega.com/support/techs/ditto/catalog7.html to see if there is an answer there.

Good Luck,

Scott

Author

Commented:
engeltje

Did as you suggested. However, I had the same problem as before ... in Windows.

However, I was able to access the CDROM in DOS, and attempted to reinstall the Ditto tape backup software. But it couldn't find the accelerator, and so I'm back to square one.

In short, Device Manager indicates a conflict, but I can't find it and can't run a backup.

Author

Commented:
mikecr

In Device Manager, under "Tape Drive Controllers" are listed the tape accelerator card and the Ditto Dash tape backup, with the conflict symbol on the latter.

However, no conflict is indicated in the "Resources box" (for either)... which is the thing that's making me nuts.

Author

Commented:
semontgomery

No, I'm not using Flash!File.

But even if I was, and wanted to reinstall the Ditto Dash software, I couldn't. (I can't access the CDROM.)

Commented:
try to remove both the ditto accelerator and the cdrom from the deice manager and let windows detect the cd-drive by itself..

mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Check the resources it's using and go into the other installed components on your system and check their resources also. See if anything comes close to being a problem. Check addresses and IRQ's thoroughly. If nothing comes up, then see if you can find the most up to software for the card. I, by accident, installed the wrong software on a computer when I was installing a Ditto drive. I installed the 2gb software but was using the 3.5 Ditto drive which had a version 3.01 software compared to the 2.6 I believe that was being used by the 2gb Ditto drive. The 3gb drive came with an accelerator card also which wouldn't work until I installed the proper software. You may want to check at Ditto's website to make sure that you have the most up to date drivers.

Mike

Author

Commented:
skarj

I removed both via Device Manager and Windows didn't detect the CDROM.

Author

Commented:
mikecr

<You may want to check at Ditto's website to make sure that you have the most up to date drivers.<

Mike, no drivers came with the card, and there's no reference to drivers at the Iomega Ditto site.

BTW, no conflicts are indicated. I even ran MSD at the C Prompt, and saw nothing.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
You may want to reconsider using the Dash card anyway, like I did. If you use the Dash card it's 16bit compared to plugging into the Floppy controller cable which is connected to a PCI slot. You would get increased performance from the PCI slot compared to the card.
Just a thought.

Mike

Author

Commented:
mikecr

<<You may want to reconsider using the Dash card anyway, like I did<<

Mike,

Are you saying you tried the Dash card and found that running off the floppy was faster?

BTW, how is the floppy controller cable attached to the PCI slot? (I don't get ... on my mb, it's attached to a special FDD socket.)

Please explain.
Thanks
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
If you have built in IDE for hard drive and floppy, then it is already built to support 32bit data transfers. That's why they call it PCI IDE. I would reccommend this, yes, because you can only get 16 bit transfers from a 16 bit slot, even if you have a Dash card installed. Your normally not going to use the floppy the same time that your using the backup drive anyway so you don't have to worry about the floppy interfering with transfers to the backup drive and slowing you down. I noticed a decent increase in speed when I used the IDE instead of the card, but to each his own. Some people may like it better using the card. That's entirely up to you.

Mike

Author

Commented:
mikecr

Mike, I assume you know what you're talking about based on first hand experience. Sounds like it's not worth all the trouble this damn card is giving me. I'll return it to NECX.

Now if I can only get my CDROM back. ;-)

Thanks for your input.
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
After you take the card out, remove the cdrom from the device manager and reboot your computer. It should pick it up and install it again for you. If not use add and remove hardware wizard to find it and if that won't work, put a Dos based driver in the Config.sys and try that. If you need help with it let me know. Yes, the accelerator card actually isn't worth the hassle in my opinion unless you have a non PCI system like an old 486, then it would be fast.

Good Luck!

Mike

Author

Commented:
mikecr

<<After you take the card out, remove the cdrom from the device manager and reboot your computer. It should pick it up and install it again for you.<<

I removed the CDROM from Device Manager, rebooted, and it was still there. (As if I never removed it.)

<<If not use add and remove hardware wizard to find it and if that wont work,<<

But first I have to remove it ... right?

<<put a Dos based driver in the Config.sys and try that. If you need help with it let me know.<<

FYI, I can access my CDROM from Dos ... but some of my software only runs in Windows. (If that's what a DOS based driver does.)

I think I'm confused. HELP!!
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
If you have a Dos based driver in your config.sys, then it will always show up in device manager. Your okay and don't have anything to worry about. If your loading a driver for your cdrom, then you don't have to worry about device manager then. Just go ahead and work on your computer. Let me know if you get any errors running the real mode driver in your config.sys. Depending on your version of Windows, the B version doesn't like it very well if you load a real mode device driver for the cdrom. If you get a vmm error or another type of error when accessing the cdrom through Windows then you'll need to remove the driver from config.sys. You should be okay though.

Good Luck!
Mike

Author

Commented:
Mike, I really appreciate your help on this thing. But I have some questions re your comments:

<<If you have a Dos based driver in your config.sys, then it will always show up in device manager. Your okay and don't have anything to worry about.<<

Does the fact that I can run my CDROM from the C: prompt automaticlly mean I have a Dos based driver? FYI, a "Dos line" doesn't appear anywhere in my config.sys file.


<<If your loading a driver for your cdrom, then you don't have to worry about device manager then. Just go ahead and work on your computer. Let me know if you get any errors running the real mode driver in your config.sys.<<

All I know is that Device Manager indicates I'm using a Toshiba driver (which I am), but when I run it in Windows I still get the error message I mentioned in my original post:

"F:\ is not accessible. ["F" is my CDROM drive.]
    A device attached to the system is not functioning."


<<Depending on your version of Windows, the B version doesn't like it very well if you load a real mode device driver for the cdrom. If you get a vmm error or another type of error when accessing the cdrom through Windows then you'll need to remove the driver from config.sys. You should be okay though.<<

My version of Win'95 is "400.950a" and the only error I get is the one mentioned above.

Hope I making myself clear ... if not, just ask me.

Thanks again.

Author

Commented:
mikecr

Mike, I was thinking about the driver types you mentioned, and was wondering if this line from my config.sys file looks right:

"DEVICE=\DEV\TAISATAP.SYS /D:MSCD000"

Aren't there two different drivers listed here?
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Right Rhyma, that is the exact type of line that you should have in the config.sys to initialize the driver for the cdrom. Your only actually loading one driver, the /D:MSCD000 is the name of the device. By naming the device with that command switch, the dos command mscdex.exe recognizes the cdrom and makes it available for the system to use. The only thing is, the way you have it listed, you don't have a drive letter for the location. It should read something like DEVICE=C:\DEV\TAISATAP.SYS /D:MSCD000 where C:\ is the drive designation for the cdrom driver. If you have any more questions, please don't hesitate to ask.

Thanks,
Mike

Author

Commented:
Mike,

I added the "C:" to the line as you suggested, and was sure that would do the trick. But I still get the "F:\ is not accessible" error message.

Very frustrating ... any other ideas?
Thanks,
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
from your C:> prompt type DIR *.SYS /S /P and look for the device drivers location. Once you find it, amend the line in config.sys to point to it, like such:

Device=c:\cdrom\cdrom.sys /d:mscd000

Then reboot your computer and press F8 when you see starting Windows 95 and choose the line by line confirmation. You will be able to see if your driver is loading properly without an error message. If it doesn't load properly let me know. Will start with this first.

Mike

Author

Commented:
Mike,

Everything loaded properly sans error messages.

FYI, this is the CONFIG.SYS line which I didn't have to amend since it was already "pointing" correctly:

DEVICE=C:\DEV\TAISATAP.SYS /D:MSCD000 /N:1

BTW, what's the "/N:1" switch do?

Thanks,
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
It's probably a DMA setting to use DMA 1. Is your cdrom working yet or do we have to go farther? I'm heading home so I won't be available till in the morning. We'll get it working if it's not, dont' worry.

Mike

Author

Commented:
Mike,

It only works from DOS ... and I appreciate your "positive thinking" and help.

Actually, I'm more frustrated than worried, since I can't backup my system with the Ditto, which I used to do several time per week. (I can't reinstall the software without the CDROM.)

Thanks again,
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Let's try this. Look into the autoexec.bat file and see if you have the following line there, it should look like this:

C:\windows\command\mscdex.exe /d:mscd000    The mscd000 should be the same one anotated in the config.sys. Reboot your computer and see if you have access to the cdrom through Windows then. If not, look into device manager and check everything listed and see if you have any conflicts listed in there at all. To install your software, make a directory, and from Dos, access the cdrom and copy everything to this directory and run the setup program from there. Keep me informed and let me know what happens.

Mike

Author

Commented:
Mike,

The AUTOEXEC.BAT line is "good" (i.e.,mscd000 matches CONFIG.SYS). Also, no conflicts in Device Manager.

I'm now going to try to install the Ditto software as you  suggested (good idea), and will let you know what happens.

Thanks,
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Good deal! Try to install your software and get back to me. If you have both lines working and you can access the cdrom in Dos, then you should be able to access it through Windows also. Keep me informed.

Mike

Author

Commented:
Mike,

Some "good news and some bad news" ... first the good news:

The software has been installed as per your instructions. ;-)
(A good learning experience for me.)

The bad news is that I can't run a backup because my Ditto Dash tape drive "wasn't found", so I can't configure it.

I plan to go into the case (at the end of the day), to check for loose and/or "misconnections", unless you have a better idea.

(FYI, I checked for conflicting device drivers as outlined in the Readme.txt file ... none found.)

I'll be in touch.
rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Yeah, your going to have to make sure that the cable is plugged in properly. You should have one end going to the drive and the other into the floppy connection on the motherboard. You should have a cable coming from the main one which will lead to the floppy drive. If this is correct then we need to check for a conflict somewhere, but this is probably unlikely. You may have to go into the Device manager and set the parameters for the tape drive by hand. Let me know.

Mike

Author

Commented:
Mike,

Since you mentioned Device Manager, I thought I'd look into it, but the Iomega tape drive wasn't even listed. (That might explain why I can't configure it and run backups.)

FWIW, I do see the Iomega tape drive listed in Device Manger in the "Safe Mode" (i.e., F8) ... any idea why that should happen?

rhyma  
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Your definately having a conflict somewhere with the tape drive. Since it's an internal then it's going to take an address and IRQ, so you may want to go into CMOS and if you have the option for plug and play operating system, I would enable it and see if it picks up the drive. If not then it will be good ole trouble-shooting time. Will have to uninstall and reinstall and get some good documentation from Iomega's website. Check the cables and everything, then set the cmos up and let me know how it goes.

Mike

Author

Commented:
Mike,

It took awhile to determine, but it was a connection problem (end pins on Ditto bent out). I can now run my backup. :-)

Assuming my CDROM worked as of my last backup (I'm pretty sure it did) which files should I restore to get the CDROM working. I'm aware of CONFIG.SYS and AUTOEXEC.BAT ... but are there others?

One down, one to go ... and thanks you for hanging in there.

rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
No Rhyma, there are not other files needed in Windows to get it to work. Windows uses what's called CDFS or cd file system to access your cdrom by addressing the Ide interface onboard the motherboard. If you put a rem command in front of the mscdex line in the autoexec.bat and also the line pointing to the cdrom in config.sys, the machine should pick up the cdrom if you use the add new hardware wizard to search for it. If it doesn't, then you have an older cdrom and you will need to leave the driver listed in your config.sys to be able to access the cdrom in Windows 95. Check it out and let me know what happens. Oh, I'll give you all the help you need until you get the thing working because I can remember a time when I needed help too!

Mike

Author

Commented:
Mike,

I'm afraid I didn't make myself clear re the CDROM: it is listed in Device Manager (Toshiba XM6102B), I just can't access it.

When I try to run or read from it I get:

"F:\ is not accessible. ["F" is my CDROM drive.]
    A device attached to the system is not functioning."

FWIW, it did work prior to that damn accelerator card install.

rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
What chipset do you have on your motherboard? Are you running Microsoft Office 97?
I will be gone till monday so if you can, hang on and we'll get this thing fixed.

Mike

Author

Commented:
Mike,

I have a 430TX chipset on my Abit AX5 mb.
No, I'm not running MS Office 97.

Thanks, and have a great weekend.

rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
I'm back and ready for action again. Your saying you can access the cdrom from a dos prompt, right? Can you exit to Dos through the start, shutdown routine and access the cdrom also? Edit the config.sys file and put the command LASTDRIVE=F statement in there as the last line and reboot your machine and let me know if you can access it then.

Mike

Author

Commented:
Well, one man's "action" is another man's aggravation. ;-)

<<Can you exit to Dos through the start, shutdown routine and access the cdrom also?<<

Yup.

<<Edit the config.sys file and put the command LASTDRIVE=F statement in there as the last line and reboot your machine and let me know if you can access it then.<<

Changed LASTDRIVE=Z to LASTDRIVE=F, but it still doesn't work.

Sid  
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Give me a list of the software you have installed on your machine, all hardware components and What version of Windows 95 are you running. I may have asked this before, but please bear with me.

Mike

Author

Commented:
Mike,

Windows'95 ver.:

4.00.950a

System hardware:

K6-2/300
AX5 mb (w/PL-ProMMX adapter)
64 mb SDRAM
2.5G. Seagate Medalist Pro HD
Ditto 2G. "Insider" tape backup
Ditto Dash accelerator card
Toshiba CD-ROM
ATI Expert@Work 3D 4mb
Ensoniq Audio PCI
Printer card (bi-directional)
Umax Scanner (parallel port)

Let me know if you still need my installed software (quite a bit) after reviewing the above. (Perhaps it would be easier if you told me what software you think may be problematical, and I'll tell you if I have it.)

Thanks,

Sid

Author

Commented:
Mike et al,

The problem has been solved. :-)

FYI, check out this great new site for the solution:

http://www.geocities.com/~budallen/DevMan.html

I just followed the instructions, downloaded the drivers, and now my CD-ROM works fine.

Thanks for trying so hard ... I really appreciate it.

rhyma



Author

Commented:
Mike et al,

To be more specefic, the link is:

http://www.geocities.com/~budallen/DevMan.html#CD ROM DRIVE NOT SHOWING

Thanks again.

rhyma
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Your welcome Rhyma! I'm glad that I could help and I'm really glad that your up and going now!

Good Luck!

Mike
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.