Solved

Help!! Now my server won't work!!

Posted on 1998-07-16
4
172 Views
Last Modified: 2010-03-18
Please refer to my earlier question first.  I followed chrisbill's advice and deleted the "indexes" text in my access.conf file. Then I typed in the command as follows:
   $ kill -1 'ps aux | grep "httpd" | grep "root" | awk '{ print $2 }'
Now my server won't work! Help!
0
Comment
Question by:TJWin
  • 2
  • 2
4 Comments
 

Author Comment

by:TJWin
Comment Utility
Edited text of question
0
 
LVL 2

Accepted Solution

by:
blowfish earned 20 total points
Comment Utility
Are there any httpd processes still running, or did it crash during the restart.  Check the last few lines of the error log file, you may have made a typo editing the Apache configuration files.  The log files should be in /var/log/httpd/error_log, and /var/log/httpd/access_log.  

When Apache was installed, a start/stop script was added as /etc/rc.d/init.d/httpd; this is how Apache gets started automagically during system boot.  Rather than type the more complex command-line with single-quotes, double-quotes, and back-ticks, you may find it easier to do the following:

  $ /etc/rc.d/init.d/httpd  restart

The script accepts four arguments; start, stop, restart, status.  When you make configuration file changes you will want to run the restart.  

After a restart, you should always check the error_log.  If the restart was successful you should see the following two lines at the bottom of the error_log:

  [datestamp] SIGHUP received.  Attempting to restart.
  [datestamp] Server configured -- resuming normal operations.

If you saved a backup copy of your config files prior to editing them (you did, didn't you), you can restore them and start the server like so:

  $ /etc/rc.d/init.d/httpd  start

Then examine the error_log, and correct the lines in the conf files that are in error, and then restart again.  

Hope this helps.  
0
 
LVL 2

Expert Comment

by:blowfish
Comment Utility
I just re-read the previous question again.  You were only supposed to delete the WORD indexes, not the entire line.  

Restore your backup copy of access.conf, and edit the line removing the word indexes.

--cheers
0
 

Author Comment

by:TJWin
Comment Utility
I DID only delete the word indexes.  I'll try your suggestions. Thanks
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now