Solved

SETTING UP A NE1000 NETWORK CARD

Posted on 1998-07-21
7
334 Views
Last Modified: 2013-12-15
I HAVE LINUX REDHAT, BUT IT DOESN'T SEEM TO SUPPORT MY NETWORK CARD (NE1000), IT SUPPORTS THE NE2000 THOUGH. HOW DO I GO ABOUT GETTING IT TO WORK WITH MY NETWORK CARD?

I ALSO HAVE SLACKWARE AND ALTHOUGH IT SUPPORTS MY NETWORK CARD, IT SAYS THAT THE CARD CANNOT BE FOUND AT ADDRESS 320.
WHATS THAT ABOUT THEN?

I SPENT DAYS TRYING TO FIGURE THIS ONE OUT.

CHEERS
MICHAEL OAKES
0
Comment
Question by:OAKESM
7 Comments
 

Author Comment

by:OAKESM
ID: 1628462
Edited text of question
0
 
LVL 4

Expert Comment

by:swwelsh
ID: 1628463
The ne1000 seems to be treated the same as the ne2000 from the documents I have read. Support for network cards is part of the kernel, and given the same kernel version it should make no difference whether you use slackware or redhat It's 8 bit instead of 16 bit, but it should still work. You'll need to know what irq and address the card is set to. This is written into the eeprom on the card, or maybe set by jumpers on the card. To change it you will need a dos utility that reads and writes to the eeprom. If you know the manufacturer, you can try their web site to see if there is a utility for the card, or try one for a similar card. If you have the card working in win95 or other os, you can get the irq and address from there. Support for the card can be compiled into the kernel or added as a module. You obviously have some sort of support set up in slackware, since it tries to probe for the card. Do you get any other messages at boot up about the card? Are you sure it set up at address 320? If you have any more detail about the card, kernel version, etc. maybe it would help to set it up.
0
 
LVL 2

Expert Comment

by:richrussell
ID: 1628464
Don't fall into the trap I did: When RedHat (or slackware) asks you for the io and irq of the NE2000 (or NE1000), don't type '320' as the address, use '0x320' - then it works. Pity it isn't documented that you have to give the prefix for hex, rather than it being assumed as in all the other options.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 32

Expert Comment

by:jhance
ID: 1628465
I don't think the support for the NE1000 is robust.  These cards are so old that there isn't much interest on the part of the developers to update them anymore.  You can get an NE2000 compatible NIC for about US$20 so there is little reason anymore to keep banging your head against an obsolete card.
0
 

Accepted Solution

by:
nivo earned 200 total points
ID: 1628466
I guess you've got a ne module in your kernel compiled, or loaded as a supplemental kernel. If the adress 0x320 doesnt work, you can force Linux to use other hardware adresses, by adding the following line to your /etc/lilo.conf (afterwards reload lilo by typing /sbin/lilo)

(in the boot entry of your linux add:)

append="ether=5,0x280,eth0"

Where 5 stands for the IRQ, 0x280 the IO adress and eth0 the logical device for linux.

Grtz,

WebSpider@IRCnet
0
 

Expert Comment

by:openGL
ID: 1628467
If the setup is the same as for an NE2000, the best way to do it is to recompile your kernel...I don't trust those red hat and slackware pre-installs.  compile the NE*000 support as a module then load it like:
/sbin/modprobe ne irq=5 io=0x320
As stated above most cards will either provide jumpers to change the ip and irq settings or will provide a dos utility (use a dos boot disk to run it) to save the settings to the card's eeprom.  Make sure that if the card has either plug & play or manual modes you take it out of plug and play or Linux will not detect it.  Do the settings by hand and make sure the irq and io address do not conflict with any other devices

0
 

Expert Comment

by:openGL
ID: 1628468
Whoops, just remembered that when you compile NE support as a module another module (8390.o) gets created as well. Load that one too before the ne module as so:

/sbin/modprobe 8390
/sbin/modprobe ne irq=5 io=0x320

sorry!
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Squid Connection Pools 3 46
We cannot find the source of the spam emails on our Debian 7 server 10 122
mobaxterm not able to change directory 28 108
Anti-virus for Linux Server 15 126
In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now