• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 318
  • Last Modified:

Win98 and Adaptec SCSI Adapter trouble. Memory Range conflicts

OK here's the situation:  I have a SCSI PCI AVA-2902I Adapter that conflicts in Memory Range C8000-CA7FF with the Bios PnP Extension.  I tried Anything: You CAN'T change in the Resource Settings that range of memory in the Adapter Driver or in the Bios PnP Extension.  I can only force a different IRQ Setting through CMOS but IRQ is NOT the problem.  I tried all drivers, the Adaptec and Microsoft ones for my SCSI Card and nothing.  The SCSI Card works perfectly in DOS, but I can't load Real Mode Drivers in Windows 98.  There must be a way to assign a different Range of Memory (like CB000-CD7FF, unused), but Windows 98 doesn't allow me to do it, except for the IO Port and a different Memory Range.  If I remove BIOS PnP Extension, when I reboot, Windows 98 installs it and reboots again, without asking me so.   My Motherboard is an Alton VX Pro with a Pentium 166.  
The ASD.log reports this is it can be useful:

7-22-1998
Windows 98 4.10.1691
{CF2524C0-29AE-11CF-97EA-00AA0034319D}
Starting a device
Adaptec AVA-2902A/E/I /AVA-2904/E /AVA-2910 PCI SCSI Controller
CI \V EN _9 00 4& DE V_ 50 78 &S UB SY S_ 00 00 00 00 &R EV _0 1\ BU S_ 00 &D EV _0 8& FU NC _0 0

So... There's a way to disable Bios PnP Extension (NO, You can't disable it for the current hardware profile), or a way to assign a different Memory Range for any of both (NO, Windows doesn't allow you to do that).

The Adapter doesn't have jumpers (to disable PnP feature) and the only thing I can do from CMOS is to change IRQ by forcing Legacy ISA.  I guess the ONLY WAY to solve this is adding some undocumented parameters to the device driver.

Let's see if you can do anything...
0
Naikel
Asked:
Naikel
1 Solution
 
steinermCommented:
try disable the windows driver. loadind the dos driver on startup the controller should work fine.
0
 
NaikelAuthor Commented:
I tried that before asking this question.  The drivers doesn't load on Real Mode in Windows 98, and I can't access my CD-Writer.
Anyway, there must be a way to have a 32bit access to my SCSI card under Windows, that's what I want.  

(NOTE: I can easily install Win 3.1 in other directory and work with my CD-Writer perfectly well, but that's not what I want to).
0
 
engeltjeCommented:
Is there a possibility to release the memory-range C800-CFFF in your bios?
Most biosprograms can. The same problem occurs with some networkadapters (SMC, Western Digital).
If not, try putting the following line in your config.SYS
DEVICE = c:\windows\EMM386.EXE /X=C800-CFFF
Does this do the job?

0
 
theyakCommented:
go to bios and turn off pnp , its not needed since the OS is pnp
or
flash your bios! may "fixes" can be done with a newer bios, since 98 came out
many oems are "tweeking" thier bios code


0
 
waynebCommented:
Your conflict is caused by the bios on the adaptec card, Can you go into the adaptec card bios and change the address or disable bios in scsi card. At boot up you should have the option of entering the card ctrl-a and try to change bios address or disable bios and this should take care of bios address conflict.
Also Make sure in computer bios that you disable all shadow ram and video shadow ram to prevent conflict. This should solve your problem.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now