Solved

Xwindows with server error

Posted on 1998-07-22
4
267 Views
Last Modified: 2013-12-15
I have intalled Linux 5.0 I have used Xconfigurator to select my Video card and monitor settings.  when I type startx, my screen goes blank for a second or two then i see little gray x's overlapping one another(which from what I
know is normal so far).  Then it says Caught signal 11. Server aborting. Can't Connect:errno = 111. those are the two error messages that stand out as errors out of everything else on the screen.  I would like very much to get XWindows running.
0
Comment
Question by:midnightq
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 

Author Comment

by:midnightq
ID: 1628479
I am new to unix and until I get xwindows up and going i am still using win95.  and if i can get it to go on my pc i have others willing to put it on theirs they just need to know it will work.
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1628480
I have the same problem. You should be able to choose size and number of colors. I have the same problem if I use 256 and with 16bit or 24 bit it was gone. There is one problem some of software and games will only work with 256.
0
 
LVL 4

Accepted Solution

by:
swwelsh earned 100 total points
ID: 1628481
Setting up the x server is mostly a matter of knowing all there is to know about your video card. Make sure you know the exact chipset, ramdac, memory, etc and read the linux documentation about your card. You might have to open the machine and take a look at the chips on it if you are not sure. Try www.XFree86.org for information, also the XFree86 FAQ. If you know your card is supported and you still have problems, try one of the other x configuration tools, XF86Setup or xf86config. You can also try the plain VGA server just to see that X is set up correctly and that you have a problem with the server. Any vga compatible card should work with the VGA server.

The Can'tConnecterrno=111 is just the generic error message that tells you your x server couldn't connect, which you already knew. Not sure about that signal 11 error.
0
 

Author Comment

by:midnightq
ID: 1628482
swwelsh got me started on finding the answer upon running xf86config i found i had not loaded the xf86_SVGA server...

Thank you a whole lot....  :)
0

Featured Post

Enroll in June's Course of the Month

June's Course of the Month is now available! Every 10 seconds, a consumer gets hit with ransomware. Refresh your knowledge of ransomware best practices by enrolling in this month's complimentary course for Premium Members, Team Accounts, and Qualified Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question