Solved

Slave drive missing

Posted on 1998-07-23
62
362 Views
Last Modified: 2010-04-12
I've got 2 hard-drives, both Quantum Fireball, one 1.7Gb and one 5.1Gb. The smaller is slave to the other. When I boot up sometimes the slave drive is missing in explorer. If I reset the computer it's there but if I properly power off/on it's gone. What's wrong and how do I fix it?
0
Comment
Question by:foxeye
62 Comments
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1121401
First of all check your standart bios seting see if there is for master and slave hard drive auto or user. Make sure that each hard drive is set in bios as user. When your system will boot and slave does not power up then you will  get bios error mesage and you will now know that your slave hard disk take more time to power up than new master and that you don't see it in explorer.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121402
Hi foxeye!
Are your drives listed correctly onscreen when you turn the power on?
Does the 5.1Gb drive have a jumper setting for "master with slave present"?
Regards,
Ralph

0
 
LVL 5

Expert Comment

by:theh95
ID: 1121403
Backup the files from your slave drive, because the drive is about to die.  That happen to one of my customer, that's what we leaned from the hard way.
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121404
I've seen the same problem with bad HD drivers and bad BIOS settings.
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121405
The BIOS and jumper settings are correct. Both drives are User in BIOS and the 5.1Gb drive is jumpered to be master, and the 1.7Gb is jumpered to be slave. What I can't understand is why it's there when i restart the computer but not when I "Cold-start" it.
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121406
So you have switched the Slave and Master state of the drives. Sounds like your BIOS doesn't recognise the 5.1 driver correctly but the OS makes up for it and recognises it after it has instantiated the System Devices from the first activation of the OS. Since your 5.1 is User defined, are you sure the settings are correct. What about setting the drives to AUTO-DETECT.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121407
foxeye,

It's easy to overlook........

Double-check your documentation for correct jumper configuration.

Many drives have one setting for master and another for master WITH slave present.

Regards,
Ralph
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121408
And you can just set them all to CS - cable select to have them set by the system.
0
 

Expert Comment

by:Tinkerer
ID: 1121409
What happens if you swap and set the smaller as master?
it sounds like the smaller one powers up a LOT slower..
I have it happen with a lot of my quantum drives, even the real old ones..
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121410
There is also a BIOS setting for drives that you set an amount of time for the BIOS to query the HD's. Older HD's require more time so increasing the amount of time may help.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121411
I haven't seen that one.......

Foxeye, we need some feedback.

Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121412
Yes, it seemed as if it was a human error. The jumper was ON ( probably set as slave WITHOUT master or something ), when all the jumpers should be OFF. I just removed the bridge and now it booted up fine. I guess Ralph was right, so please submit an answer and you'll get the points. Thanks a lot for all efforts.

 / Stefan
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121413
Hmm, sorry! I thought it was going to be alright now, but now I powered on and D: drive was missing again. Where can I set the start-up delay for drive D in BIOS?
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121414
Two of the three machines I have don't have this BIOS: Phoenix 4.0 Release 6.0. So, you may or may not have this Delay in your BIOS.

It is called "Hard Disk Pre-Delay" on the Main Bios Page right above the primary and secondary IDE dirves. It ranges from Disabled to 3, 6, 9, 12, 15, 21 and 30 seconds.
0
 
LVL 3

Expert Comment

by:cumbo
ID: 1121415
Foxeye,
Why are drives set to "USER"? If this is a Pentium system you should set them to "AUTO" and make sure both use "LBA" mode.

Also check your Device Manager for correct IDE controllers.

Cumbo
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121416
foxeye,
You still have not responded to my question about the "Master with slave present" jumper configuration.
Please read your drive's installation sheet for info.  If you don't have it, it might be available from Quantum on the net.
What is the model number?
Ralph

0
 
LVL 2

Expert Comment

by:harley47
ID: 1121417
On the Quantum drives there is no setting for master with slave present.  The slave is set with no jumpers or with the jumper in the third position from the ribbon cable.  the master is in the first position next to the ribbon cable.  The problem sounds to me like the drive is taking a longer time to power up.  try setting the drive to autodetect in the bios (as per kinkajou suggestion)  This will give the drive a longer time to powerup.

Hope this helps
If this does work please give the points to kinkajou
Bill
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121418
Sorry Bill, but that just isn't so.

I don't know if this is foxeye's model, but if you go here and click chapter three:

http://www.quantum.com/products/manuals/fireball_el_at/

On page 3-5 you'll find a chart and explanation of jumper configurations.  

There IS a separate, "Master with Slave Present" setting.

As you can see, the factory default master setting has the jumper installed across the DS pins.
Master with slave present requires moving the jumper to the CS position.

Now, I don't know if that will fix his problem, but it sure can't hurt to have the drive configured properly before continuing with the troubleshooting.

Regards,
Ralph

0
 

Expert Comment

by:Activar
ID: 1121419
Well, this may sound silly, seeing as this discussion is getting to be pretty thorough, but I  do have a comment.

The battery.

I know that the settings will be lost on a full off / on boot, if the battery is going; however, if you do a  warm boot then your settings are retained, it just means that the settings weren't flushed....get my meaning?

I would check the battery.

Good luck
0
 
LVL 2

Expert Comment

by:selim007
ID: 1121420
if you checked your bios settings and everything's ok so this should be a jumpers problem, check if its in the correct location...refer to ur hdd manual.

0
 
LVL 2

Expert Comment

by:selim007
ID: 1121421
if you checked your bios settings and everything's ok so this should be a jumpers problem, check if its in the correct location...refer to ur hdd manual.

0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121422
foxeye,
Any progress yet?
Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121423
No, the jumper settings seem to be correct. The master drive is a Quantum Fireball EL. The jumper settings are the same for "stand alone" and "master to slave", and the other is a Quantum Fireball TM. All jumpers should be OFF on that one ( "Slave to master" ). Any other ideas?
0
 
LVL 2

Expert Comment

by:harley47
ID: 1121424
did you try setting the bios to auto detect the hard drives?  if not try  that it should give the drive a little more time to power up.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121425
foxeye,

>  "...the jumper settings seem to be correct....  The jumper settings are the same for "stand alone" and "master to slave"......"

Apparently, you did not read my comment of Friday, 6:17AM.

I have repeatedly asked about your jumper settings, and my comments don't seem of any value to you, so I'll wish you good luck.

I'll spend my time with others here at EE that need help.

Regards,
Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121426
1. Yes, I've set the BIOS to "auto detect" but it doesn't help.
2. Ralph, I DID download that manual, but couldn't find anything about the jumper settings. I did however check the cover of my drive for jumper settings AND checked this page --> http://support.quantum.com/idedisk/fb(a)_el.htm
Where it clearly says "STAND ALONE --> DS=ON, CS=OFF, PK=OFF, RSVD=OFF and MASTER TO SLAVE --> DS=ON, CS=OFF, PK=OFF, RSVD=OFF"
0
 
LVL 2

Expert Comment

by:harley47
ID: 1121427
try setting the fast boot up to disable.  this will check the memory about three or four times maybe this will help.  it will be a setting like Quick Boot or something like that.

Hope this works

Bill
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121428
I've moved the jumper to CS as Ralph proposed, but no difference.
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121429
With "Quick Power on self test" disabled, no difference.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121430
Sorry that did'nt work,
It almost has to be the timing issue now.  The slave isn't recognized in time after the hard reset.
A little insight about the ATAPI confusion might be found here (if you have the time to read it):
ftp://fission.dt.wdc.com/pub/standards/atapi
Have you tried harley47's suggestion?
Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121431
Yes, I tried harley47's suggestion about disabling the "Quick power on self test", how can I check the battery? Is there some kind of software?
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 9

Expert Comment

by:rmarotta
ID: 1121432
The easiest way to check the battery is with a good voltmeter.  Lacking that, simply replace it.
How are the hard drive controllers listed in Device Manager?
Are you using busmastering?
Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121433
In device manager I have 2 GENERIC IDE DISK TYPE 46 and 1 GENERIC NEC FLOPPY DISK and the controllers are "Creative labs IDE controller" ( I've connected my CD-ROM drive to my SB32 card, it works better that way ). Then I have "Intel 82371AB PCI BUS Master IDE controller" and "Primary IDE-controller ( double fifo )". That's it.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121434
foxeye,
Your BIOS will pass the correct hard drive info to Windows when you let it auto-detect the drives.  They will then be correctly identified in Device Manager.
The busmaster IDE controller should have its child controllers listed as Primary and Secondary busmaster controllers.
Why aren't you using the Secondary controller for your second hard drive?
Read the documentation here for info on Intel's PCI Bridge fix:

http://www.windrivers.com/company/intel/intelup.htm

This patch will set up the chipset for proper operation.
Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121435
Isn't the second controller for the other IDE socket on the main-board?
0
 
LVL 2

Expert Comment

by:harley47
ID: 1121436
Check the bios to see if the secondary ide controler is turned on and try connecting the Slave drive as a master to the secondary.  (i may have asked this before forgive me if i have)Is there anything in the device manager under other devices?  if so rmarotta is correct about the PCI Bridge fix.
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121437
No, I've already installed the PCI Bridge fix so that's got nothing to do with it. I cannot set my current slave drive as master since it's not bootable, Windows 95 is on my master drive now.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121438
1) The setting of a drive as master on an IDE channel has nothing to do with whether or not it is bootable.

2) This configuration is used so that the controller can identify the drive and distinguish it from another (slave) that may be present on that channel.

3) Please read the file at that last link I posted for you.

See any familiar symptoms?
Ralph

0
 
LVL 2

Expert Comment

by:harley47
ID: 1121439
Set the slave to Master on the secondary IDE and leave you C drive on the primary as master.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121440
foxeye.........

Are we dealing with the same computer you had controller problems with before?  Located here:

http://www.experts-exchange.com/Q.10041042

Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121441
Harley47, I been thinking the same thing. Problem is I don't have a spare cable for it. Perhaps I should buy one.
Ralph, yes it is the same computer, however that issue is no longer a problem. I have reformatted the drive, reinstalled Windows, reconnected the CD-ROM drive and installed the proper drivers.
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121442
How are you doing on this issue, foxeye?
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121443
Im starting to think that the drive is broken. I've "fdisked" it and re-formatted it several times, but sometimes fdisk finds a "non-DOS partion" even though I've created one. And sometimes I can't label it.
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121444
That is weird. Is this driver new? Can you return it? Is it under warranty? Does your BIOS recognise the drive? I recently had difficulty with a system's BIOS that could recognise 1 g b drive but wouldn't recognise a 5.1 gb drive.

So the master drive is a primary partition/logical Dos drive and the slave drive is an extended partition/logical dos drive and formated? The jumper settings are master on the 5.1 and slave on the 1.7. You may need to check the cable - seems on my home system that if I have my slave drive on the further most cable conector and the master on the cable connector that is closer to the connector that goes into the MB, everything works fine. Switch the drives and my system reports no valid DOS found. The BIOS settings must reflect this configuration.
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121445
Hmm, it's worth a try. I'll let you know as soon as I've replugged it. To bad it's so &#/¤% short =)
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121446
Nope, that didn't do it. If I create a primary DOS-partion on it and restart, it finds 4 non-DOS partions?? I remove them all and create a new primary DOS-partion. The same thing.
Oh by the way, the disk is very old, and has 3 bad clusters on it. But it worked before I got the second one.
0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121447
Hey foxeye, old wise computer master say: When HD has bad sector, all HD will follow. I threw away a bad HD just last night because of bad sectors. In my experience, once a bad sector is found on a HD, back it up and toss it. Some of the errors that I had with the one I tossed last night included mis-reading sectors, Int 24 error messages, the size of the HD being miss-read, and not being recognised as a Dos partition.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121448
Just before tossing it, you might try a low-level format.
I'd watch it closely and do a good burn-in afterwards.
Regards,
Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121449
However, the fact remains: It works fine after a soft-reset, but not after a hard-reset. Even if I hard-reset it and it finds 4 non-DOS partions, I then soft-reset it and it's ok! As soon as I get my hands on a MB to HD cable we'll see if it works as a secondary master.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121450
Just temporarily disconnect the CDROM drive, and use it's cable.
That won't repair bad sectors though.....
Ralph

0
 

Expert Comment

by:b0b080698
ID: 1121451
have you looked into the possibilty of a virus on the Master Boot sector of one of the drives?  Also if you boot right into a DOS prompt do you see the drives?  that will probably help you establish whether it's a windows thing or a BIOS thing.  :P
0
 
LVL 10

Expert Comment

by:rbr
ID: 1121452
Some HDs have problem working together at the same IDE channel. Have you tried to put both HDs as master on different IDE channels.
0
 
LVL 2

Expert Comment

by:harley47
ID: 1121453
rbr it is common courtesy to read what the other experts are saying as comments.  That way you don't post an answer that some one has already suggested as a comment!! If you look at one of my comments I suggested the same thing!! There are a lot of experts here that have been trying to help foxeye and it is good practice to suggest something as a comment before you post it as an answer.  

Just my two cents

Bill
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121454
foxeye???
0
 
LVL 1

Author Comment

by:foxeye
ID: 1121455
Yes, I have tried booting in "clear" DOS. But the same thing in FDISK ( 4 NON-DOS partitions 3 x 5 MB 1 x 543 MB ).
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121456
>  "As soon as I get my hands on a MB to HD cable we'll see if it works as a secondary master."

Did it?

Ralph

0
 
LVL 1

Author Comment

by:foxeye
ID: 1121457
Sorry I haven't been able to comment. The problem sort of solved itself. I "accidently" flashed my EEPROM from Windows 95 ( BIIIIIG mistake ). I couldn't even start-up my system. So now I have a new mother-board and the drives now seem to work fine as slave and master. Maybe it was the battery after all?
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1121458
Battery?  No way.....
What about the bad sectors on that drive?
Did you try the low-level format?
Ralph



0
 
LVL 2

Expert Comment

by:kinkajou
ID: 1121459
Yeah, what have you decided to do about your problem?
0
 

Accepted Solution

by:
ficus earned 100 total points
ID: 1121460
try to conect 1.7Gb drive to secondary master.
If it won't help - low level format (from bios), and after that clean the drive with norton diskeditor (fill 00)
0
 
LVL 1

Expert Comment

by:danpaul091498
ID: 1121461
If you have to reset the computer to find it, the problem is that the system is booting before the drive is ready. The slave startes spinning up shortly after the primary. One way to prevent this in emable floppy seek. It will add a little time to the booting process.
0
 
LVL 3

Expert Comment

by:cumbo
ID: 1121462
Foxeye,

Why did you give the points to someone that jumped in at the last minute
without contributing to the thread????

If anyone deserved the points it was Ralph, Harley or Kink. This
kind of thing is going on to often on this board!

Where do these "computer illiterate" experts (sic) come from and
how did they get "expert" status???

There are four (4) dumb answers on this thread alone.

Cumbo
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Upper back Pain: My back hurt for months. Upper back, mostly my neck, spine and across my shoulder blades. I was getting headaches too, that felt like they were caused by tension in my shoulders, but now I feel fine! I'm sharing this hoping someone…
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now