• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 173
  • Last Modified:

Configuring my server to run CGIs.

I have a CGI script to execute my form, but when I submit the form, I get the error '%1 is not a valid Windows NT application'.  I know that this means my server(NT 4.0) is not configured correctly to run CGIs.  My question is, how DO I configure the server to do this?
0
khenness
Asked:
khenness
  • 2
1 Solution
 
alamoCommented:
Are you certain the script .exe is a 32-bit executable?

What kind of script? What application runs the script?

What kind of server, and what version?
0
 
khennessAuthor Commented:
Edited text of question
0
 
jcondeCommented:
Hi.

First, as alamo stated, make sure it's a 32 bit application.... (VB5, Delphi 3, C++ Builder, BC 5.0, VC5...all of these compile to 32 bits.)

To configure the server all you need to do is the following:

Start
  Programs
     Microsoft Internet Server (Common)
         Internet Service Manager
            Double Click in WWW (Running)
               Directories Panel
                  - Check if the path where your CGI is, is shown.
                    if not shown, ADD a new directory, and specify the EXECUTE option.
                    else
                    if shown, double click in the path, and specify the EXECUTE option.
         
If you have any more problems, please get back to me!

jconde  
0
 
alamoCommented:
What kind and version of *web* server?

Normally if the directory isn't mapped for scripts the 501 Not Supported error will come up, not "is a valid executable". But the errors aten't always consistent.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now