We help IT Professionals succeed at work.

Matsonic 3D Sound Problem

bytes
bytes asked
on
198 Views
Last Modified: 2010-08-05
Hello,

I just built a new computer, using the Matsonic main board/w
AMD's K6 300-2/integrated sound. The problem that I am having is that when the computer plays sound it freezes, ie. startup sounds, media on CD's, and of course games. I have tried just about everything. I disabled the sound chip in BIOS, and installed a sound card and still had the same problems. The problem is not consistant in Windows, but is very consistant when plaing games.  I have built a couple of systems with the Matsonic jumperless boards with no problems. I have tested the board, and it checks out. The board has integrated sound, 3D SoundPro. It does use 2 IRQ's
one for the Windows sound system, and one for the Sound Blaster 16 emulation, thus creating the 3D sound. There are no irq conflicts, or anything that you would normaly think is associated with a problem like this. There are no IRQ conflicts, none.  Matsonic has said that it is a problem with the integrated sound on the board. My vendor will take the board back, and give me a new one that supports the same chip (processor), but if there is a fix for the one I  have I would like to try and fix it. If anyone knows a fix for this problem let me know (not irq conflicts)
P.S. The board also has problems with network cards

ANY IDEAS?????
Comment
Watch Question

Author

Commented:
Edited text of question
get a real motherboard and real soundcard

i guess your soundcard uses 2 irq's one for windows sound system and one for sound blaster emulation, might wanna check under system properties if there is an irq conflict.
More infos about your computer would help especially the sound card

Author

Commented:
Edited text of question
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
I think spacebrain is on track. Your having either an IRQ or Address problem with your sound system. You need to go into device manager and look and see if you have any conflicts. Just because you don't see a yellow exclamation point doesn't mean that you don't have a conflict. Check you device manager thoroughly for a conflict and let us know what you find.

Mike

Commented:
What are the IRQ numbers assigned to the soundcard and video?
(Go to Computer icon in Device Manager and click properties for the list.)

Regards,
Ralph

Author

Commented:
Edited text of question

Commented:
bytes,
It isn't necessary for you to edit your question each time you comment.  Simply type your comments in the comment box to submit them.

Does Matsonic have any driver or BIOS upgrades available for that board?
Ralph

yeah cuz then we have to remember what was written before and see what been edited

Author

Commented:
This is not an IRQ problem. Matsonic has said that it is a problem with their board. I can get a new board, but if somebody knows of a fix out there let me know. I have already tried updated drivers. I have disabled the sound in BIOS and installed a sound card, and still had the same problems.
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
comes back to my first comment:
get a real motherboard and real soundcard

Commented:
I noticed an update for the Matsonic sound driver here:
http://www.matsonic.com/sp98upp.htm
I wonder if it might help.
Ralph

Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.