• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 287
  • Last Modified:

HPlaserjet setup in Solaris.

I am trying to properly setup a HPlaserjet 4000 printer on my stand alone (not networked) Solaris running 2.5.1 version of the operating system. I need to print primarily postscript files with some ascii. I have gone into admintools and configured the printer as postscript with the postscript and ascii setting.
When I print any ascii files I get two pages printed on one page in landscape mode. I want to print in portrait mode with one page on a single page. I noticed there was a hplaserjet setting for the printer type but when I select that setting it won't allow me to save that printer type. Does anyone have any suggestion on properly setting up this type of printer?
0
mljacobs
Asked:
mljacobs
  • 2
1 Solution
 
mljacobsAuthor Commented:
Edited text of question
0
 
jlmsCommented:
Does this printer recognize PS? If it does not use ghostscript (it will convert from PS to other languajes, most notable PCL or HPGL for HP printers).

If it does recognize PS: do you have any problems with the PS printings?

About the ASCII printing you have to check your manual and find the sequence to tel your printer so, then you can create those commands and send them every time you want to print in portrait mode.

Is the printer a network printer? If it is, are you using AdminJet?

0
 
mljacobsAuthor Commented:
Thanks for your comments. This is a new model HP with postscript built in. I am using my Solaris as a stand alone work station for CAM work. It is networked to a alpha NT box used as a front end to run photoplotter. The NT does not have access to my HP printer. The printer is network capable as a upgrade but I did not buy the network card it since I only need to print from my Solaris computer. I am very new to the Unix environment and the way it does things. I run the Solaris in the open windows environment. Using the file manager to print a simple ascii file, print command, the print option that comes up by default is as follows, Print box labeled FM print, cat $file| mp -l -o |lp -o nobanner. This prints the file in landscape mode with two pages on one page. If I type in lp -o nobanner $file then the print is back to portrait mode like I want. How can I change the default so I always just get the lp command? Also can I somehow configure Solaris to recognize my HP as a HP postscript and not a generic postscript, or is a postscript printer just a postscript printer?

Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now