We help IT Professionals succeed at work.

Caller ID giving weird responses

DOSFace
DOSFace asked
on
431 Views
Last Modified: 2013-12-27
Hi,

I purchased a AOpen K56 Flex modem a few months ago, and just became interested in the Caller ID function. I'm using QuickLink Message Center III. The problem is that the number doesn't show up. Here is the response when I use terminal:

AT &F E0 V1 &D2 &C1 S95=47 W2 S0=0 #CID=1
OK

RING

DATE = 0701
TIME = 1415
MESG = 030738333631383137

As you can see, the NMBR = line is missing. The MESG = line is not the phone number (if you remove the first four numbers and every odd number thereafter you do get the correct number). Is something wrong with my init string? Could the way I'm connected to my phone jack have an impact on this (via extension cord and a double jack thingy)? Could it be because I'm in Canada? (PS I am subscribed to Caller ID and it works with the boxes. The modem is Caller ID as well).

Thanks,

-DF
Comment
Watch Question

Commented:
I found this tidbit on my modem diskette:
For most MODEMs, the string AT#CID=1 will enable Caller ID. On some voice based MODEMs the string is AT#CLS=8#CID=1. Look in the user’s manual for your MODEM to see if any setup string is referenced or mentioned. Other common setup strings are:
 AT#CID=2 AT%CCID=1 AT%CCID=2 AT+VCID=1 AT#CC1 AT*ID1

Which one works for you?

Commented:
The MESG response you receive is the entire information in raw data format. On hayes FTP site you can find documentation about hot to set up the caller ID on different modems.Try to use just AT&F followed by AT#CID=1 , without the entire string.
Maybe this will help too.

AT#CID=0 Turns Caller ID off. This is the default.
AT#CID=1 TLong Format Caller ID.
AT#CID=2 Gives Caller ID info using an unformatted output.

AT%CCID=0 turns Caller ID off.
AT%CCID=1 gives Caller ID info using a formatted output.
AT%CCID=2 gives Caller ID info using an unformatted output.

Author

Commented:
Thanks guys!

I'll try those things out and get back to you!!

Author

Commented:
Hi everyone,

I know it's been a while since you guys answered my question and I have yet to grade it. Rest assured that I am trying the suggestions you gave me, but unfortunately, I haven't received all that many calls, so I will get back to you guys ASAP. Thanks again,

-DF


Author

Commented:
Sorry guys, your suggestions didn't work. I also tried unhooking all the other phones from my house but I'm still getting the garbled message with all the extraneous 3s.

If you remove the threes, you get a number pretty close to the original...
0078361817
.which is correct, except for the 007, which isn't the area code. Any other ideas?

-DF
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Commented:
> "(PS I am subscribed to Caller ID and it works with the boxes. The modem is Caller ID as well). "

If the present proposed answer does not solve your problem, please select "reopen the question to other experts" from your list of options.
You do not have to accept any answer proposed to you until your problem has been solved to your satisfaction.

Are you using Windows terminal program?

If so, what version of Windows are you using, and what driver are you using for your modem?

Regards,
Ralph

Author

Commented:
Hi everyone,

I will call the tech support of my telco as soon as I can. In the mean time, I am running Windows 3.1, using Terminal, and the CYBERCOM.DRV communications driver.

Will get back to you guys soon...

Author

Commented:
Hi,

I haven't had a chance to call Tech Support yet, but just so I don't leave you guys hanging anymore, thanks for your help.

-DF
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.