?
Solved

Please help : Xwindows mouse problem

Posted on 1998-07-28
10
Medium Priority
?
238 Views
Last Modified: 2013-12-15
I have just installed Slackware linux, and XFree86. My
is that when I type startx, the fvwm starts up okay but
the mouse pointer is stuck to the top left of the screen.
I have configured it as a two-button ps/2 mouse, connected
to the auxiliary port. I have already tried to troubleshoot
by commenting out the mouse in gpm ( that just allowed the
server to start up ).I am not  using a logitech mouse.
When I shut down the server ( ctrl-alt-bksp ) , I see a text
message when I get back to the command line prompt :

Warning:Unable to get status of mouse fd ( Invalid argument)

I don't know if this has anything to do with the erratic
behavior of my rat, but I hope it gives you enough of an
idea of my problem. I really am very stuck, so any help
would be appreciated.

Many Thanks,

Jay Banda
0
Comment
Question by:bandaj
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1628779
Check the right settings for your mouse with gpm.
Add these seetings (corresponding to gpm) in /etc/XF86Config
  Section "Pointer"
Then stop gpm before starting X.

0
 

Author Comment

by:bandaj
ID: 1628780
Thanks, ahoffman, but I have already tried that and
still I get nowhere. I am really going mad trying to find
a solution , so if you know of any , please let me know.

Thanks,

Jay
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1628781
Could you please post the gpm command line which gets your mouse working, and the Section "Pointer" from XF86Config
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 1

Expert Comment

by:tim_lbi
ID: 1628782
Check to see if the PS/2 support is compiled in kernel (Characters devices->mouse support->ps/2)

0
 

Author Comment

by:bandaj
ID: 1628783
Yipee !!!

Thanks for all the help , guys , I managed to get the mouse to
work. How ? Well , I thought that I would just try a last ditch
effort, and so I attached a Microsoft serial mouse to the system,
booted up , and would you believe that I was actually able
to control the mouse in x windows !! Although I was overjoyed,
I have a distinct dislike for problems that apparently solve
themselves ( the XF86Config file indicated that the protocol
was ps/2 and the device was /dev/psaux ). With those conditions
it is practically impossible to have a serial mouse work. Some
investigative work brought the truth to light: there are apparently 3 locations for the XF86Config file, the last on I
checked being in /etc . All along I have been working on the
other two, and so any changes I made there were not being loaded
at start up 'cos the /etc directory is high up on the search
path.

Yet again, many thanks to all who offered suggestions.
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 280 total points
ID: 1628784
Didn't I tell you to check /etc/XF86Config?

:-))
0
 

Author Comment

by:bandaj
ID: 1628785
Spot on , ahoffmann !!! I was going so fast that I forgot to
ask you to post your comment as an answer to get the points !!
Thanks again. As and aside , maybe you could let me know why
there are three different locations for the file, or does it
have something to do with linking ?? ( Forgive me, new to linux )


Ta


Jay

0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1628786
Puh, good question, probably you better ask at xfree86.org ;-)

I thinks /etc is for historical reason.
<XRoot>/lib/X11 is the place where it should be by convention (deside yourself which standard).
And  <XRoot>/lib/X11/XF86Config.hostname  which is the way like unix do a userfriendly customizable way to support different settings for different hosts.
Keep in mind that as user root X also checks for $HOME/XF86Config first.

You need more?  man XF86Config
0
 

Author Comment

by:bandaj
ID: 1628787
Thanks again.

Jay.

May I call on you again in the near future ?
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 1628788
You may, just post a question.
I thing there're some more experts here :-))
0

Featured Post

Get proactive database performance tuning online

At Percona’s web store you can order full Percona Database Performance Audit in minutes. Find out the health of your database, and how to improve it. Pay online with a credit card. Improve your database performance now!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month9 days, 8 hours left to enroll

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question