Solved

ppp fails to connect to Netcom

Posted on 1998-07-28
1
325 Views
Last Modified: 2010-03-18
When I invoke the ppp script, either ppp-on (slackware) or ppp-up (SUSE which I am presently using) after what I consider a long time, more than a minute the modem eventuall kicks in and sounds like it is connecting but doesn't.  Ping  and ifconfig both indicate no connection.  In the /var/log/messages I get the following: (parts left out)
kernel ppp line discipline registered
kernel registered device ppp0
pppd   using interface ppp0
pppd   connect:  ppp0 <--> /dev/modem
pppd   sent [LCP ConfReq id=0x1<mru1500> <magic 0x89aa264b> <pcomp><accomp>]
pppd   last message repeated 6 times Hangup (SIGHUP) modem hangup connection terminated.

I would guess the LCP ConfReq message is the problem but I have no idea what it is or means. help.

Would also like to know why it takes so long for the script to kick in.  It was virtually instantanious on a 486 running slackware, now I am running SUSE on a p90, 32meg RAM
0
Comment
Question by:ntkonnek
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
sikander earned 200 total points
ID: 1585926
You should check the ppp-up scripts and edit the line where the
pppd daemon is starting.
It should look like this (it works fine with my connection, with
no delay.
exec /usr/sbin/pppd debug lock modem crtscts /dev/modem 57600 \
    asyncmap 20A0000 escape FF kdebug 0 $LOCAL_IP:$REMOTE_IP \
    defaultroute

Now, the /dev/modem should be a link to apropriate /dev/cuaX device, where the modem is attached.

Next, in a script, you should have two variables, $LOCAL_IP and
$REMOTE_IP which is quite understanding.

This should work just fine.

The message (LCP ConfReq) which pppd sent is probably due to improper settings of pppd daemon. You should read pppd man page very carefully, and pay attention to lcp-* commands.

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Come and listen to Percona CEO Peter Zaitsev discuss what’s new in Percona open source software, including Percona Server for MySQL (https://www.percona.com/software/mysql-database/percona-server) and MongoDB (https://www.percona.com/software/mongo-…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question