2nd hdd dosmode file system

I installed a 2nd hdd and everything went well except the file system under performance came up as msdos real mode. Also the secondary ide controller has an hiphon and it says the drivers need to be reloaded. What drivers from where and  how do you get it to run in 32bit.Grant
gracecoAsked:
Who is Participating?
 
rmarottaCommented:
Grant,
Something else to consider:
Win95 needs to be installed onto the hardware on which it will run.
By copying the hard drive contents from one drive to another with different capacity, and then attaching the different drive as bootable (primary), you changed the physical hardware on which that copy of Windows was originally installed on.
When Windows next started from that drive, it was not configured correctly, hence the conflict.
Apparently, with the non-fdisk partition channging, the MBR was mis-written, and somehow showed erroneous drive info to Windows.
Glad you got it going.
Regards,
Ralph

0
 
RokeCommented:
Go into Safe Mode, delete the device with the exclamation mark, reboot the PC and Windows 95 should redetect the device and load the correct drivers (from the Windows 95 CD-ROM).
0
 
rmarottaCommented:
Go here for trobleshooting info on Dos compatibility mode problems:

http://support.microsoft.com/support/kb/articles/Q130/1/79.asp

To save time in solving your problem, it will be helpful to know more about your computer.

Please list the components of your system that might apply.
(Motherboard, CPU, RAM, Hard Drive(s), CD-ROM, Soundcard, etc.)
Also, please post your autoexec.bat & config.sys files.

Let me know if you need more.
Regards,
Ralph

0
WEBINAR: 10 Easy Ways to Lose a Password

Join us on June 27th at 8 am PDT to learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees. We'll cover the importance of multi-factor authentication and how these solutions can better protect your business!

 
harley47Commented:
under the performance tab in the device manager does it give you a reason the drive is in ms-dos mode?  ie:the master boot record has changed.  if so go into your bios and turn off virus warning then from a dos promt type fdisk /mbr.  

if this works let me know and i'll repost this as an answer


Bill
0
 
aheCommented:
delete the line with the hiphon, but before look in the manual of your motherboard which kind of chipset you've got on it. maybe you will find next to the manual an disk with "PCI IDE drivers" on it, there will you find instuctions to install the chipset correctly. An other reason could be, that you have switched off the auto-detection at your bios or and old cd-rom-drive is connected to the socind ide-controller.
good luck.

andi
0
 
rmarottaCommented:
graceco,
If the present proposed answer does not solve your problem, please select "reopen the question to other experts" from your list of options.
You do not have to accept any answer proposed to you until your problem has been solved to your satisfaction.

We need some feedback from you.
regards,
Ralph

0
 
gracecoAuthor Commented:
Have been away for weekend. Will try the comments and answer in 24 hrs or so. Grant
0
 
gracecoAuthor Commented:
Also I have reproduced the same problem on another computer which I do not have the manual for. It is a pentium 75 with 16mb Ram. Master HDD is 210mb and the sec. on the same tape is a 170mb.
It has brought up the msdos file system and Sec ide with the yellow tag in system devices. The cdrom is attached via an interface card poss panasonic.
Grant. (On NZ Time re previous comment)
0
 
gracecoAuthor Commented:
I found the problem. I had used Ghost to ghost from a smaller drive to a larger drive and so it also transfered the format structure also. I fixed it by reformatting the larger drive and then copied files manually.
Grant
PS After 24 hrs I will withdraw the question.
0
 
rmarottaCommented:
Grant,
That won't fix the conflicts you had in Device Manager.

In order to run Win95 at all, it means that the drive was configured to have been installed correctly, without the conflicts.

I suggest that what fixed it was the format and subsequent correct re-install of Windows.

Sorry you had to do that.
Regards,
Ralph

0
 
gracecoAuthor Commented:
Ralph, Watch this space. I Had the problem on the first computer that we had put the 4gig HDD into. We ghosted from a 2.1gig Quantum Fireball to a Fugitsu 4.3Gig. It showed up the file system error. So we changed the 2.1 for a 1.2 Quantum bigfoot brand new and it all came up ok. But when we changed back to the 2.1 it showed up again. So we fdisked and formatted the 2.1 and had it again as a secondary. Still problem. Then we manually copied the 4.3 to the 2.1 after doing fdisk/mbr on the 2.1. We were expecting to reformat the 4.3. But on rebbot before refomat with the 4.3 as master still the problem had disappeared.
  It is poss to have active partitions on both drives? Could that have any bearing. At present both c: and d: have active partitions.
Grant
0
 
rmarottaCommented:
Somethings wrong here.
I don't think Dos can have more than one active (bootable) partition.  There could be an error on the drive's MBR.
See if you find anything useful about it here:

http://support.microsoft.com/support/kb/articles/q69/9/12.asp

Let me know.
Ralph

0
 
gracecoAuthor Commented:
Ralph: only one bootable per physical drive but we have got 1 active on each of 2 physical drives.
Grant
0
 
rmarottaCommented:
Grant,
I don't know why that should happen.
Does your BIOS allow boot order to be set for any drive/CDROM?

Ralph

0
 
raberCommented:
If your running a large format drive you may have a bios extension driver that is not fully Win95 compatible.....go to your config.sys files and REM out any drivers that are loading. if windows loads in the 32 bit mode you may have a driver that need updating...It will be hunt and peck...Microsoft have some good info on how to troubleshoot this problem but be prepared to spend a while solving it...
0
 
gracecoAuthor Commented:
We finally solved the problem. We used Partition Magic. We deleted the active partition on the 2nd drive then set it as an extended partition. We then divided it in to 2 partitons. Rebooted and all was ok. Then deleted those so that Win95 thought it was a new drive again. It showed up because with partition magic it assigned the wrong drive letters to the drives.ie: c: to the first active partition and d: to the 2nd even though it was on the 2nd drive. But e: to the extended partition we made on the first drive. Ralph your querry about more than 1 active partition lead us to it. Set it as an answer if you wish. Grant
0
 
gracecoAuthor Commented:
Ralph your mention of the MBR is significant because I did FDISK /MBR when it was set up in the new config and the problem didn't return. Many thanks for your help. Grant

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.