We help IT Professionals succeed at work.

PCI ethernet card setup

bandaj
bandaj asked
on
Medium Priority
469 Views
Last Modified: 2010-03-18
Hi, I just finished installing slackware linux 1.2.13,
and XFree86 3.1.2. I am trying to configure my ethernet
card so that I can see our local network. Details:
card : PCI Ethernet DECchip 21040 Based Adapter
irq : 09
i/o : FC80h-FCFFh
Windows 95 detects and configures the card , and the
above details are from the device manager.

When I start up linux, during the boot I get messages
like :


SIOCSIFADDR : No such device
SIOCSIFBRDADDR : No such device
Network unreachable.

I have looked in /dev , and there is
no entry for eth0, eth1 etc , or anything
denoting an ethernet card. Is there any way
of forcing linux to find my card ?
Also, in a file called pci , the card is listed
there , meaning that linux can see it ??
So, where have I gone wrong ? Any ideas
would be greatly appreciated.

Jay.
Comment
Watch Question

In your bios you will see setings about OS set it no pnp and if this does not help you go to www.linuxmall.com and get RedHat 5.1 for 1.99 plus S&H . I have the same chip and redhat installed driver without any problem
You can force to use ethenet card by adding line to lilo check out howto ethernet www.linux.org

Commented:
I am using Slackware Linux 3.4,
from your kernel version (1.2.13) i assume you are
running Slackware 3.0. It would be a good idea to
upgrade to 3.5 or something with a version 2 kernel,
i am using slackware 3.4 using the 2.0.35 kernel
and this kernel has much better support for the PCI
bus and PCI network cards. I previously had some problems
like you are having and by upgrading my kernel things
have become much smoother.
ftp (or http) to ftp.kernel.org for the latest kernel
and docs.

Commented:
You must have the appropriate driver.
I know there's support for that adapter in kernel version 2.0.33, cause that's what I have. The ethernet howto will help.
Linux will detect the existence of any pci cards, but it's a matter of having support a card before you can use it.
Since the pci file lists the card, linux is seeing it.
Also, I understand that the files in /dev are not involved in setting up ethernet, so missing /dev/eth0 doesn't matter.


for new kernels thereĀ“s a driver called ne2k-pci

to use it, assuming you have kerneld, write the following line in /etc/conf.modules:

alias eth0 ne2k-pci

Good Luck

Author

Commented:
Hi all,
sorry for the long silence, my service provider had a few hiccups.
Now for my replies :
    Marcelofr: I tried to download the driver you suggested,
and I got a file called ne2k-pci.c. I have no idea how to make
this into a module. Possibly you could give me a little more
info on that ??
    rasp: I upgraded the kernel to 2.0.4 , and when it asked if
I wanted to include support for ethernet and tcp/ip, I said yes.
However , at reboot time , the same messages keep on coming up.
    jburghardt: I did change my bios settings to a non- PnP OS,
to no avail. I would go to linuxmall to get Redhat @ $1.99, but
it would take forever to reach me ( I am in Zambia, Africa ).

Maybe I just don't know how to tell if the network card is detected.
I have been told that it does not show up in /dev as eth0,eth1
etc. So how does on know that the card is being seen by the OS
( I have been using ping to see if communication could be
established, but the only messages I get are that the network
is down or unreachable , when I know that the network is actually
alright. ) Any ideas ??
At this point I am willing to raise the points to 150.
Thanks for all the help so far. Please bear with the Newbie
questions :-))

Jay

Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.