LILO stuck at LI from bootdisk installation

Posted on 1998-08-02
Last Modified: 2013-12-15
Hi!  I'm trying to install Linux on a friend's system, using
Slackware 3.4 (November 97), on a system using an AMD chip and UltraDMA disks (and an EIDE CDROM).  I made the boot (bare.i) and rootdisks, but when I try to boot from the bootdisk, it gives me "LI" and stops there.

I looked around on the newsgroup archives, and there are similar questions, but they seem to involve LILO AFTER Linux has been installed to disk (and seem to involve having installed the root partition at >1024 cylinders or what not)-- whereas here I can't even boot into the installation rootdisk!

For reference, I made the boot and rootdisks from within a Win98 DOS window, though I don't see why this should make a difference.

Any help would be appreciated.

Question by:ap9

Expert Comment

ID: 1629108
If the bootdisks are working on other computers, it is probably because the system of your friend is faulty.. might even be the processor or memory (mixed different brands ...) .  Linux is very hardware sensitive.

LVL 51

Expert Comment

ID: 1629109
Stopping at  LI  indicates a missing second stage boot loader (i.e. boot.b) or a damaged/wrong /
This usually could be fixed by running lilo again.
For details see lilo man-page.

Author Comment

ID: 1629110
Well, the thing is that Linux isn't even INSTALLED yet.  I had just made the bootdisk and tried booting from it, and this happens.

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Author Comment

ID: 1629111
Well, the thing is that Linux isn't even INSTALLED yet.  I had just made the bootdisk and tried booting from it, and this happens.

LVL 51

Expert Comment

ID: 1629112
Then lilo didn't what you need on you bootdisk.
Check you lilo.conf which you used for the disks, for example following entries:


Also check lilo's   -r  -c   options.

Author Comment

ID: 1629113
Would these be on the disk itself, or the CDROM?  The bootdisks I'm using are straight from the root and bootdsks directory on the CDROM, done via RAWRITE.


LVL 51

Expert Comment

ID: 1629114
I would expect that bootdisks from a CDROM distribution work without any modifications, but you never know.
Check the kernel image on the disk with rdev, then you may see if it fits to your environment. If not, you may alter it using rdev (and/or some of its aliases) and/or using lilo as mentioned before.
Please refer to  man rdev  before.

Accepted Solution

Riva earned 200 total points
ID: 1629115
I had the same problem once.
But it disappeared when I recreated the boot and rootdisks from DOS instead of from Windows DOS-shell.

2nd thing to mention is that Windows98 uses FAT32x which is different from Windows95 FAT32. So their Windows DOS-shell is different (works differently);

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

713 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question