Solved

SAMBA networking

Posted on 1998-08-04
4
271 Views
Last Modified: 2010-03-18
I have 3 win95 computers, and 1 red hat linux machine. i have samba running on the linux machine, but every time i click on it's name from the network neighborhood on the win95 machines, it asks for a password. could someone tell me what i have to change in my smb.conf to get rid of the password to access my shared stuff (THIS IS NOT A SHARE PASSWORD, It comes up when i click on the computer name from the network neighborhood)
i have tried a few things, so if you want the full 700 points, please give me several different answers IF POSSIBLE.
thanx
ty
0
Comment
Question by:TRM
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 

Author Comment

by:TRM
ID: 1586245
please answer asap, thax
0
 
LVL 1

Accepted Solution

by:
sioux earned 700 total points
ID: 1586246
Set 'guest ok = yes' in your smb.conf

See example for spool

[global]
        comment = Servername
        workgroup = WORKGROUP
        guest account = nobody
        netbios name = Servername
        log file = /usr/local/samba/log.%m
        printing = bsd
        printcap name = /etc/printcap
        load printers = yes
        preserve case = true
        short preserve case = true
        socket options = IPTOS_LOWDELAY TCP_NODELAY
        server string = Samba Server

[spool]                    
path = /export/spool
        comment = Export volume (spool)
        guest ok = yes
        read only = no
        preserve case = yes
        case sensitive = no
        admin users = admin, admin2
        browsable = yes
        create mode = 770                              
0
 

Expert Comment

by:larrydog
ID: 1586247
Yes. I believe you need to activate your samba users by doing a
smbpasswd -a username

This will allow your users access to the Samba Server and all of its resources. Make sure they use the exact same login and password combination when starting Windows 95/98 that you use for your Samba users.

If you are using your Samba Server as a Wins Server you need to add that info to your TCPIP settings of your Ethernet in the Network config applet found in Control Panel.



0
 

Author Comment

by:TRM
ID: 1586248
thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question