Solved

running xwindows

Posted on 1998-08-04
9
287 Views
Last Modified: 2013-12-15
i just loaded redhat 5.1 on a pc and can not get the xwindows to display the correct size screen, everything to big.
i have went through the xf86config a million times,ran superprobe and listed the exact info from my v.card and monitor,and changed the screen resolution from 640 to 1280 and all points in between but to no avail.please help.ps: i am a newbee so keep it simple thanx.tom
0
Comment
Question by:tommiller
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 

Author Comment

by:tommiller
ID: 1629273
Edited text of question
0
 
LVL 4

Expert Comment

by:swwelsh
ID: 1629274
Try Ctrl-Alt-+ to scroll through the available resolutions.  You could also try the other tools for configuring X, X configurator on Redhat and XF86Setup. What does it say in your XF86Config file under 'screen'
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 100 total points
ID: 1629275
If you want another reolution as default, just change order of the  Modes  line in the   Section "Screen", the first (valid) mode is default.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Expert Comment

by:rhanson
ID: 1629276
I have the same problem.
Is it like your desktop is 4 times the size of the monitor?
Can you scroll around with a mouse or keystrokes and see other
portions of the screen?


0
 

Expert Comment

by:rhanson
ID: 1629277
I have the same problem.
Is it like your desktop is 4 times the size of the monitor?
Can you scroll around with a mouse or keystrokes and see other
portions of the screen?


0
 

Author Comment

by:tommiller
ID: 1629278
thank you for your response,my only question is how do i find "screens" is there a manual that might help me find some of the basic steps (other than the red hat manual)i am very new to linux. i will look tomorrow at my system and then let you know if it worked.
the "alt/ctrl/+. does not work untill i load more monitor configurations, but i am having problems with xf86config not recognizing the resolution properties that i am setting up.
RHANSON: yes your description is exactly correct,and i did not enablethat feature in setup.         THANX TO YOU ALL
0
 

Expert Comment

by:rhanson
ID: 1629279
Let us know if you figure this out since i have the same problem.
Im goint to work on it this weekend.
rhanson@tiny.net
0
 

Expert Comment

by:rhanson
ID: 1629280
in the /etc or /etc/X11 directory as ROOT and go to the bottom of the
screen, you will see 3 or so groups of listings, there you will see each
group has a MODES and a VIRTUAL line, delete the VIRTUAL line, and on the
MODES line make whatever you want the default resolution to be, the first
entry

fixed it for me

Ron Hanson
0
 
LVL 6

Expert Comment

by:joe_massimino
ID: 1629281
Do this, run Xconfigurator gain, but when it gets to the video mode, select the Choose your own option.  This is where you select some of the other resolutions your video card supports. Once you have finished Xconfigurator you may have fixed your problem if Ctrl-Alt-+ changes modes for you.

I was dealing with this same problem since last night. The fastes way I found to fix my Xwindows troubles was to reinstall Linux, and make the right selections when you get the the Xwindow setup. I tried editing the Xconfig file with VI, but I found it not working the way I wanted when I got done.

Also, be sure you identify the correct video card, and amount of video Ram. The RAMDAC chip used must be identified correctly. If you use a generic driver, you get generic results.
I like the fact that I can use high res when I'm doing soem things, and low res when I'm doing other things.
The screen will scroll when you select a low resolution, or it will become many times larger so you can view many running applications in a seperate window. I think it works prety well. If I get the Netscape for Linux installed, and a good news reader and pop mail client, I won't want to go back to Win95, or WinNT.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question