We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Hang 98?

itinerant
itinerant asked
on
Medium Priority
281 Views
Last Modified: 2013-12-28
Freshly installed 98, on Scsi only system, hangs immediatly after startup as soon as I try to do anything but run a program from a shortcut. If I run windows explorer either from a shortcut, or the start menu, the computer slowly grinds to a hang. ie, the taskbar freezes, then the machine hangs. CTRL-ALT-DEL just brings up unstable/busy blue screen. The severity varies, ie sometimes no problems, somtimes nothing but problems.
The only thing I can see out of the ordinary is that IRQ 14 and 15 are being shared.

tx-pro m/board
cyrix 233
64mb edo dimm
Adaptec 1542cf Scsi card
Shitty old Fujitsu H/D (slow but not suspect)
Comment
Watch Question

James ElliottManaging Director

Commented:
Sounds like your SCSI adapter is at fault. Make sure all settings are correct in device manager and that u have all the lates drivers installed.
Is this a freshly built computer..or have you simply upgraded from another opperating system? In other words....do u know for certain that your old HD is compatible with other hardware eg. SCSI adapter?
Also can u post what devices are sharing the interupts...shouldn't be the problem though.

Commented:
Is there a setting in the BIOS or on the mainboard for Linear processing?  in the bios it will be under the Ram section.  if so det it to Linear.  Cyrix doesn't use a floating point unit in there CPU.


Bill
bbaoIT Consultant
CERTIFIED EXPERT

Commented:
No any problem you got during procedure of this installation?

Commented:
itinerant,
(I'd rather have the Fuji HDD than the TX-Pro M/B)

What devices are being shared by IRQs 14-15?
Do you have IDE controllers disabled in the CMOS?

Regards,
Ralph

Author

Commented:
There were no problems during installation, which was a burn and build, The IDE controllers are all set to "auto" in the CMOS, no "linear" setting in BIOS, (nb) Bios reports Co-Processor on Cyrix chip. Are you sure about the H/D it's the size of three housbricks

Commented:
Since you say "SCSI only" system, why are you allowing IDE controllers to possibly be enabled?
Ralph

Commented:
I've heard other problems with scsi and 98, have you booted with a log file to see if it's successfully loading that drive? or what other FAIL's you get, for that matter...
(hit F8 when win starts to load, choose bootlog.txt option)

and what IS being shared by 14 and 15?

Commented:
IT, Try these steps,
yea, they are right from the 98 troubleshooter, also on the RESKIT.
----
1.Restart the computer.
2.Press and hold down the CTRL key as the computer starts.
3.On the Startup menu, choose Safe mode.
THEN
1.Click Start, and then click Run.
2.In the Open box, type msconfig, and then click OK.
3.On the General tab, click Create Backup to back up your current system configuration files with System Configuration utility.
4.Click Diagnostic Startup, and then click OK.
5.When you are prompted to restart your computer, click OK.
6.On the Startup menu, choose Step-by-step confirmation.
7.When you are prompted to process the Autoexec.bat and Config.sys files, press the ESC key to bypass the files. Press ENTER to load all other items.
THEN
1.Restart your computer.
2.Press and hold down the CTRL key as the computer starts, and then choose Safe mode from the Startup menu.
3.Right-click My Computer, and then click Properties.
4.On the Device Manager tab, disable any devices in the following categories: Note
After you disable these devices, you may need to re-enable them in your CMOS settings. For more
information about CMOS settings, contact your computer's manufacturer.

Display adapters
Floppy disk controllers
Hard disk controllers
Keyboard
Mouse
Network adapters
PCMCIA socket
Ports (COM & LPT)
SCSI controllers
Sound, video, and game controllers

To disable a device
a.On the Device Manager tab, double-click the category name, and then double-click the device you
want to disable.
b.On the General tab, click to select the Disable in this hardware profile check box, and then click
OK.
c.Repeat steps a-b for each additional device. Do not restart the computer until you have disabled all the devices you want.

5.After your computer starts, enable one of the devices you disabled in step 3. Enable the devices in the following order:

COM ports
Hard disk controllers
Floppy disk controllers
Other devices

To enable a device
a.On the Device Manager tab, double-click the category name, and then double-click the device.
b.On the General tab, click to clear the Disable in this hardware profile check box.
c.Click the Resources tab, and then verify that there are no conflicts listed under Conflicting device list. If a conflict is listed, one or more of the conflicting devices must be configured to use different resources. For information about how to do so, consult the device's documentation or manufacturer.
d.Click OK.

6.Restart your computer.
7.Repeat steps 4-5 for each device until your computer does not start correctly. When your computer does not start correctly, the last device you enabled is causing the problem.
8.Restart your computer in Safe mode, and then disable the last device you enabled. This driver or device may be configured incorrectly or may be damaged. Consult your device documentation for more information.

lemme know.
Nathan Stanford SrSenior Programmer

Commented:
How much free hard drive space do you have on c:\?
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
IN WHAT way did my answer assist you, itinerant? i'd like to know because i want to see how much i am improving. thanks

Commented:
I'd like to know too.  Since it wasn't a solution to the problem at all.
Ralph

Commented:
I'd like an answer myself, since I'm having a seemingly untrackable 98/SCSI problem...

Commented:
Nebworth,
What's yours doing?
Ralph

Commented:
I am having a similar problem with an Adaptec 2940 and Windows 98.  The same controller and drive functioned properly for about a year under Win 95 and for a month or so under Win 98.  Then, I upgraded motherboards and the problems started.  My system boots off of the IDE drive.  I can boot up and run for days, but if I do an extended access of the SCSI drive (large program loads, moving the swap file to the SCSI, or running Scandisk), the entire system hangs up.

I have:
- Checked termination (looks OK)
- Tried to hang my system with the drive disconnected (can't do it)
- Done a full surface scan under the Adaptec BIOS utility -- via Cntrl-A on startup (no problems)
- Upgraded my Win98 drivers to the latest version from Adaptec (didn't help)
- Made sure the card was seated firmly in the PCI slot (it wasn't at first, but seating it better didn't help)
- Screamed and cursed (to no avail)

What I haven't done (Things I have found on the web that I will try tonight):
- Move the card to a different PCI slot
- Remove the card from the Device Manager and let Windows pick it up again.
- Check the BIOS on the card (which will be a pain in the butt if that is the problem since it is not flashable)
- Change cables, maybe to one with an active terminator on the cable and removing the termination jumper from the drive

Any further answers or suggestions would be welcomed.  It seems Adaptec doesn't know Win98 has been released -- there are no references to it on their web site.

Commented:
To cmpalmer try setting the bios so that the 2940 card has its own irq.  I use a 2940 with no problems. But I did have some problems in the past when it was sharing an irq with my LAN card.

hope this helps
bill
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.