We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Upload files

vpietri
vpietri asked
on
Medium Priority
174 Views
Last Modified: 2013-12-25
I have tried several perl upload scripts and I have the same problem each time. The server IIS 4.0 abort the connection when the files to upload have a size bigger than about 100 Kb. I have ever check the limiter parameters in the cgi-lib.pl and cgi.pm but nothing work. How can I solve this problem ?
Comment
Watch Question

Author

Commented:
Edited text of question

Commented:
I found that perl and IIS4 have some problems in cooperating.

The problems I found (and solved) are after upgrading from IIS3 to IIS4:
- perl scripts does not work at all
  solution: in the MMC, find where extensions are associated with external programs and change the perl association to: C:\Perl\bin\perl.exe %s %s. The %s must be in undercase.
- perl scripts that open files to write to don't work (including, but not only for uploaded files)
  solution: installed PerlISAPI (can be downloaded from the perlsite) and changed the registry manually:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\W3SVC\Parameters\Script Map

with a string value named .pl

.but it will have a value of :

C:\Perl\bin\PerlIS.dll

.you should edit the value so it's :

C:\Perl\bin\PerlIS.dll %s %s

This enabled perlscripts to write to files.

- Had some problems with NT write rights.

I haven't met your problem yet. Does your script work with small files ??


Commented:
Dont use PERL... Use something designed for ASP...

Author

Commented:
>My script work with small files.

>The perl ISAPI (PerlIS.dll) is already installed, I have changed the registry (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC\Parameters\Script Map\.pl C:\perl5\bin\PerlIS.dll %s %s) because this entry didn't existed but there is no change.

> In the MMC, the perl association is: C:\perl5\bin\PerlIS.dll (and nothing else works ..\perl.exe %s %s or ..\PerlIS.dll %s %s)

I really think that the problem comes from IIS 4.0 but I still don't know the solution.

Author

Commented:
I can't use ASP because of security problem.
The ASP solution would obliged me to create a FTP site that I don't want.
I prefer use the HTTP protocol to upload files on my server.

Commented:
There are some ASP solutions for using the HTTP protocol for file-upload. See for example SA-FileUp from SoftArtisans (http://www.softartisans.com/)

The "problem" is you have to pay for it.
The good thing about this one is that it can even upload into a database (i love that).

Concerning the perl-problem: I'll be trying to find a solution for that soon too. I wonder if I will meet your problem.


Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.