• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 494
  • Last Modified:

Hard Drive in DOS format?

I recently bought a JTS 4.3 GB hard drive, and it installed good. However, it is set for MSDOS mode and can only have 8 character file names on it. The drive did not come with a driver disk or anything and I can't find anything on the website (WWW.JTSCORP.COM) Any ideas?

Devin
0
devinm
Asked:
devinm
  • 7
  • 5
  • 3
  • +9
1 Solution
 
sailwindCommented:
If you want to use the long file names, then you might have to
use a new OS such as win 95,98, or NT. What exactly is it
that you want to do with the drive?
0
 
devinmAuthor Commented:
I am running WIN95 of course
0
 
jcnorkCommented:
When you boot up the computer, do you only get a dos prompt?
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
harley47Commented:
under the device manager are there any devies with ! next to them?  Is this hard drive the master drive?  Did you Reinstall windows on this drive?  If so does your motherboard have the TX or LX orBX chipset? If so did you run the patch for these chipsets. (you can tell by looking in the device manager under other devices there will be stuff like PCI card)  If this is just a second drive (not a new Master) then is virus protection turned on in the bios?  if so turn it off and from a DOS promt type fdisk /mbr


Let me know if this helps
if this does help I'll repost this as an answer

Bill
0
 
cmcgeeCommented:
You might want to check and see if your Long File Names are disabled.

Right Click on My Computer,
Click Properties,
Click on the Performance Tab
Click the File System Button,
Click the Troubleshooting Tab,
And check to make sure that Disable long name preservation for old programs is not checked (Or anything in here for that matter)

Have fun,
Craig

0
 
busukaCommented:
I have a guess (proved several times :)
- Enter BIOS Setup and change type of your HD from Large to LBA
- you must reformat HD after type change

Feel free to reject my answer if it is not your case and you already
have HD in LBA mode.
0
 
devinmAuthor Commented:
nope. already in LBA mode.... hmmm. Under the control panels and then performance, it says one thing: "Hard Drive in MSDOS Format" for the error.
0
 
harley47Commented:
does it say MSDOS Format or MSDOS mode?  What about the "other devices" in the device manager and the motherboard.  How about the Virus protection in the Bios?  
0
 
busukaCommented:
"... HD in MS-DOS compatibility mode". It can be caused by zillion
causes: some real-mode driver in CONFIG.SYS/AUTOEXEC.BAT or wrong
installation of busmaster drivers or conflict in Device Manager
or sound card IDE connector interfers or ... anything. Check also
BIOS Setup -> Integrated Peripherals that PIO mode for your HD is
Auto or PIO 4 (DMA 2). Also if you have simple (IDE/EIDE) HDD and
Ultra-ATA (UDMA) HDD on the same IDE connector, disable UDMA
support.
0
 
waynebCommented:
Try to boot off win95 disk and with fdisk on it and then type the command
fdisk /mbr and see if this helps you out.
0
 
plastic_74Commented:
OK now what you have is a 4.3 GB HDD right... and there is nothing wrong with your HD formatting.

First you must detect your HD using the BIOS HD DETECTION, then change your HD type to LBA. The DEFAULT type is normal, which is located at the end of the row, the same row of the HD settings (cyl, head, sector ....)

You must format your HD into 2 partition for your HD to work, coz the IDE can only recognize it to a max 2.?? GB only. If you are using the

If you are using - Win95 then the window software will recognize your file as a long file name.

When you change switch it to MSDOS then DOS will recognize your file as normal file name, that is 8 char.
0
 
devinmAuthor Commented:
No, it did not work. That was the exact method i used to install the hard drive. Hmm. Does the hard drive use drivers that can be loaded in the CONFIG.SYS does anyone think? Maybe an updated driver or something.. Hmm.
0
 
harley47Commented:
again I will ask are there any devices in the device manager under "other devices"?  What kind of motherboard do you have and is the virus protection turned on in the Bios


Bill
0
 
jom080298Commented:
If you already have a master harddrive (c:) and a new one will be a slave. Now you are in Window95, format a new one. then you can use long filename with it.

Thank.
0
 
plastic_74Commented:
Devinm,
I think we should leave the Config.Sys alone.... what I suggest is that, did you accidently mark any settings on the Windows Control Panel.

Coz... there are some settings there, where you can disable some of the system settings.

It is located at the System Properties, Perfomance, File System Properties.

plastic_74
0
 
plastic_74Commented:
Devinm,
I think we should leave the Config.Sys alone.... what I suggest is that, did you accidently mark any settings on the Windows Control Panel.

Coz... there are some settings there, where you can disable some of the system settings.

It is located at the System Properties, Perfomance, File System Properties.

plastic_74
0
 
rmarottaCommented:
To save time in solving your problem, it will be helpful to know more about your computer.
Please list the components of your system that might apply.
(Motherboard, CPU, RAM, Hard Drive(s), CD-ROM, Soundcard, etc.)
Please post your autoexec.bat & config.sys files also.
Regards,
Ralph

0
 
devinmAuthor Commented:
What do you mean, format a new hard drive jom??? I have a primary and a slave and the slave is already formatted. Ralph - remember me? You helped me build a computer previously. ;-) Anyways, the motherboard is an ASUS 1571, K5 100 MHz, 16 RAM, and JTS 4.3 GB hard drive which i can't get into WIN95 format. There isn't much in my config.sys and my autoexec.bat as i have just been building this sucker for someone. Harley47, no there isn't any devices listed under other devices. And yes, virus protection is on under the BIOS settings...
0
 
harley47Commented:
Turn off the virus protection then fdisk /mbr form a dos promt.  With virus protection turned on it locks out the master boot record and therefor puts the drive in MS-DOS compatability mode.

Let me know if this works and I'll repost this as an answer.

You might have to refdisk and reformat the drive.

Bill
0
 
NusseCommented:
What did You format it as?
0
 
rmarottaCommented:
Devin,

Bill's suggestion should work.

If there's nothing installed, I would go ahead and re-partition after first deleting any created previously. (Just to start clean.)

Regards,
Ralph

0
 
newexpertCommented:
* Edit your Windows 95 Registry under
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\FileSystem

* Set value of Win31FileSystem to 0

* Restart the computer.

* If you don't know how to use regedit.exe then do the following:
* Create a text file and put the following lines between stars in
  the text file. (don't include the stars)
*************************************************************
REGEDIT4

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\FileSystem]
"Win31FileSystem"=hex:00
*************************************************************

* Save the file as "lfn.reg"

* Now double click the file.  You should get some acknowledgement
that Information has successfully been entered into the registry.

* Restart your computer.

Note all the short name remains short names but now you should be able to create long filenames (or rename some of them to long filenames)
0
 
devinmAuthor Commented:
Newexpert: Good idea! Although, i checked the registry and that value was already set to 0. Thanks for the idea though, good one!
Bill: I did what you said and turned virus protection off and fdisk'd it again. Voilla, it worked and it is now in Win95 format. Thanks!
0
 
devinmAuthor Commented:
Newexpert: Good idea! Although, i checked the registry and that value was already set to 0. Thanks for the idea though, good one!
Bill: I did what you said and turned virus protection off and fdisk'd it again. Voilla, it worked and it is now in Win95 format. Thanks!
0
 
devinmAuthor Commented:
uh oh. i accidentaly accepted newexperts answer. what should i do?
0
 
harley47Commented:
well devinm It's not the first time some one else has gotten points that I should have gotten (and I'm sure it won't be the last)  I'm just glad your problem is solved.

Bill
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 7
  • 5
  • 3
  • +9
Tackle projects and never again get stuck behind a technical roadblock.
Join Now