Solved

Please kill my Bios

Posted on 1998-08-08
29
272 Views
Last Modified: 2010-04-26
Even an expert needs help sometimes.
I have a 1993 Gateway HandBook.. It has a  removal battery pack and an internal battery which is soldered in.
 there are no jumpers near the bios nor the battery Or anywhere as a matter of  fact. With as many computers as I have worked on in the past this is a first  for me.  I remove the internal battery for over 30 days and a bios still retained  its original information. Might I add that I had installed a password, now forgotten.  This puts me in a predicament. I intended to give it to a neighbor boy for some help around  my house.
this little portable is not worth more than 50  to 75 dollars.  Gateway tells me the only way to clear the password is to send it in for repair.................   BUNK!!   It will  cost  me more than the computer is worth, then to have them fix it.
If  Gateway can clear the bios so can I.  I just lacked the knowledge that they have.
This is what it has:
8680 CPU.(80286 like)........SCAT Bios....Whatever that is, ........two TC518512FTL-80(512X8) rams
Shoot..... I am beginning to thinking that it may even have  bubble memory of some sort. There is one chip that has 16 pins and some small parts coverd patly by a plate.?????
Well, there you go.  Can you find a solution to my problem?
 Thanks......  ICVR
0
Comment
Question by:ICVR
29 Comments
 

Author Comment

by:ICVR
Comment Utility
Edited text of question
0
 

Author Comment

by:ICVR
Comment Utility
Adjusted points to 180
0
 
LVL 1

Expert Comment

by:newexpert
Comment Utility
From memory the old computers didn't have CMOS discharge jumpers.  All you need is a piece of wire and wrap that around one of the IC Chip for a few minutes to discharge the CMOS.  You can try get a strip of wire, wrap it around every chip for a few minutes (make sure all pins of the chip are in contact with the wire).  Hope that will work.

If it was a design where discharge jumpers are far away from the bios then there's a little trick you can perform

While the computer is off
For all 2 pins without jumpers put a jumper in for several mins then remove it.
For all 3 pins jumpers move the jumper to the other position for several mins then move it back.
Repeat with all jumpers.  And the bios should be cleared.
0
 

Expert Comment

by:bios072698
Comment Utility
Against all logic, there seems to be a bios upgrade for this machine.  

http://www.gw2k.com/home/support/hardware/28602/

Perhaps upgrading the bios will automatically reset the settings, since there appears to be no way to clear the cmos. If you can get the bios out, you might be able to burn the new one in with an eprom burner.
0
 
LVL 7

Expert Comment

by:cmcgee
Comment Utility
You may want to try KillCmos . It has worked for me numerous times and it was never necessary to remove the case.

http://www.mindspring.com/~deathboy/index.html
http://www.windrivers.com/utility.htm

Hope this helps,
Craig
0
 
LVL 1

Expert Comment

by:x30
Comment Utility
try to over write the bios with an older version then rewrite with the actual or if it possible a newer version of the bios.
0
 
LVL 1

Expert Comment

by:avtronics
Comment Utility
Hello, a file from the site ( http://www.knoflach.com/uha1/ ) called BIOS.zip has many bios cracking programs. It causes the bios to return to it's default state. If that will not work and considering the value of the unit itself you can always try to short out the bios chip itself under power, I have done this on some 286's and 386's with excellent results. May sound bad, but at the cost of the board, it's worth it.
0
 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
ICVR,
Discharge the soldered-in internal battery using a resistor or flashlight bulb.
Now we need some feedback from you.
Regards,
Ralph

0
 
LVL 12

Expert Comment

by:mark2150
Comment Utility
Some of the machines use a EEPROM for BIOS settings. Ain't no battery required. There are also low power CMOS RAM's where the battery is built in to the IC package. (Look for an "extra thick"  .6" wide IC...)

0
 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
He already told us that the machine has "....an internal battery which is soldered in."

Any luck yet, ICVR?

0
 

Expert Comment

by:Subzero
Comment Utility
                 Hi  there !!!!!
It's really easy !!!
Try to assemble and link this prog...
ideal
model small
assume cs:@code,ds:@data
codeseg
start:
             out 71h,al ; Thats all !!!!!
             mov ax,4C00h
             int    21h
dataseg
stack 200h
end start

Start this prog..and reboot your system, then wait the message "
Press F1 to..."

If you can't make this prog...then write mess to me with your email adress and i send that prog to you....

That is REALLY coders method !!!
 Sorry for my english....

With best WISHES -=SubZero=- aka WiZard
0
 

Author Comment

by:ICVR
Comment Utility
Thanks for the great help friends.   So far, no luck.  I had tried everything but, Shorting out the ICs while the power is on,  This I think I will hold off for the final attempt.
As for using any programs to change the bios, the password comes up even before the memory begins counting.  So injecting code  is out all the question.(LOL)
Its seams that the direction I'm looking at is with  Mark2150  above.
There's not much of a reference on the  Internet for SCAT  bios, so if you know anything about them ......  So let's say that the chip has a battery of a sort on board.  Without destroying the chip,  the best away to short out the chip would be  what?  I have tried shorting all leads on the chips with the power off, ( I'm afraid  that some of  the on-board resisters may not take a liking to the power of being on).
     Well I think we are on the right track.  I see I am not aloan  with this problem,  judging  by what I have seen on the Gateway news groups.  I will make this outcome definitely public knowledge.
        Any more suggestions is more than welcome.
thanks  ICVR
0
 

Author Comment

by:ICVR
Comment Utility
Adjusted points to 200
0
 
LVL 3

Expert Comment

by:khemicals
Comment Utility
if you post your email address i can post a program that has always worked for me in the past when i needed to get around a CMOS password... it creates a checksum error and resets the bios to defaults... it has been used on some desktop 286s that I have used... maybe it wont work but is worth a try. Ignore the fact that it is written for a specific bios... has worked on all i have used it on...

so post your email address and i will send it to you
0
New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
I thought you said it had "....an internal battery which is soldered in."

Ralph
 
0
 
LVL 1

Expert Comment

by:newexpert
Comment Utility
I didn't mean short out IC when power is on, I mean when power is off...
0
 
LVL 1

Expert Comment

by:newexpert
Comment Utility
You see CMOS is suppose to be running even when main power is off.  So shorting it out discharges its memory.

I don't think password was, is or ever will be put into the BIOS which in most cases are ROM, EPROM or EEPROM, and cannot be reprogrammed(updated).  286's BIOS would probably be ROM and not erasable without UV.  Therefore your password cannot possibly be there.

Old 286 don't come with CMOS discharge jumper.  So your only choice is to short out the power supply pins that feed into the CMOS memory chip.  That's what I mean wrap a piece of naked wire around it for a few minutes.  If the chip has internal battery that would be killed too.

0
 
LVL 1

Expert Comment

by:dumbscotty
Comment Utility
How about throwing it away and giving the kid 50 dollars?
:-)
0
 

Accepted Solution

by:
tangkh earned 200 total points
Comment Utility
Ask the Gateway newsgroup if the bios is stored in the EEPROM, FlashROM, conventional CMOS RAM that requires battery backup, etc.. then fix it accordingly.

FlashROM is very unlikely to be found in the old machine. So as the EEPROM.  SO the only possibility is the CMOS RAM with a piggy-back battery, which is considered as an leading technology back in 286 time.

Discharging this type of CMOS isn't easy as the supply to the CMOS chip itself isn't exposed. Shorting the pins doesn't really help, because it normally has the diode built-in to prevent negative transfer of the power back to the mainboard.

Therefore I think doing it from the hardware isn't really a practical approach. It should be done at the software. Have you tried out several software suggestions from these folks? Tell me if it doesnt work, I will suggest another software method.
0
 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
If you have a re-chargable CMOS back-up battery soldered onto the board, it IS easy.
Just take a couple of alligator clip-leads and connect a flashlight bulb across the back-up battery's terminals.
Come back tomorrow and the CMOS will have reverted to default values.
Regards,
Ralph

0
 

Expert Comment

by:tangkh
Comment Utility
rmarotta, he has mentioned that the internal battery has been removed for 30 days and still couldnt get it erased...
0
 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
Nope, that was the laptop's battery-power source.
I'm speaking of a soldered-in, CMOS back-up battery.
Ralph

0
 

Expert Comment

by:tangkh
Comment Utility
rmarrota, and he also said "there are no jumpers near the bios nor the battery Or anywhere as a matter of  fact"...
0
 
LVL 9

Expert Comment

by:rmarotta
Comment Utility
What does that have to do with killing the CMOS battery?
(using a load connected to the battery's solder terminals with some clip leads)

0
 

Expert Comment

by:tangkh
Comment Utility
I believe he has looked around for the CMOS battery yet couldnt find it.
0
 

Author Comment

by:ICVR
Comment Utility
tangkh........
Your viewpoint seems to fall along the same line as to what to I have expected.
The disk drive is external,  and as fast as the password pops up I don't think the drive would be able to inject a program.  So using software seems to the out of the question.
It is to my opinion that the reason why Gateway requires the unit  returned to them, is so they may remove the expanded memory chip And install a ROM with a sub program that reset's the bios.
But yet there should still be a way to get around this............. perhaps not.
I have set one last final email to Gateway technical support giving reference to getting his car fixed at a price over the value of the car.  Perhaps this will at the verry least get a response  to what HE must do to remove the password.  If and when he does reply, and gives me a reasonable answer, I'll let you know
But if any one could configure out how to defeat the CMOS ROM I'll appreciate it.
And as for  dumbscotty the boy wishes a computer, if I gave him 50 bucks I'm sure he would not have long, or his parents will probably confiscate it.
Thanks
      ICVR

0
 

Author Comment

by:ICVR
Comment Utility
By the way...... ALL Batteries have been removed
0
 
LVL 2

Expert Comment

by:warmcat
Comment Utility
ICVR, I can't fix your problem, but I can fix your little confusion here... The BIOS is something that is nonvolatile, probably in an EPROM.  It cannot get overwritten or disappear because the battery ran out - in fact it is the BIOS code which is giving you the password nightmare right now.

Your problem is coming from the fact that having removed the battery that backed up the CMOS RAM, the contents are random and probably different every power-up.  Unfortunately it is in this RAM that the BIOS stashed its copy of the password.

The engineer dude plans to replace your battery with a new one, pull out your SCAT (ha!) BIOS EPROM, and stick in a custom EPROM instead.  This custom ass-saving EPROM simply zeros the CMOS RAM and halts.  Then he plans to swap your normal BIOS EPROM back in, and bingo, no more password.

0
 

Author Comment

by:ICVR
Comment Utility
Well I think that is about it .......
Thanks all of you for your input
ICVR
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now