We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now


changing program icon on desktop

seekfind asked
Medium Priority
Last Modified: 2010-08-05
When I install a new program instead of windows placing the startup icon for the program on my desktop it is replacing it with the a window's generic icon. I've gone into the shortcut menu, I see the appropriate icon, and I've tried to change the icon for the program, but it wont change on the desktop. Can someone tell me how I can work around this problem?
Watch Question

you may want to delete your shellicon cache file and reboot.

This can sometimes store the windows default icon for all shortcuts.

You can delete this file and it will rebuild itself when you reboot.

Hope this helps,
You might want to try to change the color depth of your display, and then restart your computer, or alternatively start your computer in safe mode by pressing F5 right after your bios checks are complete. That should have the same effect as deleting your shellicon file.

delete the shortcut on your desktop... right click on the start button and select open, navigate your way to the shortcut within the startmenu. highlite the correct shortcut icon right click and copy it, close all the open windows. rightclick on any blank portion of your desktop and paste it.


I tried all the suggestions, but none of them worked. Maybe someone can suggest something else I can try.
Hi Seekfind.

Download a copy of TweakUI (http://www.microsoft.com/windows/downloads/bin/W95tweakui.exe). It will install an applet in your Control Panel.  Double click on the TweakUI icon and select Repair from the list of tabs across the top of the window.  

From there you will be shown five buttons.  Click on the rebuild icons buttons.  It will rebuild all icons which are being displayed incorrectly.

Hope this helps,



Sorry Stuart, it didn't work. I believe the problem is with the file type defined in settings under folder options, because the icon associated with applications is the generic icon and the edit option for some reason is not available for me to make changes. Does anyone out there have any suggestions?
Hi, Try deleting the icon from your desktop, then using Explorer or My Computer , copy the shortcut that you want to the C:\windows\desktop folder.


Sorry Dumbscotty, I already tried that. Thanks anyway. I guess this will just remain one of those unsolved mysteries for me. :(

So this only appears as the wrong icon when it is on the desktop? What about when you copy it to a folder, or create an icon in a folder? Will moving a copy of an existing shortcut (say, from the Start Menu) to the desktop cause it to change? What is the shortcut to, exactly? (which program)

I know a software program called "MicroAngelo" which can enable you to change and create program icons and cursors.  If you wish, i can send you a copy or you can download it from the net.  This is a shareware wersion and can be evaluated free for thirty (30) days.


Thanks mmmanansala, the program "MicroAngelo" worked like a charm. After downloading it and I was able to replace windows default icon with the the icon for the program. I'm a happy man. :) Thanks again.

rightclick on the icon in the start menu after deleting the shortcut on the desktop, then after the right-click menu opens, select "Make a shortcut" or something. so that to the desktop.
Can I convert my comment to an answer to get the points?  Thanks...


You sure can  MMMANANSALA. I appreciated your help and thanks again.

open regedit, search for *.  remove ny icons from its definition.. this could do it...

You have to unlock the question first before I can post an answer.  Thanks again...
Unlock this solution and get a sample of our free trial.
(No credit card required)
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.