Solved

Accounts not shown in USRMGR ?

Posted on 1998-08-11
13
245 Views
Last Modified: 2013-12-28
I run a standalone NT Server 4.0 SP3.
Suddenly ALL accounts are no longer visible within the GUI in USRMGR.
I can still create new accounts, but afterwards they don't show up in the GUI.
I still see all the groups, and I can add/remove accounts to them.  

Note that since that point "Adduser /d" is looping. "Net Users" doesn't show accounts anymore.
The system still works fine. The only thing is I can't look at  and manage existing accounts !
I've also checked their existence and security within registry. But there is no difference to another
system of mine which has no problems with USRMGR.  
Any help is welcome.
Thanks in advance
 Jürgen
0
Comment
Question by:jkrautner
  • 6
  • 2
  • 2
  • +2
13 Comments
 
LVL 2

Expert Comment

by:Rincewind
ID: 1788415
Is your server a domain member? If so, to view your domain-accounts you need to use the usermanager for domains.

(available on any BDC or the PDC of your domain in the %systemroot%\system32 directory.)
0
 
LVL 1

Author Comment

by:jkrautner
ID: 1788416
It's a standalone server, not participating in a domain.
And remember it used to work !
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1788417
Anything in the event viewer to speak of?
0
 

Expert Comment

by:s_chugh
ID: 1788418
If you have emergency repair disk which you prepared before coming this problem. . You can try to repair user database with the help of ERD.If you are having erd you can try this...
0
 
LVL 1

Author Comment

by:jkrautner
ID: 1788419
I enabled auditing (success/failure on 'use of rights' and 'user/group mgmt') .. but there
is nothing usefull in the eventlog.
I also used REGMON:  I see that usrmgr/lsass are scanning the registry (for all accounts) and all the reads are successfull, but no account data is displayed. The funny thing is
that account related dialogs within USRMGR (i.e add/remove from group, add/remove
user rights) work fine i.e they display all the users    
0
 
LVL 1

Author Comment

by:jkrautner
ID: 1788420
I don't have an uptodate repair disk.
Well, it's not an important or a production system, therefore I can easily reinstall and recreate the accounts.
But I wan't to find out what's wrong.  A system only does what it has been told to, unless
something is really corrupt.

0
Will my email signature work in Office 365?

You've built an email signature using raw HTML code in Office 365, but you can't review how it looks with Transport Rules. So you have to test it over and over again before it can be used. Isn't this a bit of a waste of your time? Wouldn't a WYSIWYG editor make it a lot easier?

 
LVL 2

Expert Comment

by:Rincewind
ID: 1788421
Since other apps are showing users correctly, I would go for the following:

- run chkdsk on your system partition and see if this turns up anything
- check all usrmgr files against the original NT cd and/or SP3 installation. Any changes there?

This is indeed a very strange problem.. I would love to know what has gone wrong here too.. ;-)
0
 
LVL 1

Author Comment

by:jkrautner
ID: 1788422
Chkdsk runs without complaining about anything.
I connected via another machines USRMGR to this very node... same effect.. no accounts
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1788423
I believe the sam is corrupted and can only be fixed by with repair disk or by running winnt32.exe and selecting repair, there are default repair files on the harddrive and it can be put back to normal with them.  This is only a begining problem and I believe it would get worse over time.
0
 
LVL 1

Author Comment

by:jkrautner
ID: 1788424
I found a solution, but I don't really know why this happened. I focused on the
looping "addusers /d" and monitored it with regmon and found out that it was reading
the same keys over and over again.I went into REGEDIT and found that HKLM\sam\sam\domains\account\aliases contained a
key named 000003EB. The same key was found in sam\sam\domains\account\users
along with some others. But the contents of the 'others' looked a little bit different
and therefore i simply did a cut&paste of the contents of the key !
Guess what ! It was a good try. The accounts are back. visible. manageable ...

Thanks for all your hints.

0
 
LVL 7

Accepted Solution

by:
linda101698 earned 200 total points
ID: 1788425
I'm posting the solution found by jkrautner so it can be saved in the PAQ.

Linda Gardner
Customer Service @ Experts Exchange

Solution:
I focused on the
     looping "addusers /d" and monitored it with regmon and found out that it was
     reading
     the same keys over and over again.I went into REGEDIT and found that
     HKLM\sam\sam\domains\account\aliases contained a
     key named 000003EB. The same key was found in
     sam\sam\domains\account\users
     along with some others. But the contents of the 'others' looked a little bit
     different
     and therefore i simply did a cut&paste of the contents of the key !
     Guess what ! It was a good try. The accounts are back. visible. manageable
     ...
0
 

Expert Comment

by:s_chugh
ID: 1788426
I suggested you to try erd(emergency repair disk) I think It would have done the same thing automatically which you have done manually. Please tell me you really tried with ERD.

Thanking You

Surinder Chugh
0
 
LVL 1

Author Comment

by:jkrautner
ID: 1788427
I didn't use ERD. Of coures it would have been an option. But first of all i really wanted to know what was wrong and second I would have had to reenter lots of accounts because the erd-disk wasn't up to date.



0

Featured Post

Do email signature updates give you a headache?

Are you constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Compromised PC? 17 178
forgot pst password 2 41
Dual boot for S.O 7 35
Desktop items cannot be moved / deleted 10 53
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now