Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 406
  • Last Modified:

inittab setup for mgetty . . .

We currently have a modem setup on our system so that we can make a ppp
connection to other systems.  This setup is sometimes unreliable and we suspect
that it is because that connection is being serviced by getty, instead of mgetty.  In
setting up for mgetty I think I've made the appropriate entries in gettydefs.  Now I'm
not sure how to make the appropriate entries in /etc/inittab, so that mgetty knows
to look in gettydefs.  Some of the principle issues I'm concerned with are:

a.)  Making sure that the port can continue to be used the way that it has been, both
for ppp and direct login.

b.)  Solving our problems with not being able to use the port again, when the line drops
improperly.

Question:  What is the appropriate string for setting up inittab, for mgetty, so that it can
do auto-baud rate detection?
0
otser
Asked:
otser
1 Solution
 
alexbikCommented:
Hi,

If you use mgetty with 'default' settings you'll be fine.
You may want to compile in Auto_PPP support, so your users can login
from W95 /NT machines without a loginscript. But that's a bit beside the point here.
Take a look at mgetty.conf, configure the default settings for your modems
(speed, initstring and stuff), and take a look et login.conf.

From inittab, you can start mgetty with mgetty /dev/ttyXXX -D
The -D disables 'adaptive answer mode'. If you don't and you are using fax modems
(you probably are), mgetty tells your modems to try to find out weahter there's a fax
or a modem at the other end of the line. This sometimes results in failed V34 handshakes.

The only thing you may want to change is the login prompt (-p), so you can keep using
your old loginscripts. Just put -p <login prompt> at the command line. If you don't
the default login prompt looks like

<machine_name>!login:

So if your machine is called cs-01 it will be:

cs-01!login:

Your old getty probably uses a space instead of a bang.

Alex.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now