• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 160
  • Last Modified:

binding and pinging W95

null
0
dovedove
Asked:
dovedove
  • 5
  • 2
1 Solution
 
dovedoveAuthor Commented:
Please help!!
0
 
fmismettiCommented:
dovedove:
I understood that you are unable to ping Machine A from Machine B and vice-versa. If this is true your TCP/IP setup is totally wrong, at least for the network cards. Do you have TCP/IP installed for the net cards? If yes, what are the settings?  Which IP you are using for the network card (look in Control Panel, Network, TCP/IP->network adapter)?
Need more details to help you.


0
 
czamudioCommented:
in the network control panel, press add button
then select protocol
then in the left panel select microsoft, then select tcpip

this procedure must install and bind the tcp/ip to your network card.

and in my personal experience, it's better to use linux + IP Masquerading.

other solution wil be too expensive.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
dovedoveAuthor Commented:
Thankyou for the answer czamudio, however I have already elected TCP/IP etc......
Also I think that linux is a separate OS. If so we do not have linux.
0
 
dovedoveAuthor Commented:
Thankyou for the answer czamudio, however I have already elected TCP/IP etc......
Also I think that linux is a separate OS. If so we do not have linux.
0
 
dovedoveAuthor Commented:
Thankyou for the answer czamudio, however I have already elected TCP/IP etc......
Also I think that linux is a separate OS. If so we do not have linux.
0
 
fmismettiCommented:
Let's see if I can help you. You have two equipments, one with network adapter (let's call MachineA) only and the other with net adapter and modem (MachineB).

Configuring the MachineA

Open Control Panel, NetWork, you need to have in the configuration tab: Client for microsoft networks (service), Your network card (adapter), Netbeui (protocol), TCP/IP (protocol), File and Printing sharing for MS networks (service).
If you don't have all these item, add. Click on TCP/IP protocol, properties and make the configuration: on tab TCP/IP address, put specify and IP address and enter a public IP address, like "10.1.1.1", netmask "255.0.0.0". Disable DNS, WINS and remove any gateway at this time; on tab bindings, turn on both items.

Reboot the machine. Open a DOS box and enter the following command:

PING 10.1.1.1

You are pinging the local machine but using the net card. You need to receive an answer similar to:

#begin of screen capture
Pinging 10.1.1.1 with 32 bytes of data:

Reply from 10.1.1.1: bytes=32 time<10ms TTL=128
Reply from 10.1.1.1: bytes=32 time<10ms TTL=128
Reply from 10.1.1.1: bytes=32 time<10ms TTL=128
Reply from 10.1.1.1: bytes=32 time<10ms TTL=128

Ping statistics for 10.1.1.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum =  0ms, Average =  0ms
#end of screen capture

If you receive an error, something is wrong. Don't proceed and review the settings.

Configuring the MachineB

Configuring MachineB is almost the same. But MachineB has a modem, then in the control panel you have NetWork Card Adapter and DialUp Adapter. Then you need to have the following protocols: NetWorkCard->TCP/IP, NetWorkCard->Netbeui, DialUpAdapter->TCP/IP. If no, add this protocols.

Click on NetWorkCard->TCP/IP, Properties, and repeat the configuration, but use IP "10.1.1.2", same netmask. Note that in
DialUpAdapter->TCP/IP you need to leave as "Obtain an IP address automaticaly" because this IP is given by your ISP at connection time. Reboot MachineB. Try to execute: Ping 10.1.1.2. If this is wrong, review your settings.

At this point, try, from MachineA, Ping 10.1.1.2 (machineb) and vice-versa. If this is OK, you have you TCP/IP network running between you 2 PCs.

The main difference is that, when connected to the Net, MachineB will have two IPs: here you will have to deal with gateways, proxy and so on.

The idea is simple: you need to tell MachineA that it needs to go to external Internet using the gateway MachineB (that is connected by modem). With plain Windows 95 this is impossible. You will need a proxy server, and the configuration varies from each brand. But this is another phase, and the documentation of you proxy server should tell you how to do.

Hope this could help you.
0
 
dovedoveAuthor Commented:
Thankyou very much fmismetti. Your answer to my question was given with extensive detail, in general the details were similar to my machines. However, a few small variations which I would assume apply to the W95 version.. I have removed the TCP/IP on the client station and reinstalled. I then set up the two computers following your suggestions. The client station is now able to ping itself, also pinging between computers is successful. Furthermore, I am able to dial out from the client, through the computer with the modem connected. It works fantastically! I am really pleased with the results. I owe you one fmismetti. Also thankyou to Experts Exchange for this service. How small the world has come as a result of the Internet!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now