Solved

Running Video CDs under W95/98

Posted on 1998-08-13
19
190 Views
Last Modified: 2010-04-26
I've been assured by a friend that Windows 95/98 will play films released on the Video CD format via Active Movie. From what I've seen of the two Video CDs I've borrowed, I believe that he is correct - but my system is dreadfully inconsistent in the way that it treats these discs.

Even before I started trying to view them, I had problems with auto-insert notification - it kept "reactivating", so I would get the same program trying to run several times which was very frustrating. I disabled it.

Then W98 started playing up by either failing to register that the CD drive was connected, or telling me that I had an audio CD inserted, even when I had put a Video CD in the drive. Ejecting and reinserting the disc cleared this eventually, but it keeps re-occurring.

After fiddling with the devices in the Multimedia window under control panel I managed to view a half hour section of a video CD before it locked up on me.

My system frequently crashes out, and I've had messages telling me that "an exception has occurred at 0028:C1827442 in VxDCDVSD(03)+000027C2. This was called from 0028:C1826C5C in VxDCDUSD(03)+00001FDC". Whatever that means.

I've tried installing the original CD driver (it's a creative 24 speed) but this has had no effect.

My friend tells me that his system is stable, even during and after running Video CDs, so what's wrong with mine?

Oh, btw, I disable all extraneous applications before running Active Movie, but this doesn't always work.
0
Comment
Question by:EricCartman
  • 7
  • 3
  • 3
  • +4
19 Comments
 

Expert Comment

by:MarcelM
ID: 1122746
Do you have an MPEG card installed?

MarcelM
0
 
LVL 3

Expert Comment

by:varun071898
ID: 1122747
Get the latest Media Player from Microsoft. It supports a variety
of multimedia files and gives troublefree performance. If
it works for you add a comment so that I can post this as an answer.

Also MarcelM, I don't think it is really important to have a
MPEG card to play video CD's. I don't have one but I still
can see Video CD's in full screen.
0
 

Author Comment

by:EricCartman
ID: 1122748
As Varun suggests, I don't have an MPEG card and I didn't think I could run Video CDs until I was told I could by a friend.

I'll d/l Mediaplayer (I thought it already came with W98?) and see what happens.
0
 

Author Comment

by:EricCartman
ID: 1122749
Downloaded Mediaplayer and tried accessing the Video CD ("Forrest Gump", if it's important). My computer locked up and I had to use ctrl-alt-del to unfreeze it.

I'm convinced it's the CD that causing the problem - on some occasions I can access its contents in Explorer, on other occasions I'm told it's "not ready" (even though there's a disc in the drive) and on a couple of occasions I've found that the Bios doesn't recognise that a CD drive is attached! I've lost count of the number of times I've had to press the reset button because the system has locked while I tried to access a video CD - the thing just doesn't seem to want to know. (It's a Creative 24xMX, btw)

Come to think of it, I've only had a problem since installing W98, which I did a day after I installed a new hard drive into the system.

I was sure all the cables were connected properly, and the computer doesn't get moved around at all, but could this be a CD rom connection problem? I'll open it up and have a look...
0
 
LVL 3

Expert Comment

by:varun071898
ID: 1122750
If it is only one CD that is giving you problems try to run it in any other computer. If it doesn't run fine there, then the CD is faulty. If it runs fine there do the following:
There is a CD cleaner available ($4-5) run it.
0
 
LVL 2

Expert Comment

by:plastic_74
ID: 1122751
EricCartman,
You can actually run VCDs on your System alone without any MPEG cards.... if your PC supports MMX technologies then it should be no problem running VCDs without MPEG cards.

If hardware no problem then you should hunt for software then.... here are the site that will help you, just download this XingMpeg software :"http://www.download.com/PC/Result/Download/0,21,0-45711,00.html?st.dl.tdtl.txt.tdl" and if you can't download from this site than maybe I can mail mine to you.

Good luck :-)
0
 
LVL 2

Expert Comment

by:plastic_74
ID: 1122752
My e-mail add is : "mun_hong_gan@schindler.com"
0
 

Author Comment

by:EricCartman
ID: 1122753
Downloaded Xing MPEG and ran it. It displayed a single frame from the VCD in the drive, and then locked up. I tried changing various settings (accelleration, MMX detection and so on) but this single frame was the best I could get.

I restarted the computer, and my system informed me that there was no VCD in the drive, and it thought it was an audio CD!

I have now tried running Video CDs  with Active Movie, Windows Media Player, the CompCore softpeg player and Xing. The best result I ever had was with Active Movie, but since that one occasion (I managed to see a whole half an hour before the system crashed) I've had no luck.

I am convinced that this is a hardware problem (or a Windows 98 fault?). I've cleaned the drive and the CD I'm playing, but still get this intermittent and annoying failure.


0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1122754
Eric,
First, I'd check hardware settings.
Boot in safe mode and go to Device Manager.
Check all device listings for duplicated entrys, and if any are found, delete every occurance listed for that device.
Windows should re-detect and install them correctly on the next normal boot.
Let me know how it goes, or if you need help with this.
Regards,
Ralph
0
New! My Passport Wireless Pro Wi-Fi Mobile Storage

Portable wireless storage to offload, edit, and stream anywhere.

High-capacity, wireless mobile storage designed to accompany professional photographers and videographers in the field to easily offload, edit and stream captured photos and high-definition videos.

 

Author Comment

by:EricCartman
ID: 1122755
I removed a number of devices from the list under "multimedia" in the control panel, but aside from getting a bit further into the Video CD (a different one to the one that started me off on this) there was no improvement.

The failure of a VCD also makes my system terribly unstable and usually requires a restart to clear it.

I'll be interested to hear any more suggestions as to what might be causing this, but I won't be able to act upon them for a few days since I'm going away for a short holiday.

Thanks to all those who've tried so far.
0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1122756
To go to Device Manager:
Right-click My Computer icon, select properties, and click Device Manager tab.
Do that, and try what I suggested to get all devices installed properly.
Ralph

0
 

Expert Comment

by:eschatar
ID: 1122757
If you copied the CD's (Burned them from silver to gold disks), that may be your problem.  I've had similar troubles with data CD's I made under Win95.
0
 
LVL 6

Expert Comment

by:joopv
ID: 1122758
I think there is a problem with your video card and/or driver.  Try updating the driver to the latest one, or swap the card including the drivers for a completely different one.

0
 
LVL 9

Expert Comment

by:rmarotta
ID: 1122759
Eric,
From what I can tell from your comments, your CDROM has trouble reading CDs.  Not video troubles.......

I think you are confusing the hardware "devices" I refer to in my comment, with the media control devices listed in the multimedia section of Control Panel.

Have you tried what I suggested yet?
Regards,
Ralph
0
 

Author Comment

by:EricCartman
ID: 1122760
Having looked in the device manager, I didn't find any repeated entries to remove, so I've left things as they are.

I downloaded the latest drivers for my Mystique card, and using the FinalReality benchmark I noted a slight improvement in speed. But when I tried running SiSoft Sandra's CD-Rom benchmark (which can use a VideoCD) I was given a "drive access error" no matter which VCD I used.

I don't have access to another 2D card, so this option is out.

I wondered if the Voodoo2 card I have in my system was causing a slow-down of 2D performance, so I disconnected the "pass-through" cable from my Mystique, and ran the monitor directly off the Mystique. Running the benchmark again yielded almost identical results (a 0.01% improvement!) so there doesn't appear to be a problem there.

When I tried to run a VCD with XingMpeg the video started, but locked up and jerked along for a minute or so until jumping to the end of the disc, then back to the beginning. It was trying to run, but failing.

Running MediaPlayer yielded an "unexpected failure" error (8000FFFF). The video started, but I could hear the drive struggling and the image was full of glitches. It locked up before I even got to the opening credits.

I've emailed Creative to ask if they have ideas what might be going wrong, since the literature that came with my CD-rom said that it was able to handle VCDs.


0
 
LVL 6

Accepted Solution

by:
joopv earned 90 total points
ID: 1122761
From the video-cd, the file that contains the actual movie data (audio + video) is the avseq01.dat file that resides in the mpegav folder on the cd.  This is a 500+ MB file.

I suggest you do the following :

Copy this file to the harddisk entirely.  Don't make a shortcut!  Then, compare the file on the harddisk with the file on the cdrom drive.  You can use the FC command in a dosbox.

(the copy and FC operations will take some time !)

If they are the same, try playing the movie from harddisk and see what happens.  If they are not the same, there is a major problem with your cd drive, cable, or IDE interface.

Playing video from a video-cd is quite demanding for your system.

0
 

Author Comment

by:EricCartman
ID: 1122762
JOOPV has apparently hit the nail on the head, although I'm now in a situation where I still don't know what to do.

I was unable to copy the .dat file from the VCD. It started copying normally, but after a minute or so I had a message telling me that the system was unable to read from the CD.

I don't have any other CDs with such large files on, so I tried copying the W98 disc to hard drive in its entirety - the copying got about half way through then I had a message telling me that my system was unstable and I had to reboot.

So it seems that my CD, or Windows 98, is unable to handle large volumes of information at once, which would account for the VCD problems since the files are so huge.

But how do I go about establishing whether it's the CD or Windows 98?

And do I give JOOPV points for helping me narrow the problem down, and then post a separate question, or carry on waiting here for a solution?
0
 
LVL 6

Expert Comment

by:joopv
ID: 1122763
Some more suggestions :

Copy large (>100MB) amounts of data around on your harddisk, from one folder to another and back.  Stays the system stable ?  Compare the data you copied with the original.  Is there no data corruption ?

If this all goes well, and assuming you have IDE disk and cdrom on the same IDE port,  i would guess that IDE port and cable is ok, and the cdrom drive is probably broken.

If your cdrom is on an different IDE port - well, you don't know anything yet.

Another thing you can try : boot the system from a DOS floppy with the dos cdrom drivers (idecd.sys(or something alike) and mscdex).  Check if you can copy the large file under DOS.

0
 

Author Comment

by:EricCartman
ID: 1122764
I finally succeeded in copying the AVSEQ.dat file to my hard drive, all 600+Mb of it, and started watching it on XingMPEG player with the settings optimised for better performance at the expense of picture quality.

I got about 10 minutes in before the video locked up and I had to ctrl-alt-del to clear it.

Looks like my system gets indigestion when faced with such long streaming video files, and with copying large files from CD to hard drive (I suspect my success with this file was a fluke!).

It is only a P166MMX with 48Mb of ram, and it could be that a faster processor is needed to handle the vast amount of information from a VCD. It could also be that the CD-rom is not all that it could be, although in "normal" use it works fine.

I feel I'm left with little choice but to give JOOPV an "acceptable" rating (after all, we've not solved my problem) and give up any thoughts of watching long videos on my machine.

Thanks to all who tried to help.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Hello to users to the new age of computers. There are so many products to choose from nowadays that you maybe confused to understand which product is the correct product for you. Let me explain briefly what should be the idea product for your best n…
Upper back Pain: My back hurt for months. Upper back, mostly my neck, spine and across my shoulder blades. I was getting headaches too, that felt like they were caused by tension in my shoulders, but now I feel fine! I'm sharing this hoping someone…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now