Solved

URGENT HELP - No Security Device No tty

Posted on 1998-08-13
4
515 Views
Last Modified: 2013-12-06
All my users dropped off the system today.  Error message received was "No Security Device Found" "mesg: no tty".  However, if each user logged on as "root" they were able to access the system and continue working.  After shutdown and reboot...no change.  Immediately after mounting the filesystem during reboot, the following message appeared:  "auditd:error on open of read audit device"  I'm running SCO UNIX 3.2.4 V 5.  I've at a loss here.  I do know I don't want 64 users logged on as root.  Note:  when ps -ef |pg is used some of the users processes are displayed as <defunct>.  All passwords are lifetime.  
Thanks.
0
Comment
Question by:brando
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 2

Expert Comment

by:kellyjj
ID: 2009232
you may want to disable/enable those ports, as well as kill off those <defunct> processes.  when you do a ps -t....   do you get a getty? or logon? (which ever would be apporiate )
0
 

Author Comment

by:brando
ID: 2009233
Solution:  For some unknown reason, I lost permissions on /dev.  Chmod 777 on /dev worked.
0
 
LVL 1

Expert Comment

by:fredfan
ID: 2009234
Hi brando,

Don't think chmod 777 on /dev is a good move. Any fella can remove all your device files. I have a solution for HP-UX but not for SCO.

Will keep you inform once I found the solution for it.
0
 

Accepted Solution

by:
jlongo earned 100 total points
ID: 2009235
I got somethinfg that may help you, first run command integrity and see what it reports and then run authck -av this will check users database and fix any problems also if integrity reports some permissions problems it can be fixed with fixmog command but make sure to use proper swicthes and have a good backup before changing anything, for the switches on these commands just do man -a command-name and this will help you out I think this should work, lety me know how it goes.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question