[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

adduser problem

Posted on 1998-08-16
8
Medium Priority
?
191 Views
Last Modified: 2013-12-06
i tried useradd command and control-panel way to add user account but failed to login, though it looks new user is added to /etc/passwd file, the password part in that file is not encrypted. what is the problem? it is redhat 5.0
BTW, where is the file to change the machine name? it is still localhost.localdomain after i changed the /etc/HOSTS file.
0
Comment
Question by:smiley020999
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 

Expert Comment

by:Shockwave
ID: 1637790
Smiley,

When you use the 'User Configurator' under the control panel, you need to grab the arrow next to 'Encrypted password' and select 'change' from the list.  A dialog will pop up an you should enter the user's password in it (2 times).  It will only show **** instead of the actual password as it is typed.  After you enter the password the second time, select done and the encrypted version of the password will appear in the 'Encrypted password' field.

If you use the 'adduser' method, then you will need to do a
'passwd <username>' in order to set the user's password.

For your second question, I assume you are trying to set it in the HOSTNAME file in /etc?  This is probably being overwritten at boot by the parameters in /etc/sysconfig/network.  Try changing the hostname in network and I think that will fix your problem.

Cheers,

Shockwave
0
 

Author Comment

by:smiley020999
ID: 1637791
the answer didn't explain why the pass is not encrypted and why the 'useradd' command is not working.
0
 
LVL 1

Expert Comment

by:Sieger
ID: 1637792
adduser only adds user without the pasword I think.

if you doing it in control panel.  You should set passwords with the change option instead of original.  I couldn't get the original to work either.. maybe I don't understand what it does...
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Expert Comment

by:dima_sherman
ID: 1637793
Ok here we go try this:
Login as root and do:
$ adduser
It will ask all you need.
If it didn't help do:
pico /etc/passwd
Insert new user there without password.
and do:
$ passwd <newuser> (While you are root)
That all.
To change name try:
In:
/etc/motd
/etc/hosts
/etc/ppp ( i forgot, but im sure it's ppp directory if you're using PPP!).
0
 

Expert Comment

by:neewbie98
ID: 1637794
It's abit hard for you to  add user(Contro Panel...) in Red hat 5.0 cause It's a bug and should be fixed(pls check again in CD rom Red hat 5.0-Contest-Change password.....)you should try this way and I hope It will work:
#adduser bob
#passwd bob
After you added new user successfully,you can change finger information for bob
#chfn bob
...

P.S: you can still set passwd in Red hat with the change option.....
0
 

Author Comment

by:smiley020999
ID: 1637795
i tried adduser and then manually change password while as root. it's just not working the only time it's working is when i issue 'su' in root and in text mode(well in xterm) but if i do it at the beginning which is the xwindow login level(i set inittab at run level 5 as default) it never works.
i found red hat 5.0 is worse than older version, maybe more packages, but performance is bad. and slower
0
 

Author Comment

by:smiley020999
ID: 1637796
to change the name of machine, the /etc/hosts is not right and not working, /etc/motd has nothing to do with it(running only after login?)
i don't think /etc/ppp is the right place to control the machine name.

0
 
LVL 1

Accepted Solution

by:
pestilence earned 150 total points
ID: 1637797
to add a user simply type:
#adduser bob
and then
#passwd bob
remember! you have to be root!!!!
if it gives you an error message then delete the /etc/.pwd.lock file, this file locks your passwd file without letting you add any other users.
If you want shadow support then visit www.linux.org and read the appropriate HOWTO.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month13 days, 18 hours left to enroll

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question