Solved

Cannot Format the Hard Disk???

Posted on 1998-08-17
36
250 Views
Last Modified: 2010-04-27
I have been having problems running windows 95 since upgrading my machine from a 486 to a 233 pentium. I decided to format the hard disk and start again. I backed up  my important files and started formatting.
It got to 99 % complete and stopped, the message said not ready  - format terminated. I tryed to repartition my drive so that there was just a primary partition. But now when I try to even look at the c drive it doesnt register  and shows a invalid media type message.

HELP??
0
Comment
Question by:rds770
36 Comments
 

Author Comment

by:rds770
ID: 1009690
Edited text of question
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1009691
Try to do a format c: /u this is an unconditional format and will not try to save the unformat info, this may or may not work but it is worth a shot.  Is it always 99% when it stops or does it sometimes stop other places?  What steps have you taken so far?
0
 
LVL 2

Expert Comment

by:hboys
ID: 1009692
What are you using to format the disk?

i.e. is the win95 bootdisk or an old dos disk?
0
 

Author Comment

by:rds770
ID: 1009693
It always stops at 99%. I tryed Format c:/s but not c:/u. Ill try it. Ive tried both Windows startup and Dos to format it.
0
 

Expert Comment

by:ShootThemLater
ID: 1009694
See if you can go into BIOS and do a low-level format of the whole HD,  This will nix any partitions you have though...
0
 
LVL 1

Expert Comment

by:willemnel
ID: 1009695
The bios' i've seen lately does not have the low-level format option anymore. You can try to get hold of a low level format program from the manufacturer (via website) to do a low level format and partitioning for you. That was the only way I could get a Seagate disk to work recently. I think the Seagate program might work with other drives also...
0
 
LVL 6

Expert Comment

by:ckayter
ID: 1009696
Do you know what brand of HD you've got? I've found that most of the name brand mfg's offer formatting utilities at their websites. I keep stuff from Seagate, Western Digital, Maxtor, and Quantum in my emergency toolkit (I'm all over the map).
0
 

Author Comment

by:rds770
ID: 1009697
I have a Quantum HDD, but Im not sure which model. Do you think its a hardware problem or software?
0
 

Expert Comment

by:KAD
ID: 1009698
Be VERY careful doing a low level format with an IDE drive, as it can physically dammage the disk.
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1009699
It is possible that the drive is no good, but try some of the other suggestions first before getting the drive replaced under warranty if less then 3 yrs old.
0
 

Expert Comment

by:ShootThemLater
ID: 1009700
Quantum's OnTrack disk manager can be found at http://support.quantum.com/menus/soft_menu.htm.  I'd agree with the caution about doing anything low level with disks but I think that if you RTFM OK (I'm sure OnTrack is well documented), you'll be fine.  It's not as if you have any data to lose, right?  <g>
0
 
LVL 2

Expert Comment

by:wk51
ID: 1009701
Do you get the 99% problem also, if you make your partition smaller?
0
 

Author Comment

by:rds770
ID: 1009702
Ive had a look at the Quantum site. Downloaded a zero fill program which Ill try tonight. Ill also try that Ontrack disk.
0
 
LVL 2

Expert Comment

by:datn
ID: 1009703
Several points to remember
1) Did you do a true upgrade by replacing the CPU? You might need a newer BIOS that can really handle the new CPU.
2) The invalid media message is because the hard drive isn't formatted. Nothing to worry about yet.
3) What did you initially have in terms of partitions? How did you try to repartition? From a bootable floppy, you need to use FDISK to first delete all partitions and then to create a new primary one. Then you need to restart your computer with the bootable floppy and then "format c:/s" your C: drive. It sound like everybody here thinks you need to first use a Disk Manager since your hard drive is too big and not originally supported by your motherboard. Again, a new BIOS would fix this.
4) Give us more specifics about your computer, i.e, computer make and model, hard drive type and size, which OS exactly, etc. You can have a number a problems, ranging from old motherboard and BIOS or too big of a hard drive without LBA support or even wrong OS utilities being used.
5) Tell us what exactly do you want on your new setup. This could speed things up to give you a functioning computer.
0
 

Author Comment

by:rds770
ID: 1009704
The upgrade included a new motherboard and chip. The bios shows the presence of a hard disk but the command prompt wont show it's directory.
Windows 95 version A originally. 233 IBM chip and compatible motherboard. The hdd is 1038mb.
0
 
LVL 2

Expert Comment

by:datn
ID: 1009705
Since the BIOS shows your hard drive you should be fine. The command prompt not showing any directories is because you still have to correctly repartition and reformat your hard drive. A 1GB hard drive should not require a disk overlay program like Disk Manager with such a new motherboard and CPU.
I would try and find a friend with Win95 version B or newer, since the A version is the upgrade with a patch. Reinstalling that would take a lot of time since you would have to first install Win3.x, then Win95 upgrade, then the service pack.
0
 
LVL 2

Expert Comment

by:datn
ID: 1009706
The next time you try, do only "format c:". Restart your computer with the bootable floppy. Do a "dir" and it should find the C drive, but have no files. Then "sys c:"  from the a: prompt. Hope this helps.
0
 

Expert Comment

by:paddyq
ID: 1009707
Try this:

1. Boot up from a floppy disk that has fdisk on it
2. Run fdisk, delete all your partitions and repartition your HD
3. Reboot from the floppy disk again, format your HD again
4. I too would suggest going to your PC makers web site and checking to see if you require a BIOS upgrade. You can get your BIOS version at boot up.
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:rds770
ID: 1009708
Ive explained that the hard disk will not be formatted. Ive dwnloaded the Zero Fill program and will have to try it  later.
0
 

Expert Comment

by:kapoor
ID: 1009709
did you try format /mbr?
0
 
LVL 1

Expert Comment

by:FuzzyLogic
ID: 1009710
This may be trivial, but did you check that the BIOs parameters of your HD are correct? I don't meen that you do AutoDetect, but check the parameters that are writen on the HD itself. Sometimes, the AutoDetect doesn't give the right parameters.
0
 

Expert Comment

by:andre_heckmann
ID: 1009711
Check your bios.
In your HD configuration menu there should be the statement LBA. Check whether your HD is autodetected and configuered correctly. You should find the hardware specifications on the HD itself. If not you should ask your lokal dealer by giving him the serial id and the manufacturer. If the HD is not correctly configuered you may not be able to format it.

You may test to create a smaller partition to test whether a format always stopps at 99% regardless the size if the partition ?

GOOD LUCK
 
0
 

Expert Comment

by:Fredje
ID: 1009712
If you have disks of OS/2 then you can do practically everything with the tools fdisk (not from windows but from OS/2) you should be able to format your drive from there. You don't need to install OS/2 to use this tool, just start installing and break after the second disk. Then run fdisk from disk 2. Good Luck
0
 

Author Comment

by:rds770
ID: 1009713
I cannot even begin to install OS/2 becaus there is no where to install it to.
Do you think that the Zero Fill option will work??
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1009714
What choice do you have, if it does not work you are no worse off then you are now, and if it does work then you are ahead of the game.  Have you contacted Quantum about getting the drive replaced under warranty, I believe that your drive is going out.  They will send you one next day air if you secure it with credit card and you have a month to send the old one back before they charge your card.  I would consider this.
0
 
LVL 2

Expert Comment

by:wk51
ID: 1009715
you should try to format your disk with a smaller partition. If this works, the problem would be the inner part of magnetic surface. It can also be a problem of the surface where the system tries to write boot information after formatting.
0
 

Expert Comment

by:ShootThemLater
ID: 1009716
No offence, wk51, but you shouldn't have posted that as an answer because:
a) It's already been suggested.
b) It's hardly definitive - rds770 has a number of things to try by now.

Just my 2 cents/pence...
0
 

Author Comment

by:rds770
ID: 1009717
Thanks for the comments but Ive tried just about all I can except the Zero Fill program. If that doesn't work I think Ill have to buy a new HD because  I would imagine that the existing drive is over three years old.
Thanks for all your comments and suggestions. I'll let you know how I get on.  
0
 

Author Comment

by:rds770
ID: 1009718
Woohooo!!!!!!
I managed to sort it out. I used the Zero Fill program which worked 2nd time around. I then looked at the partitions. The original problem was at the end of the HDD. So instead of using 100% (1040mb) and making it the primary partition, I used 1000 mb instead which WORKED!!!
I have lost 40mb but at least it works.
Thanks again for all your help.
0
 
LVL 2

Expert Comment

by:datn
ID: 1009719
You should give the points to wk51 since your problem would have been fixed by creating a smaller partition, thus bypassing the bad sectors at the end. I would also follow wayneb's advice of getting a new drive. I had an old drive that worked fine until bad sectors started to appear. I got it working, but as time went on, it got more and more bad sectors, causing my system to crash here and there.
0
 

Author Comment

by:rds770
ID: 1009720
Ill give wk51 the points - tell me how. wk51 mentioned what the problem is caused by - could you tell me more?
0
 
LVL 8

Expert Comment

by:wayneb
ID: 1009721
Have wk51 resubmit his answer then accept his answer and award him the points by grading his answer.  The last portion of the drive is shot and you may soon lose the whole drive, I would replace the drive as soon as possible.
0
 
LVL 2

Expert Comment

by:datn
ID: 1009722
His first comment suggested for you to make your partitions smaller (Monday, August 17 1998 - 07:43AM PD) then reformatting.
He then answered on Tuesday, August 18 1998 - 05:33AM PDT ( which you rejected) to repartition your hard drive into smaller ones, because there could be surface area defects.
0
 
LVL 2

Expert Comment

by:datn
ID: 1009724
The solution was not to use a low level format program.

Zero Fill is not a low level format program.

According to Quantum:

"ZERO FILL is a DOS/Windows 95 command prompt utility created by Ontrack for Quantum and is used to remove all information from ATA / IDE hard disk drives. ZERO FILL will delete all data (partitions, folders, directories, files, file tables, boot record information) and viruses from the ATA / IDE Disk drive it has been run against. The ZERO FILL utility is included in the latest releases of Quantum's Ontrack Disk Manager program and due to popularity it is now provided as a self-contained program.

As the name implies, ZERO FILL will write a data pattern of all zeros to the hard drive media. ZERO FILL is NOT a low-level format utility and any use of a low-level formatter on a Quantum ATA / IDE drive may void your warranty. However, the ZERO FILL utility does provide the same benefit as a low-level formatter when run against the IDE/ATA drive. ZERO FILL only works properly on Quantum ATA / IDE hard disk drives. ZERO FILL cannot access drives that are not detected in the BIOS."
0
 
LVL 2

Accepted Solution

by:
wk51 earned 200 total points
ID: 1009726
Thank you rds770. Glad, that my hint helped you. You only need to accept my answer with one of the predefind evaluations, which meets your mind.
0
 

Expert Comment

by:kevincristo
ID: 1009727

If you are having disk manager or other hard disk utilities
then you can assign the bad sectors and you can leave the bad sectors.

Assume that you are having 500 mb HDD. Use fdisk and create
DOS Partition for 450 mb but you cant use the rest of 50 mb.


0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
This is about my first experience with programming Arduino.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now