• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 235
  • Last Modified:

Mask edit won't work

I have a masked edit control connected to a VB data control (which addresses a date field in an Access database). No matter what I set the .format property to on the mask edit control, the date always appears as mm/dd/yy ( I want it to be mm/dd/yyyy.  Is this control buggy or am I doing something wrong?
1 Solution
On way to correctly displayy mm/dd/yyyy in a masked edit control is to use the "ddddd" (5 d's) as the format value.

Second, you have to change the computer's short date format to include the century:

goto your control panel and double click on Regional Settings, then select the Date Tab, finally in the middle section "Short Date" read "mm/dd/yyyy".

This will then display the entire year in your masked edit box.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now