Solved

Win NT RRAS dialing into Linux running uugetty --> problems

Posted on 1998-08-19
4
261 Views
Last Modified: 2010-03-18
I have a Linux box running RedHat 4.0 with uugetty waiting for a connection via a modem.

When a Portmaster tries to connect, everything works fine.  The modem answers, the Portmaster follows it's script sending a username and password, and then starting pppd.

However, when I try to get a Win NT box running RRAS to establish a connection with the Linux box, it doesn't work.  I've tried various changes and scripts on the NT side, but basically what happens is:

The modem answers and then almost immediately the connection is dropped.  It appears that the login script I've defined for RRAS is never run.

I suspect that the RRAS is expecting something that uugetty is not sending.

Any ideas?
0
Comment
Question by:egrether
  • 2
4 Comments
 
LVL 1

Expert Comment

by:sioux
ID: 1586506
Probably your NT server sends Encrypted passwords.
You can disable this in RAS. Linux does not accept these encrypted passwords.
I believe the option is called 'require encrypted passwords' you should set this to
'any authentication allowed including plain text.

0
 

Author Comment

by:egrether
ID: 1586507
Thanks for your answer sioux, but we have already tried that option and unfortunately, it did not change the behaviour that we were seeing with RRAS.
0
 
LVL 2

Accepted Solution

by:
alexbik earned 30 total points
ID: 1586508
Why are you using uugetty?

Mgetty is much better for this purpose. It also supports loggin in without a script,
using PAP authentication. Just compile it with the Auto_PPP option.

It's much easier to setup at the client side than if you use another getty with a loginscript.
Users are still logged in utmp/wtmp.

If you like, I can mail you a pre compiled mgetty binary.

Alex
0
 

Author Comment

by:egrether
ID: 1586509
Alex, you got it!  Thanks!

One additional note for anyone interested in doing the same thing in the future:

The mgetty/RRAS combination appear to be using PAP for authentication, so
an /etc/ppp/pap-secrets entry must be set up for RRAS to authenticate against.
The entry which did the trick for us was * * SECRET where SECRET is the password supplied to NT in the Password box of the Set Credentials dialog.  HTH.

Ed
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Concerto provides fully managed cloud services and the expertise to provide an easy and reliable route to the cloud. Our best-in-class solutions help you address the toughest IT challenges, find new efficiencies and deliver the best application expe…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

943 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now