Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 304
  • Last Modified:

Outlook & DNS

I have a DHCP Server assigning IP leases to NT Workstations.  I added the option for ‘003 Router’ to the scope of my IP Address Pool so that clients were allocated a default gateway and could browse the Internet from their workstations.  Worked fine if they put an IP address for the web site they wish (i.e. 207.46.130.14) to view but not when using web site names (i.e. www.microsoft.com).

I added a ‘006 DNS Servers’ option to the scope with two IP addresses given to me by my ISP – this worked fine for clients and they could browse the web using correct web site names (i.e. www.microsoft.com).

However, clients/workstations are now experiencing long delays (up to 5 mins) when accessing their mails through Outlook 97 which are held on an Exchange 5.0 server.  As soon as the ‘DNS Servers’ option is removed from the DHCP server’s scope, clients no longer experience delays when entering Outlook.  Even with the DNS option removed from the server’s scope and added to a Workstation’s TCP/IP’s properties – the same problem occurs.  With no DNS specified, no lengthy delays.

Any help on why this is happening or how to prevent it would be much appreciated.

Thanks
0
omb
Asked:
omb
1 Solution
 
ktownsendCommented:
Are you running MS Proxy Server.
0
 
ombAuthor Commented:
No - just got an Exchange Server with an ISDN TA for it's connection to our ISP and a ISDN router which will be used for Workstation Internet browsing once I've sorted this DNS problem out.
0
 
mcixCommented:
We have had a similar problem...

Apparently, Exchange uses DNS (instead of WINS) to resolve names in certain situations. I have not been able to make it work consistently with Outlook 97.  

However, when I installed Outlook 98, the problem went away.  Go figure?

Anyway, check out the WINS settings as a starting point.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
TSauerCommented:
Your problem is related in the way Outlook resolves names. When you have entered a DNS Adress, it will use this information for resolving the name of the Exchange Server.
When you have entered the DNS of your ISP, there is no way to  enter the name of yr. exchange in the DNS, so you have to solve the problem different.
Try entering the name of your exchange server in the local host file, the connection should go faster, or change the settings for the Name Providers of your client.
You can do this in the regestry, the Key is HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Providers\RPC Binding Order
After doing this changes, you have to restart your computer to make this changes work
0
 
ombAuthor Commented:
Adding my Exchange server to local the 'host' file on each workstation worked just fine.

Thanks
0
 
ombAuthor Commented:
Adding my Exchange server to local the 'host' file on each workstation worked just fine.

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now