• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 861
  • Last Modified:

MechCommader problem

I just installed MechCommader but after i start the first mission it gives me this screen and shuts down.
                 **********
ASSERT (00000000 -  Frame Count wrong)
Address  : 0x00638B52
Location : No .PDB file found
File     : No .PDB file found

Stack
=====
0x0069DA7C Tree::render() +0x4C           H:\honorb\Object\tree.cpp(512)
0x0068F2CC ObjectQueueNode::render() +0xAC H:\honorb\Object\ObjQue.cpp(517)
0x0068EC25 ObjectQueue::render() +0x15    H:\honorb\Object\ObjQue.cpp(158)
0x006AF330 Camera::render() +0x170        H:\honorb\Camera\Camera.cpp(1801)
0x006B1275 CameraList::renderView() +0x55 H:\honorb\Camera\Camlist.cpp(505)
0x0072BF0B Scenario::render() +0x1B       H:\honorb\mission\Scenario.cpp(583)
0x006AD2BB viewWindow::display() +0x5B    H:\honorb\Camera\Camera.cpp(696)
0x00615DAB aHolderObject::display() +0x3B H:\honorb\gui\Asystem.cpp(6552)
0x006AD7B4 aMainWindow::display() +0x34   H:\honorb\Camera\Camera.cpp(865)
0x0061DDE7 UpdateDisplay() +0x177         H:\honorb\gui\updisp.cpp(397)
0x00613F24 aSystem::run() +0x104          H:\honorb\gui\Asystem.cpp(5375)
0x006109A1 RealWinMain() +0x311           H:\honorb\gui\Asystem.cpp(3072)
0x0075BE64 WinMain() +0x54                H:\honorb\rmain.cpp(45)
0x0075FEEF WinMainCRTStartup() +0x13F    

Machine Details
===============
Executable name           : C:\GAMES\MECHCOMMADER\MECHCMDR.EXE
Current time, date        : 16:38:51 Thursday 8/20/1998
Executable time, date     : 21:32:36 Tuesday 6/9/1998
User name                 : usual
Machine name              : CTX200
Processor                 : AuthenticAMD Pentium MMX
Operating system          : Windows 95
Version                   : 4.00.1111
Time since booted         : 0h 11m 2s
Physical memory           : 66,609,152 bytes  (63 Meg)
Available physical memory : 0 bytes  (0 Meg)
Swapfile size             : 869,367,808 bytes  (829 Meg)
Swapfile available        : 840,830,976 bytes  (801 Meg)
Virtual memory            : 2,143,289,344 bytes  (2044 Meg)
Available virtual memory  : 2,083,717,120 bytes  (1987 Meg)
Memory load               : 71%

PCI bus
=======
 S3 Inc. Trio64V2 DX/GX (Version 004) by S3, Dated 1- 3-1996

ISA bus
=======
Communications Port (COM2) (Version 1.0.00) by (Standard port types), Dated 8-24-1996
ES1868 Control Interface (Version 1.0.10) by ESS Technology, Inc., Dated 8- 1-1997
ES1868 Plug and Play AudioDrive (Version 1.0.10) by ESS Technology, Inc., Dated 8- 1-1997
Gameport Joystick (Version 1.0.10) by Microsoft, Dated 8-24-1996

DLL Version numbers
===================
amstream.dll  - Version 5.01.51.0207
quartz.dll    - Version 5.01.51.0207
devenum.dll   - Version 5.01.51.0207
dsound.dll    - Version 4.05.00.0155
dinput.dll    - Version 4.05.00.0155
d3dhalf.dll   - Version 4.05.00.0155
d3dim.dll     - Version 4.05.00.0155
ddraw.dll     - Version 4.05.00.0155
dplayx.dll    - Version 4.05.01.1583
dplay.dll     - Version 4.03.00.1096
ntdll.dll     - Version 4.00.950
rpcrt4.dll    - Version 4.71.1120
Ir50_32.dll   - Version R.5.04.15.2.39

Information returned by Game
============================

ScenarioTime: 001.39
ScenarioTurn: 11
MoverUpdateFreq: 000.00
TurretUpdateFreq: 000.00
WorldStateUpdateFreq: 000.00
WeaponFireUpdateFreq: 000.00
MissionAppName : MechCommander Release  Version: 1.0 Build RC2 P5 -- MIS0101
           ************************
What could be wrong here?
Any help would be apreciated.
0
Serg
Asked:
Serg
1 Solution
 
eschatarCommented:
You need to update your DirectX drivers.  You can find the latest drivers at Microsoft's site, but the game probably has them on the CD.  Look for a directx directory, and run setup.
0
 
SergAuthor Commented:
Well i re-installed DirectX and it didnt do that agian, however this time it gave me this message:

EXCEPTION (Access violation at 0x00771FA5)
Address  : 0x00771FA5
Location : VFX_shape_count() +0xA
File     : vfxa.asm(9419)

Any more ideas?
0
 
SergAuthor Commented:
I tryed DirectX 5.2 (comes with the game) -that didnt work
Then i got DirectX 6 which upgraded all the files to 4.06 and 4.08

Now my drivers are at 4.03 and 4.00 can that effect the game?
I tryed getting the upgrades for drivers too, but on DirX info screen they still show up as 4.03 and 4.00
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
kapoorCommented:
There is a patch for mc that fixes some problems at microprose support. Also are you running a cyrix chip?
0
 
SergAuthor Commented:
Yup i got the patch, not sure what chip i have though...
how do i check?
0
 
kapoorCommented:
Go to start / settings / control panel / system. if you are using a cyrix, it will show up as CyrixInstead in the processor. In older versions of win95 it will identify as a 486
0
 
SergAuthor Commented:
No it says AuthenticAMD now what?
0
 
MicroSeyedCommented:
You must to following steps :

1 - Defrage Your Hardisk with Optimizing it.
2 - Then Try to uninstall the program
3 - Install it again

If Doesn't Work this mean that the library files doesn't compatible with Windows 95 32 Bits

0
 
blood_angelCommented:
microseyed,
     Bullshit.

Serg,
     I have an AMD CPU too, and Mech Commander Runs fine         on My machine, Now These error messages do you get a           nasty blue screen? does anything else crash out? (explorer,        word, quake2) try changing your graphics card. (and drivers)
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now