RAS Logging automatically

When RAS authenticates the user who wants to log on to the NT network ,(of course he has a account in the NT network), a login dialogue appears which requests user's password (but I've pass the user's password in calling rasdial API). How can I get hold of the login dialogue in my program so as to pass the password to NT authentication and log onto tne network ? Any help is appreciated.
wuxieAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
fmismettiConnect With a Mentor Commented:
Create a Dial profile using the dial up, including phone number, DNS stuff and all.

Fill an structure RASDIALPARAMS, where szEntryName is the name of the dial up profile you created. Suply the fields szUserName and szPassword.

Call the Win32 function RasDial, passing your structure as parameter number 3.

After that, look for messages WM_RASDIALEVENT to determine the conection status.

Good luck.

0
 
wuxieAuthor Commented:
My question refers to logging  onto the NT network so that the remote user can use shared resource; I've tried RasDial API,but it doesn't log the user onto the network really in NT,except that  you manully fill the dialogue it calls for example, the  password. I want to find a way to get rid of the logon dialogue so I can control the logon instead of typing something while I'm logging so I can login automatically..  
0
 
fmismettiCommented:
In the configuration of the DialUp profile, in the server types tab you have a "Log on the network" check box. Turn this on. Also, turn on and configure all the protocols you want to use.

When RAS get connected, it applies all the options that you have setup in the profile (you pass the profile name in the RASDIALPARAMS.szEntryName field) and uses RASDIALPARAMS.szUserName RASDIALPARAMS.szPassword to log on the network.

I used this method in several configurations, and logging on to the network it was not a problem, accessing resources by TCP/IP or Netbeui. After the dial, I receive a message "RASCS_Authenticate" (begin of authentication) and after a few seconds, "RASCS_Authenticated" (authentication OK).

Hope it help you. If no, you can always reject the answer to see if someone has another way to do this.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.