?
Solved

Configuring BIOS for CD-ROM master

Posted on 1998-08-24
15
Medium Priority
?
326 Views
Last Modified: 2010-04-27
I have had serious Windows 95 problems and have to reinstall.  My new CD-ROM, made by Pioneer, no longer is recognized as I am operating in DOS.  The manufacturer's helpdesk tells me I have to reconfigure my BIOS in order to do so.  I have two hard drives running off an Award 450G, one set to primary master, the other to primary slave.  I was asked by the CD-ROM helpdesk to get the CD-ROM player set up as a secondary master but I have NO IDEA as how to do so.  Any ideas?
0
Comment
Question by:gazapo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +5
15 Comments
 
LVL 1

Expert Comment

by:genius2
ID: 1123743
do you have a diskette with driver for your cd-rom?
0
 
LVL 7

Expert Comment

by:cmcgee
ID: 1123744
There are a few things that you may need to do.

First check your Bios and make sure that you Primary and Secondary IDE channels are enabled.

Next Make sure that your jumper settings on your CD rom are set to master. If you have another device attached to the cable, it will need to be jumpered to Slave.

Make sure this cable is plugged into the Secondary IDE channel.

Since this is not recognised in DOS (You did not specify that this works in windows) you will need to make sure that your Config.sys and Autoexec.bat have the appropriate MSCDEX lines included.

If you have a driver diskette, install that. They are usually setup to add the proper info to your startup files.

Hope this helps,
Craig


0
 

Author Comment

by:gazapo
ID: 1123745
Craig,

I had already done all of that and I still can't get my CD-ROM to appear and get useful.

Genius2,

Yes, I do have a manufactures's diskette with drivers (the CD-ROM was purchased only a month ago).

Thanks.

Still CD-less and clueless.

0
Bringing Advanced Authentication to the SMB Market

WatchGuard announces the acquisition of advanced authentication provider, Datablink, with one mission – to bring secure authentication to SMB, mid-market, and distributed enterprises with a cloud-based solution, ideal for resale via their established channel & MSSP community.

 

Author Comment

by:gazapo
ID: 1123746
Good answer but it doesn't solve the problem.

I have to operate in DOS because Windows won't boot.  I have installed the drivers and they are mentioned in autoexec and config, but nothing happens.

This is a Hi-Val 24x CD-ROM.  They tell me that I have to reconfigure my BIOS to get it to work.

As this CD-ROM as well as my previous Sound Blaster model worked fine under PlugNPlay, I can't figure out why and how to change the 450G Award BIOS.


0
 
LVL 1

Expert Comment

by:genius2
ID: 1123747
to make your cd-rom visible in dos mode you have to edit your config.sys and autoexec.bat.
In config.sys you must load the (dos-)driver from your driver disk, in autoexec you must load mscdex.exe which you can found in your windows-directory.
the syntax for the options of your driver must be found in the manual (perhaps a txt-file on the driver-disk) of your cdrom. one option will be somethind like /d:<name>. this name must appear also as option in mscdex. The options for mscdex you can get with mscdex /?. Good luck.
0
 

Author Comment

by:gazapo
ID: 1123748
Thanks but it still doesn't work.


0
 

Expert Comment

by:ewilson
ID: 1123749
gazapo, would you mind posting your config.sys and autoexec.bat, there is no reason why you should have to set your CD as a master. also if all your drives were accessable before your crash then it is highly unlikely that your cmos reset itself unless your motherboard cmos reset jumper somehow was shorted or you had a power surge.

0
 
LVL 1

Expert Comment

by:derosa
ID: 1123750
Some drives come with an install that also configures the the way the driver is loaded in config.sys. If possible make sure the driver is loading using IRQ 15.
0
 

Expert Comment

by:ewilson
ID: 1123751
Ooops, completely slipped my mind but the last 2 or 3 PII motherboards i have built have all come with a warning that if you flash the bios for the U-DMA mode 3 you may experience difficulties accessing ATAPI devices. only one of the boards showed any problem and that was an inability to access my CD rom when booting to DOS. Is your motherboard capable of Ultra-DMA?
0
 

Author Comment

by:gazapo
ID: 1123752
Actually that may be the correct answer.  However, I don't know what a IRQ15 is, so it was communicated but not understood,  Sorry.

I will post my config.sys and autoexec.bat Thursday morning at 9:30 EST.  Thanks.
0
 

Author Comment

by:gazapo
ID: 1123753
I just typing in both my config.sys and autoexec.bat files (no cut and paste at the local library!).  To see them, please go to my question listed under Windows 95 general.  (I have a more complicated problem there.)  Thanks!!!
0
 
LVL 2

Expert Comment

by:jkjung
ID: 1123754
Um...why didn't you just specify the URL?  It's HARD to search for YOUR question.
0
 

Author Comment

by:gazapo
ID: 1123755
Sorry.  I finally fixed this problem thanks to the Hi-Val help desk.  They had me set up a diskette with just a shortened path to their cd-rom in autoexec.bat and it worked when I booted via the A drive.
0
 
LVL 1

Expert Comment

by:mlaiosa
ID: 1123756
You DO NOT need to configure the BIOS.  If you CD ever worked, then the BIOS is fine.

What you need to do is install dos drivers.
0
 
LVL 12

Accepted Solution

by:
Otta earned 20 total points
ID: 1123757
> The manufacturer's helpdesk tells me I have to reconfigure
> my BIOS in order to do so. I have two hard drives running
> off an Award 450G, one set to primary master, the other
> to primary slave. I was asked by the CD-ROM helpdesk to
> get the CD-ROM player set up as a secondary master but I
> have NO IDEA as how to do so. Any ideas?

You don't have to reconfigure your BIOS;
you do have to reconfigure your hardware.
Fortunately, the BIOS will auto-detect the changes you make.

Hopefully, your motherboard has *TWO* IDE-ports.
The first one is the "primary",
and the second one is the "secondary".
Each IDE-port can handle one or two IDE devices.
So, they want you to connect both hard-drives
to the "primary" IDE-cable, and to connect only
the CD-ROM to the "secondary" IDE-cable.
Since you have two devices on one channel,
the jumper-switches on each of the 3 devices must be set
to indicate which device is "master" on the channel,
and that the other device is "slave" on the channel.
So, set the jumpers on each hard-drive.
Set the jumpers on the CD-ROM as "master-as-only-device"
(or alternatively as "master") on its channel.
Then, reconnect the power-cord, and reboot.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
pc, laptop  monitor connection configurations
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question