[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

diald keeps dialing...

Posted on 1998-08-24
8
Medium Priority
?
369 Views
Last Modified: 2010-03-18
I've set up diald from the rpm diald-0_16_5-201_i386.rpm on a RH 5.0 system. It seems to work just fine except after the
connection is droped it will immediately dial back out and
continues to do this.  If I use the diald command "diald-off" and then issue the command "diald-on".  The system will not dial out until it specifically sees a packet to force a dial-out, but once it does, it continually dials
out and connects.  Do you have any ideas how I might get this to stop occurring?  Thanks for your time in advance.
0
Comment
Question by:pmalinow
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
8 Comments
 

Author Comment

by:pmalinow
ID: 1586539
Edited text of question
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1586540
you need to move diald.conf to /etc/diald and remove connect from /etc/diald
0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1586541
Can you post your diald.conf  there are some setings that you need to add or change to stop diald form redialing
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:pmalinow
ID: 1586542
If I remove the connect script from /etc/diald then where does it
get the phone number and login information it needs to dial and
connect.  I have not made any modifications to the stock distri-
dution except of course to the connect script inputting the phone
number of the machine I am trying to reach and the login info.
I recently discovered that the remote machine being dialed is the
one terminating the connection after not seeing any IP traffic.
Therefore I am now looking into making the disconnect time
shorter on the diald machine.

As requested I am inclulding a copy of my diald.conf file:

device /dev/cua1
speed 38400
lock
mode ppp dynamic
local 10.0.0.1
remote 10.0.0.2
pppd-options name anappp :  up-delay 5
defaultroute
modem
crtscts
connect /etc/diald/connect
redial-timeout 10
fifo /etc/diald/diald.ctl


0
 
LVL 5

Expert Comment

by:JBURGHARDT
ID: 1586543
First step is to resolve ppp problem use minicom to logon to your ISP then write down all steps you need to get to internet like password login any options. I had the same problem  and my ISP changeg from host login  to login and your script is incorrect check this firs
0
 

Expert Comment

by:buzh
ID: 1586544
dump diald. Try using pppd and chat.. I don't know the details of your isp, but assuming it doesn't use pap/chap the following should work..

Make a file with the following in it, and do a chmod +x filename to make it executable

pppd /dev/modem 38400 connect "chat -f dialerscriptfilename" accept-ipcp-local accept-ipcp-remote crtscts modem

then, you need a script to dial.. in this example, call it dialerscriptfilename and put the following in it..

""
ATZ
OK
ATDT[ISP PHONE NUMBER]
CONNECT

if your isp uses pap or chap, just ask.
I could start ranting about how redhat makes linux users too dumb to figure out things like this on their own, but I wont. ;)
0
 

Expert Comment

by:buzh
ID: 1586545
btw.. to disconnect, just press the hangup/voice/data/whatever button, or make a script that kills pppd.
for example, you could do this:

$echo "killall pppd" >> disconnect
$chmod +x disconnect

then, you just have to run ./disconnect to take down the link.
0
 

Accepted Solution

by:
brunovan earned 100 total points
ID: 1586546
You don't seem to have any filters in your diald.conf file. In other words there is nothing to tell diald how long you want to stay connected if there is no traffic. Include the standard.filter file to your diald.conf

include /usr/lib/diald/standard.filter

If you would like read the standard.filter file. It has a lot of good comments to explain what it is doing.

Bruno
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question