Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Can't open perl script: ????????? Invalid argument

Posted on 1998-08-25
5
Medium Priority
?
2,652 Views
Last Modified: 2011-09-20
when i try to execute a perl script on iis4.0 and NT4.0 ws i get the following answer:

Can't open perl script: ????????? Invalid argument

What am i doing wrong?

When i execute a perl scrip direct from the commandline everything works fine!

Thanx in advance.
0
Comment
Question by:thommy1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 

Expert Comment

by:gre
ID: 1204533
give some more info about the script.
are you passing it arguments?
are the file permissions set correctly?
do you have IIS map the .pl extension?
0
 

Author Comment

by:thommy1
ID: 1204534
The script is the example from Microsofts Knowledge Base:

print "HTTP/1.0 200 OK\n"; print "Content-Type: text/html\n\n";

print "<HTML>\n"; print "<HEAD>\n"; print "<TITLE>Hello World</TITLE>\n"; print "</HEAD>\n"; print "<BODY>\n"; print "<H4>Hello World</H4>\n"; print "<P>\n"; print "Your IP Address is $ENV{REMOTE_ADDR}.\n"; print "<P>"; print "<H5>Have a nice day</H5>\n"; print "</BODY>\n"; print "</HTML>\n";

i have maped HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ services\W3SVC\Parameters\ScriptMap

permissions are set for the complete directory.

0
 

Expert Comment

by:gre
ID: 1204535
I would make sure that the directory is mapped to a .pl
( I am assuming this is a .pl script)
in IIS Service Manager highlight 'Default Web Site'
go to the 'Action' pull down menu and click on 'Properties'
then click on the tab that says 'Home Directory'
click the button towards the bottom right 'Configuration'
you will now see a list of extensions and thier exe path.
check to make sure the .pl extension is in there.
if not you can add it:

pl      c:\your path to Perl exe...\Perl.exe %s %s


0
 

Author Comment

by:thommy1
ID: 1204536
Yes, now it works fine!

I've got the newest release from ActiveState Perl, and there the IIS is configured automatically.

It has done exactly the same changes as you told me.

Thanks again.
0
 

Accepted Solution

by:
gre earned 30 total points
ID: 1204537
Glad to hear it's all working now.
I just got IIS myself a couple days ago and am now having problem with SSI's.

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many time we need to work with multiple files all together. If its windows system then we can use some GUI based editor to accomplish our task. But what if you are on putty or have only CLI(Command Line Interface) as an option to  edit your files. I…
I have been pestered over the years to produce and distribute regular data extracts, and often the request have explicitly requested the data be emailed as an Excel attachement; specifically Excel, as it appears: CSV files confuse (no Red or Green h…
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
Six Sigma Control Plans

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question