Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Stupid PPP question??

Posted on 1998-08-25
3
Medium Priority
?
313 Views
Last Modified: 2010-03-18
I recently installed RedHat 5.1. I have a Cirrus Logic 33.6 PNP modem. With X-Windows, I set up a PPP connection to my ISP, it dials up the number, waits a few minutes, then my modem clicks like it disconnected and I can't get a connection. Does anyone know why this is? My friend said it's not my modem because if it was, I wouldn't be able to dial up.
0
Comment
Question by:cooper14
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 2

Expert Comment

by:JYoungman
ID: 1586547
Put
      DEBUG=yes
in /etc/sysconfig/network-scripts/ifcfg-ppp0.
Attempt to dial up again.  Then look in /var/log/messages.

PS: It's "X" or "The X Window System", but not "X Windows".  See "man X" for more information.
0
 
LVL 1

Accepted Solution

by:
pestilence earned 400 total points
ID: 1586548
First of all either if you use x-windows or command prompt only do the following:
First of all make sure you have installed ppp support...then

1) go to /etc/ppp and edit the "options" file there (vi options), here you must add the following lines:
modem /dev/cua1 (cua1 stands for com2 and cua0 for com1)
defaultroute
crtcts
2) now edit the file /etc/resolv.conf to point to the correct nameservers,
for instance
domain ns1.otenet.gr
nameserver ip.address.of.n1.otenet.gr
3) launch "minicom" (did you know that ezppp is also available for Linux, it simulates windows95 dial-up networking and works great for x-windows only)
4)call your isp and hook up to him
5) press ctrl+q
6)answer yes to the question "exit without reseting"
7)run as root:
root#] pppd
8)to make sure do a ifconfig -i and see if there is a device called ppp0
if there is you are ready.
If you are connected and you cant resolve the names of hosts then the problem will be spotted in /etc/resolv.conf file, it means your nameserver entry isn't correct.

0
 

Author Comment

by:cooper14
ID: 1586549
Thanks guyz.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question