Solved

LPT WIN95 conflicting with DOS

Posted on 1998-08-27
14
204 Views
Last Modified: 2013-12-16
I currently use some DOS applications under WIN95 that use the LPT port.  The problem is that WIN95 interrupts with a dialog box asking whether WIN95 or DOS should have the port. How can I configure WIN95 so it does not interrupt DOS using the LPT port?
0
Comment
Question by:charltonlewis
  • 5
  • 3
  • 2
  • +3
14 Comments
 
LVL 3

Expert Comment

by:varun071898
ID: 1757972
Go to the printers folder in My Computer. Right Click any printer and click properties.
Go to the details tab. Now click Port Settings. Uncheck spool
MS-DOS Print jobs.
0
 

Author Comment

by:charltonlewis
ID: 1757973
When I select the port settings button a error message stating 'there is nothing to configure for this report'.

The printer driver being used is for a network HP LJ6P.

The LPT port is NOT being used for printing.  It is being used for PROM programming and parrallel downloading to target boards.

Thanks anyway.
0
 
LVL 17

Expert Comment

by:mikecr
ID: 1757974
Since it sounds like your computer is mapped to a network printer, then you need to go into the details tab where you were at before and hit the capture button and capture LPT1 to whatever your printer name is. Then you'll be able to print in Dos without a problem. Let me know if you need any more help.

Good Luck!
Mike
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 

Author Comment

by:charltonlewis
ID: 1757975
Just to restate. I DO NOT want to print from the LPT port( see previous comments). One of the machines that has this LPT problem has never been configured to have a printer of any kind. In fact it is a clean Win95 installation that is used as an AS400 terminal and for programming EPROMS.

Thanks for the help so far.
0
 
LVL 3

Expert Comment

by:varun071898
ID: 1757976
Another idea, go to device manager, click LPT1. Check disable this in this profile. Then restart and try out.
0
 
LVL 3

Expert Comment

by:varun071898
ID: 1757977
Another idea, go to device manager, click LPT1. Check disable this in this profile. Then restart and try out.




Take this as answer and grade this.
0
 
LVL 17

Expert Comment

by:mikecr
ID: 1757978
Again you have to capture an LPT port under Windows to be able to print Dos programs to it.

Mike
0
 

Author Comment

by:charltonlewis
ID: 1757979
The disabling LPT1 idea did not work, but thanks for the effort.  Still have not resolved the problem tho, so any other ideas.  
0
 
LVL 1

Expert Comment

by:daverolfe
ID: 1757980
How about in the properties of the shortcut to your dos program (if you have a shortcut) going to the program tab, pressing advanced and ticking "prevent MSDOS programs from detecting windows"

Best of luck
Dave Rolfe
0
 

Author Comment

by:charltonlewis
ID: 1757981
RE daverolfe. I have set 'prevent MSDOS programs from detecting windows' but it makes no difference.  Thanks for the suggestion tho.
0
 
LVL 7

Expert Comment

by:MATTCEI
ID: 1757982
On all systems with this problem that DO use a printer,I'm reading from the above comments that it's a network printer.Therefore none of these systems has LPT1 in the "Print to the following port" box in Printer-Properties-Details.(If this is not true,please let me know).

SO: ADD a fake printer - any simple printer,like "Generic/Text only",and tell Windows it's on LPT1.Then in Properties-Details-Port Settings,clear the "Check Port State Before Printing" box.
0
 

Expert Comment

by:davidellis
ID: 1757983
Some HP printer installations leave cause a program to be loaded at startup which sits and polls the LPT port.  I cant remember exactly what it is called but it begins with hp I think.  Stop this from starting up and everything should be ok.
0
 

Author Comment

by:charltonlewis
ID: 1757984
RE MATTCEI's answer. Somenbody has now installed the HP laserjet drivers on the machine which previously did not have any printer drivers.  When I selected the port settings option a dialog box stating 'There is nothing to configure for this port' was displayed.
0
 

Accepted Solution

by:
davidellis earned 70 total points
ID: 1757985
RE my previous comment. Try this.

Some HP printer installations leave cause a program to be loaded at startup which sits and polls the LPT port.  I cant remember exactly what it is called but it begins with hp I think.  Stop this from starting up and everything should be ok.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Problem to App source 6 72
How to set IPSec under Server 2008 R2 and Server 2012 R2 3 43
Password manager for small company 3 33
Windows icons complete gone 8 30
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
Learn how to PXE Boot both BIOS & UEFI machines with DHCP Policies and Custom Vendor Classes
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question