Linux upgrade on RedHat 5.0

I recently installed Redhat 5.0 on my pentium machine. I would not recognize my FAT32 dos partitions (Win98). I was told to install a kernel updat rpm to solve this problem. I did install it successfully and changed my /etc/conf file to load ther newest version (2.0.35-2)

Any suggestions?
rutledgjAsked:
Who is Participating?
 
marcelofrConnect With a Mentor Commented:
upgrade to mount-2.7l-3

Good luck
0
 
JYoungmanCommented:
Make sure you followed the instructions in the Red Hat Linux 5.0 Errata document.  Then run
      /sbin/lilo
and reboot your machine with "shutdown -r now && exit".
0
 
joe_massiminoCommented:
If you are using LBA you may not be able to use Lilo.  Try turning off LBA and see what you get there.   You will not do anyhtimg to the HD with this, if you can not boot, just put it back.  I removed it and everything worked fine.  Just a thought.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
laeuchliCommented:
Well I don't know about red hat but on slakware I needed to upgrade my kernal before I could install on a fat32 partions. I think red hat has issued a new version, maybe you should upgrade your kernal.

0
 
rutledgjAuthor Commented:
As stated in my original question, I have loaded the Redhat upgrade rpm which updated my
kernel to version 2.0.35-2. I also tried changing HD modes to non LBA--no help.
Lilo works fine as far as booting up. It sees the new kernel. It just can't see the DATA on the FAT32 Drives. I can access the drive but can't see the data on it. The "ls" command gives me nothing.
0
 
joe_massiminoCommented:
I have Red Hat 5.1 coming in today. I will install it on a second partition along with Win98 Fat32 on the primary. I'll let you know what happens.
0
 
vxCommented:
Try mounting your drive with the following command:
mount /dev/<whatever> /mnt -t vfat

Maybe this'll work

Ties
0
All Courses

From novice to tech pro — start learning today.